upgrading from beta 1

Dragonfly integration forum

upgrading from beta 1

Postby aalwein » Thu Sep 14, 2006 1:09 am

Ok I'm trying to upgrade from beta 1 to beta 2. The current roster works great but I want to get in on these "fixes" to make UU work and it seems I'm going to need beta 2. What do I need to do to update?

BTW, I already tried to upload a fresh set of files to a new directory, ran thru Rottgutt's instructions (see below) and the new roster is not working. It never asked me to enter the server information anywhere, btw, nor did it create a conf.php file when I clicked install from the modules menu. It said it installed properly but when I click on the wowrosterdf menu item, i go to a DF page saying "A database error has occured. The webmaster has been notified."

Here's the instructions I followed:

1) Completely remove ALL the WoWRoster files from your server.
2) Make sure you have the CORRECT version of WoWRosterDF, as it is CMS specific. You want: www.wowroster.net/Down...id=17.html
3) Upload the files to your server, following the correct folder structure. You do not need to CHMOD anything.
4) Log into your site as the Administrator.
5) Browse to the "Modules" section of the Admin page.
6) Find WoWRosterDF in the list of Modules you have on your site.
7) Click the word "Install" on the right side of the line.
8) Configure WoWRosterDF to your specifications.
Last edited by aalwein on Thu Sep 14, 2006 1:10 am, edited 1 time in total.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

upgrading from beta 1

Postby aalwein » Thu Sep 14, 2006 1:36 am

Well after starting over again, I got a little further. Now it comes up with a white screen with the conf.php variable written out on the screen and a link under all that that leads to the root\install.php labelled INSTALL.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Re: upgrading from beta 1

Postby RottGutt » Thu Sep 14, 2006 1:52 am

This probably goes without saying, but after you installed DragonFly, you MUST make sure that you delete the INSTALL folder and the file install.php. I have had problems with certain things in the CMS not working correctly if this folder and file were not deleted immediately after a DragonFly installation.

Also, if you did a clean install of WoWRosterDF, then you probably should have first edited your site's database to delete the old WoWRosterDF tables, then trying the fresh install.
Last edited by RottGutt on Thu Sep 14, 2006 1:55 am, edited 2 times in total.
RottGutt
WR.net Journeyman
WR.net Journeyman
 
Posts: 92
Joined: Sun Aug 13, 2006 12:07 am

upgrading from beta 1

Postby aalwein » Fri Sep 15, 2006 8:57 pm

That's the only way? I guess it's not too bad to have to re-upload all the character data again, especially with UU working, but thats still alot of data loss. I hope there is an easier way to "upgrade" the roster in the future without losing the data.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

upgrading from beta 1

Postby aalwein » Fri Sep 15, 2006 9:07 pm

ok, well I realized that when I installed the beta 1 roster, I renamed the folder to wowroster instead of wowrosterdf, so I should be able to install the one with wowrosterdf without removing the old one. So i deleted all tables with the DF designation and reran installation, and still get the same error:

"$eqdkp_prefix = "cms_eqdkp_"; $eqdkp_db = "******"; $eqdkp_password = "******"; $eqdkp_user = "******"; $eqdkp_host = "localhost"; $roster_host = '******'; $roster_user = '******'; $roster_password = '******'; $roster_db = '******'; $db_host = "localhost"; $db_name = "******"; $db_user = "******"; $db_passwd = "******"; $db_prefix = $prefix.'_'.strtolower($module_name).'_roster_'; define('ROSTER_INSTALLED', true); ?>
Roster is not installed"

Am I supposed to MANUALLY edit the conf file to have the correct variables? the conf.php file is CHMODed 777
Last edited by aalwein on Fri Sep 15, 2006 9:08 pm, edited 1 time in total.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

upgrading from beta 1

Postby Anaxent » Sat Sep 16, 2006 7:40 am

To do the installation you would do this from in the admin > modules control panel you should not have to edit any files at all to allow this to work.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

upgrading from beta 1

Postby aalwein » Mon Sep 25, 2006 2:05 pm

If I wanted to have two rosters use one database file, what would I have to do? Would I just edit the conf file and change the "prefix" variable?
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm


Return to Dragonfly

Who is online

Users browsing this forum: No registered users and 0 guests

cron