UU 2.5.0 Beta 1

Support and feedback for UniUploader
UniUploader requires microsoft .net runtimes!

UU 2.5.0 Beta 1

Postby MattM » Wed Sep 20, 2006 8:56 pm

This is a continuation of the "Release Candidate" releases ( I should have named them beta in the first place but whatever)

changes (not including previous 2.5 Release Candidates / betas changes):

new shiny icon
now saves/retrieves the selected account properly

notes:
optionality of addons doesn't work with uniadmin version < 0.7.0
uniadmin bug (blah.php?foo=bar) remains when using uniadmin version < 0.7.0

other notes: exe file in bin folder, delete ini file before running it
Attachments
uniuploader_v2.5.0beta1_update_v1.4.4_source.rar
2.5.0 Beta 1
(867.69 KiB) Downloaded 79 times
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

UU 2.5.0 Beta 1

Postby AnthonyB » Thu Sep 21, 2006 4:31 pm

Feedback having extracted \bin contents into a directory and ran UniUploader.exe

1. Default user Agent string is "UniUploader 2.0 (UU 2.4.1; English)" rather than "UniUploader 2.0 (UU 2.5.0; English)"

2. About tab still shows version as 2.4.1

3. The Tabs order seems really weird and unintuitive now that I actually stop to think about it.

Currently: Settings, Server Response, Updater, Help, Options, Debugger, Advanced, About
Suggested: Settings, Updater, Options, Advanced, Server Response, Debugger, Help, About

4. AUTODETECTWOW setting not being picked up from UniAdmin 0.7.0. By default it is off. I've turned it on in UA but UU fails to change the setting. Looking at the Debugger log the setting does appear to be being pulled down correctly as evidenced by the existence of "AUTODETECTWOW[=]1".

5. Ditto above for the USELAUNCHER setting. "USELAUNCHER[=]1"
Last edited by AnthonyB on Thu Sep 21, 2006 4:37 pm, edited 1 time in total.
Roster 2.0.2 svn [latest] latest trunk SVN svn [latest] running on IIS7/Windows Server 2008 SP2 | MySQL 5.0.85 | PHP 5.2.10 | Yes, Roster and PHP rocks on IIS! Even run as FastCGI extension!
User avatar
AnthonyB
Gimpy Developer
Gimpy Developer
 
Posts: 346
Joined: Tue Jul 04, 2006 2:44 pm
Location: Sydney, Australia

Re: UU 2.5.0 Beta 1

Postby MattM » Thu Sep 21, 2006 6:35 pm

Excellent observations, I will investigate the settings problems and reorder the tabs.

The version being displayed as 2.4.1 is intended, as I will change it to 2.5.0 when I release the final 2.5.0

the reason for this is so that UU doesn't downgrade itself back to 2.4.1 from 2.5.0beta because the update system wont have the 2.5.0 in it until i release the final 2.5.0
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

UU 2.5.0 Beta 1

Postby MattM » Fri Sep 22, 2006 8:28 pm

HAS ANYONE been able to update their character while playing wow with this version of UU?

This is the only thing holding me back from releasing 2.5.0
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

UU 2.5.0 Beta 1

Postby AnthonyB » Sat Sep 23, 2006 8:11 am

You mean by doing a force reload in-game? I did with this version from memory and it worked fine.

I test again with the beta 2 and confirm in that thread.
Roster 2.0.2 svn [latest] latest trunk SVN svn [latest] running on IIS7/Windows Server 2008 SP2 | MySQL 5.0.85 | PHP 5.2.10 | Yes, Roster and PHP rocks on IIS! Even run as FastCGI extension!
User avatar
AnthonyB
Gimpy Developer
Gimpy Developer
 
Posts: 346
Joined: Tue Jul 04, 2006 2:44 pm
Location: Sydney, Australia


Return to UniUploader

Who is online

Users browsing this forum: No registered users and 0 guests

cron