Problems in a mixed languages environment

Addon that shows the maximum statistics possible

Moderator: Exerladan

Problems in a mixed languages environment

Postby Snipes » Thu Sep 21, 2006 4:09 am

Hi there,

I am a big fan of the roster and all the marvellous addons that are released. Unfortunately I have a strange problem with the max. resist addon:
we are a German guild but our members use a mixed language environment. Some people don't like the German localisation (for a reason) and play the enGB-client (like myself). If you take a look at http://www.vaeter-der-horde.de/roster/a ... ame=maxres all seems fine and the calculated values are correct. But the per character display only works for deDE and not for enGB?! Take a look at my character (Snipes) and e.g. Sharkeem (who uses the deDE-client).

Unfortunately I have no idea why this is happening, but maybe someone here has a good guess :D
User avatar
Snipes
WR.net Apprentice
WR.net Apprentice
 
Posts: 20
Joined: Wed Jul 05, 2006 7:22 pm

Problems in a mixed languages environment

Postby zanix » Thu Sep 21, 2006 7:43 am

You need localization for enGB

You should be able to just copy the enUS locale and rename every instance of 'enUS' to 'enGB'
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Problems in a mixed languages environment

Postby Snipes » Thu Sep 21, 2006 5:05 pm

Mmmh, sorry I gave some wrong information. According to the CharacterProfiler.lua the client uses enUS locale (it seems that there is no enGB locale :oops: ). The roster main language is set to deDE. Setting it to enUS fixes the problem?! Is there any way I can misconfigure the addon itself? Could this be a problem with the update triggers?
Last edited by Snipes on Thu Sep 21, 2006 5:06 pm, edited 1 time in total.
User avatar
Snipes
WR.net Apprentice
WR.net Apprentice
 
Posts: 20
Joined: Wed Jul 05, 2006 7:22 pm

Problems in a mixed languages environment

Postby zanix » Thu Sep 21, 2006 5:32 pm

It's probably the addon itself in this case
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Problems in a mixed languages environment

Postby Diska » Fri Sep 29, 2006 3:51 pm

There are several localisation problems, and the only real solution would be a complete rewrite of the addon as has already been stated in other threads.

Looking at your website though, I don't see the problem you are describing. Did you manage to fix it yourself?
The only problem I currently see at your character is that the keyring is filled in with empty slots. That bug has been fixed with 3.09 which I just released.
User avatar
Diska
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 179
Joined: Tue Jul 04, 2006 2:05 pm


Return to Max Stats

Who is online

Users browsing this forum: No registered users and 0 guests

cron