401 in UniUploader with Apache basic auth

Support and feedback for UniUploader
UniUploader requires microsoft .net runtimes!

401 in UniUploader with Apache basic auth

Postby thantous » Thu Sep 21, 2006 10:52 pm

Hello,

First off, thanks for making this sweet system.

I tried looking through the forms and google but was unable to find any reference to a similar issue.

I have a pretty simple setup. UniAdmin and the Roster are on the same server. UniAdmin is open and the Roster is behind basic Apache auth. The problem I am having is that when I try to upload my profile, UniUploader shows a 401 (Unauthorized) in the Debugger window. I verified that my user/password are correct and that the primary url is correct. Also, in the debugger window I'm not seeing it send the user/password info. When I syncronize with UniAdmin, it is displaying the user/pass info in the debugger window.

I have my username/password entered under the "options" tab, along with keeping the password secure checked (I tried with and without).

Other relevant info:

I'm using the most recent versions of UniAdmin, UniUploader, and the Roster.

I removed the basic Apache auth as was able to upload with UniUploader.

I've tried both simple and advanced interfaces.

I am able to "syncronize" with UniAdmin (not behind any auth).

I am not running phpbb.

I tried to re-install UniUploader, as well as deleted the settings.ini file.

I'm running Windows XP (completely patched, Service Pack 2)

Any help would be greatly appreciated,
Thanks.
thantous
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Thu Sep 21, 2006 10:35 pm

401 in UniUploader with Apache basic auth

Postby MattM » Fri Sep 22, 2006 8:04 am

UU doesn't support Basic or Digest HTTP authentication
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

Re: 401 in UniUploader with Apache basic auth

Postby thantous » Fri Sep 22, 2006 8:22 am

Matt_Miller wrote:UU doesn't support Basic or Digest HTTP authentication


From the wiki:

If the directory that you are uploading to requires basic HTTP authentication set by a .htaccess file, then fill in the settings for HTTP Credentials, found in the Options tab.

Is that why I can't find the "HTTP Credentials" setting?
thantous
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Thu Sep 21, 2006 10:35 pm

401 in UniUploader with Apache basic auth

Postby MattM » Fri Sep 22, 2006 7:19 pm

I dabbled in the HTTP authentication back in the beta days, but it wasn't working. This feature hasn't really been in demand so I took it out before version 1.
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA


Return to UniUploader

Who is online

Users browsing this forum: No registered users and 0 guests

cron