Warning: array_keys(): The first argument should be an array

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

Warning: array_keys(): The first argument should be an array

Postby johnymac2 » Sun Oct 08, 2006 8:47 pm

So, I should assume that:
Code: Select all
Warning: array_keys(): The first argument should be an array in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: Invalid argument supplied for foreach() in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: array_keys(): The first argument should be an array in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: Invalid argument supplied for foreach() in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: array_keys(): The first argument should be an array in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: Invalid argument supplied for foreach() in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: array_keys(): The first argument should be an array in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: Invalid argument supplied for foreach() in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 845

Warning: array_keys(): The first argument should be an array in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 937

Warning: Invalid argument supplied for foreach() in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 937

Warning: array_keys(): The first argument should be an array in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 937

Warning: Invalid argument supplied for foreach() in /home/content/h/e/a/heartlabwow/html/roster/lib/wowdb.php on line 937



Is the same issue as reported?
User avatar
johnymac2
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Sun Oct 08, 2006 8:22 pm

Warning: array_keys(): The first argument should be an array

Postby yamyam » Sun Oct 08, 2006 9:31 pm

Yes, and there seem not to be any fix for it until yet.
and patch 1.12 is out a while :(

Help anyone?
yamyam
WR.net Apprentice
WR.net Apprentice
 
Posts: 37
Joined: Sun Jul 16, 2006 4:11 am

Re: Warning: array_keys(): The first argument should be an a

Postby Stadler » Thu Oct 12, 2006 12:26 am

Could someone attach an unified-diff file, that I could apply on the console? Or an updated wowdb.php? That would be really nice :-)

Regards,
Christian Stadler
Stadler
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Thu Sep 28, 2006 1:22 pm

Re: Warning: array_keys(): The first argument should be an a

Postby Freydis » Mon Oct 16, 2006 11:32 pm

Warning: array_keys(): The first argument should be an array in /home/sdbra2/public_html/roster/lib/wowdb.php on line 937

Warning: Invalid argument supplied for foreach() in /home/sdbra2/public_html/roster/lib/wowdb.php on line 937

I'm obviously having the same problem. However, the characters are updating, but not the Guild information. (i.e. updated guild info, updated rank in the guild and levels of those players who do not use the individual characterprofiler.)
Freydis
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Thu Jul 13, 2006 7:47 pm

Warning: array_keys(): The first argument should be an array

Postby yamyam » Tue Oct 17, 2006 11:31 am

Still noone knows how to fix it or get this done? :/
yamyam
WR.net Apprentice
WR.net Apprentice
 
Posts: 37
Joined: Sun Jul 16, 2006 4:11 am

Warning: array_keys(): The first argument should be an array

Postby NRK7 » Tue Oct 17, 2006 5:24 pm

I dunno if it's a fix but i cleared SVs from UU and it stopped giving me the same error...
I don't know if I'm going to have same problem again as I did it yesterday and updated the roster just once...
NRK7
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Fri Jul 07, 2006 8:31 pm

Warning: array_keys(): The first argument should be an array

Postby PleegWat » Tue Oct 17, 2006 5:57 pm

This error should go away if you apply the fix I posted earlier this thread. Freydis, your guild update problem probably isn't related to the errors. Are you using the update pass?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: Warning: array_keys(): The first argument should be an a

Postby bugmenot » Sat Oct 21, 2006 12:54 pm

PleegWat wrote:Damn, you're right. I must have been in my 1.7.1 beta folder.

The right blocks are at line 845, 924 and 937. You should surround all 3 with the if statement


Im kinda dumb so it seems :(
Is there any way you could post the entire wowdb.php file as Im clueless where to add what.
bugmenot
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Mon Jul 10, 2006 8:51 am

Previous

Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 0 guests

cron