Can't get it to work

Scans for, and displays main/alt relations in your Guild

Moderator: PleegWat

Can't get it to work

Postby giddeaon » Fri Oct 13, 2006 3:32 am

Ok - installed w/out issue. But I can't get it recognize alts at all.

Here's what I've tried. First - I edited almost every member of the guild to have similar Public and Officer notes.

All Public Notes are: "ALT - main'sname" or "Main"
All Officer Notes are: "Main's Alt" or "Main"

Example Characters
- Main = Giddeaon
- Alt = Menehil

Example of Menehil's Public Note: ALT - Giddeaon
Example of Menehil's Officer Note: Giddeaon's Alt

Giddeaon's Public Note = Main
Giddeaon's Officer Note = Main

I tried to use /ALT-([\w]+)/i - with this set to look at the public note and couldn't get it to work.

Second attempt was: I tried to use /([w]+)'s Alt/ - with this set to look at the officer's note and couldn't get it to work either.

Even after updating the guild and updating relations, none of the characters show as having alts (i.e. all are considered mains).

I also have it set to
Use Match No: 1
Main Identifier: Main
No Result: Main
Invalid Result: Mainless Alt
Alt of Alt: Set as Mainless Alt

Any idea what I'm messing up? Any help would be appreciated.
Last edited by giddeaon on Fri Oct 13, 2006 3:36 am, edited 1 time in total.
giddeaon Apprentice Apprentice
Posts: 1
Joined: Tue Oct 10, 2006 5:29 am

Can't get it to work

Postby PleegWat » Fri Oct 13, 2006 2:32 pm

If using the public note, add the spaces on both sides of the - to the regex as well
The officer note regex has a \ before the w missing.
I <3 /bin/bash
User avatar
PleegWat Dev Team Dev Team
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Return to AltMonitor

Who is online

Users browsing this forum: No registered users and 0 guests