Special Characters in names causing update to fail

A signature and avatar generator addon

Moderator: zanix

Special Characters in names causing update to fail

Postby robweeks » Sat Oct 14, 2006 2:34 am

When visiting MYURL/roster/addons/siggen/sig.php?etag=0&name=%D8kseskaft

The %D8kseskaft is what the log is trying to show as an image

i get this error
Code: Select all
Error - [GD Info]

Line 1114: Unable to open 'PATHTOROOT\roster\addons\siggen\saved\sig-Økseskaft.jpg' for writing


The Members name is actually Økseskaft

On doing a Guild update, the update log is blank, and the SQL output just reads
Code: Select all
SELECT `config_name`, `config_value` FROM `roster_config` ORDER BY `id` ASC;


No to sure what to do about this, how is the File saved? with URL Encoding or just the members name.
ImageImage
robweeks
WR.net Apprentice
WR.net Apprentice
 
Posts: 45
Joined: Tue Jul 04, 2006 8:17 pm

Special Characters in names causing update to fail

Postby zanix » Sat Oct 14, 2006 4:53 am

The file is saved utf-8 encoded, this is why there are funny characters in the filename

Try deleting that file from the siggen saved folder
Make sure that folder is world writable (777)
And try to load the image again
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to SigGen

Who is online

Users browsing this forum: No registered users and 0 guests

cron