GD Help please

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

GD Help please

Postby Uzeal » Fri Oct 20, 2006 1:36 am

I appologize in advance since this seems to be an annoying topic, but I can't figure out what is wrong. Here is a picture of my phpinfo page, and if I'm reading it correctly, gd and freetype are both installed.

http://www.uzeal.com/images/phpinfo.jpg

Anyways I'm guessing it's installed since it says '--with-freetype-dir=/usr' and '--enable-gd-native-ttf'.

We also have psychostats, a cs stats program that requires GD, and we are not having any problems with it. The sections that require GD are running correctly.

However, I'm still getting the error saying GD and Freetype libraries are not installed.

I'm at a loss, can someone please point me towards the right direction?
Uzeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Fri Oct 20, 2006 1:13 am

GD Help please

Postby zanix » Fri Oct 20, 2006 3:50 am

Because we use freetype with GD, not ttf
It needs to be compiled with php

I don't know how to go about doing this, but you web host might
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

GD Help please

Postby Uzeal » Fri Oct 20, 2006 5:29 am

The bad news is I'm the webhost :D

But after messing around with it all day I got it all figured out and working :)

Image
Last edited by Uzeal on Fri Oct 20, 2006 5:48 am, edited 2 times in total.
Uzeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Fri Oct 20, 2006 1:13 am

GD Help please

Postby zanix » Fri Oct 20, 2006 9:03 pm

Sweet, can you tell us how you fixed this so we can add it to our documentation page?
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: GD Help please

Postby Uzeal » Sat Oct 21, 2006 12:13 pm

I'm not sure if it will help anyone, but in the end it just turned out that I was wrong about GD being installed. I had to recompile / reinstall apache a few times in order to get both GD and freetype installed but after that everything ran fine.

There is one thing that might help some people. When / if you create a phpinfo() page and you see "'--with-freetype-dir=/usr' and '--enable-gd-native-ttf'" that does not mean you have GD installed. If GD is installed you will see something that looks similar to :

Image
Uzeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Fri Oct 20, 2006 1:13 am


Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 0 guests

cron