Addons Going Awry

Support and feedback for UniUploader
UniUploader requires microsoft .net runtimes!

Addons Going Awry

Postby carlpalmer » Fri Oct 20, 2006 2:23 am

We have been using UniUploader to keep everyone on the same version of addons for some time, and it has worked without a hitch. Since the update it has been acting up. Instead of placing addons in the World of Warcraft\Interface\AddOns folder, it is placing them in the World of Warcraft folder. It seems to be doing this to a number of people in my guild.

I have looked through the posts here, UniUploader settings, and the UniAdmin settings. Am I missing something?

Thanks
User avatar
carlpalmer
WR.net Apprentice
WR.net Apprentice
 
Posts: 24
Joined: Fri Jul 21, 2006 4:27 am

Addons Going Awry

Postby MattM » Fri Oct 20, 2006 2:35 am

wow this is a strange one

what version of UA are you using
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

Re: Addons Going Awry

Postby carlpalmer » Wed Oct 25, 2006 2:35 am

I am using version 2.50.

I just deleted all the addons out of the C:\Program Files\World of Warcraft directory and ran the uploader, and they came right back. It is so wierd.

Could it be a problem with my UniAdmin?
User avatar
carlpalmer
WR.net Apprentice
WR.net Apprentice
 
Posts: 24
Joined: Fri Jul 21, 2006 4:27 am

Addons Going Awry

Postby zanix » Wed Oct 25, 2006 6:37 am

Did you read the instructions for uploading addons in UniAdmin?
Code: Select all
The uploaded addon must be in zip form only.
The zip file must have the following directory structure: [folder],{file}, and not literally "addonName" or "addonfile"
The AddOn Name is the same as the name of the folder that the AddOn's files are in

[Interface]
     [AddOns]
          [addonName]
               {addonfile}
               {addonfile}
               {addonfile}
               {addonfile}
etc.

In UniAdmin 0.7.1, a check box will be added to "fix" the pathing in addon zips that do not have the "Interface/AddOns/" pathing
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Addons Going Awry

Postby carlpalmer » Wed Oct 25, 2006 5:11 pm

Ah Hah! That would be the problem! I did not put in the interface and addon folders into the zip. doh!

Thanks.
User avatar
carlpalmer
WR.net Apprentice
WR.net Apprentice
 
Posts: 24
Joined: Fri Jul 21, 2006 4:27 am

Addons Going Awry

Postby MattM » Tue Oct 31, 2006 3:41 am

cool avatar zanix ;)
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

Addons Going Awry

Postby zanix » Tue Oct 31, 2006 9:37 am

Matt_Miller wrote:cool avatar zanix ;)
Thanks, I went from Sonic to Shadow
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Addons Going Awry

Postby dhirmadi » Sun Nov 26, 2006 6:24 pm

Zanix, you'd be my hero if that works, because repackaging all addons every time is a huge pain, as most folks do not put int the interface?addons into their zip archive
User avatar
dhirmadi
WR.net Apprentice
WR.net Apprentice
 
Posts: 15
Joined: Sun Aug 06, 2006 9:01 pm

Addons Going Awry

Postby zanix » Sun Nov 26, 2006 7:00 pm

It does, and I'll get a new version out as soon as I can
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Addons Going Awry

Postby robweeks » Mon Nov 27, 2006 10:21 pm

I have had this problem in the past, and it was due to a caching problem i think.

I uploaded the addon first forgetting the directory structure, after updating it (with the correct structure) it still placed the addons in the wrong folder.

but when FTPing the file off the server, the Zip file structure was correct.

It sorted out after a while...
ImageImage
robweeks
WR.net Apprentice
WR.net Apprentice
 
Posts: 45
Joined: Tue Jul 04, 2006 8:17 pm


Return to UniUploader

Who is online

Users browsing this forum: No registered users and 1 guest

cron