Issue on upgrade from 1.70 to 1.7.1

Installation issues with WoWRoster

Issue on upgrade from 1.70 to 1.7.1

Postby joehail » Sun Oct 22, 2006 9:29 pm

I am receiving the following error:

Parse error: parse error, unexpected T_STRING, expecting ')' in /home/www/smokin-joe.net/roster/lib/wowdb.php on line 2459

and I can't find the issue. I downloaded the file at Noon EST on Sunday the 22nd. uploaded files overwriting all and this is what I got

please help
Image
User avatar
joehail
WR.net Journeyman
WR.net Journeyman
 
Posts: 103
Joined: Tue Jul 04, 2006 4:54 pm
Location: Cincinnati, Ohio USA

Issue on upgrade from 1.70 to 1.7.1

Postby zanix » Mon Oct 23, 2006 3:26 am

Re-upload the file to your webserver
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Issue on upgrade from 1.70 to 1.7.1

Postby joehail » Mon Oct 23, 2006 9:21 am

I have reuploaded 3 times now, once after re downloading it.

the site is at www.smokin-joe.net/roster
Image
User avatar
joehail
WR.net Journeyman
WR.net Journeyman
 
Posts: 103
Joined: Tue Jul 04, 2006 4:54 pm
Location: Cincinnati, Ohio USA

Issue on upgrade from 1.70 to 1.7.1

Postby Tsikura » Mon Oct 23, 2006 9:24 am

What version of the roster were you using?

Can you post that line of lib/wowdb.php on here?
Image
User avatar
Tsikura
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Tue Jul 04, 2006 1:49 pm
Location: New York

Issue on upgrade from 1.70 to 1.7.1

Postby joehail » Mon Oct 23, 2006 9:27 am

I was using 1.70

line is:
Code: Select all
      $this->add_value( 'level', $data['Level'] );


I am also receiving the error
Parse error: parse error, unexpected '{' in /home/www/smokin-joe.net/roster/upgrade.php on line 536
when I try to upgrade. that line is:
Code: Select all
      }


what is funny is that the ) is there in the first and there is no { in the second.

I am at a total loss here
Last edited by joehail on Mon Oct 23, 2006 9:34 am, edited 2 times in total.
Image
User avatar
joehail
WR.net Journeyman
WR.net Journeyman
 
Posts: 103
Joined: Tue Jul 04, 2006 4:54 pm
Location: Cincinnati, Ohio USA

Issue on upgrade from 1.70 to 1.7.1

Postby Tsikura » Mon Oct 23, 2006 9:34 am

That line looks fine and now you are having another problem.
Code: Select all
Parse error: parse error, unexpected '>' in /home/www/smokin-joe.net/roster/index.php on line 172
User avatar
Tsikura
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Tue Jul 04, 2006 1:49 pm
Location: New York

Issue on upgrade from 1.70 to 1.7.1

Postby joehail » Mon Oct 23, 2006 9:35 am

line 172 is simply a } in index.php. I think I am going to have to wipe my roster and start over.. that is the last thing I wanted to do :(
Image
User avatar
joehail
WR.net Journeyman
WR.net Journeyman
 
Posts: 103
Joined: Tue Jul 04, 2006 4:54 pm
Location: Cincinnati, Ohio USA

Issue on upgrade from 1.70 to 1.7.1

Postby Tsikura » Mon Oct 23, 2006 9:36 am

For now, try renaming your addons folder to something like addons1 and recreate an empty one named addons
Image
User avatar
Tsikura
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Tue Jul 04, 2006 1:49 pm
Location: New York

Issue on upgrade from 1.70 to 1.7.1

Postby joehail » Mon Oct 23, 2006 9:38 am

same errors on both pages. let me try a sideways install .. creating a new roster in a rosetr1 directory, see wha thappens. back in a few.

Edit:

ok new roster works. www.smokin-joe.net/roster2

I did nothing but upload and install it.
No clue what happened
Last edited by joehail on Mon Oct 23, 2006 10:00 am, edited 1 time in total.
Image
User avatar
joehail
WR.net Journeyman
WR.net Journeyman
 
Posts: 103
Joined: Tue Jul 04, 2006 4:54 pm
Location: Cincinnati, Ohio USA

Issue on upgrade from 1.70 to 1.7.1

Postby zanix » Mon Oct 23, 2006 9:58 am

That file has to be corrupted
I just downloaded the package and checked myself

Make sure your ftp is actually overwriting the files
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Issue on upgrade from 1.70 to 1.7.1

Postby joehail » Mon Oct 23, 2006 10:04 am

that is my thought Zanix. Can I wipe all but addons and images and upload, and then run the update. would that work?
Image
User avatar
joehail
WR.net Journeyman
WR.net Journeyman
 
Posts: 103
Joined: Tue Jul 04, 2006 4:54 pm
Location: Cincinnati, Ohio USA

Issue on upgrade from 1.70 to 1.7.1

Postby zanix » Mon Oct 23, 2006 10:05 am

Yeah, the upgrader just updates the database
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Issue on upgrade from 1.70 to 1.7.1

Postby joehail » Mon Oct 23, 2006 10:45 am

ok I deleted everything but conf.php and the img directory. uploaded the roster. started and got you need to upgrade. Clicked upgrade, then set to 1.70 and hit upgrade

received the error
Code: Select all
Upgrade Error
 
You have already upgraded Roster
Or you have a newer version than this upgrader


That is as far as I can get :(

btw a new install works flawlessly
Last edited by joehail on Mon Oct 23, 2006 10:46 am, edited 1 time in total.
Image
User avatar
joehail
WR.net Journeyman
WR.net Journeyman
 
Posts: 103
Joined: Tue Jul 04, 2006 4:54 pm
Location: Cincinnati, Ohio USA

Re: Issue on upgrade from 1.70 to 1.7.1

Postby calrayray » Tue Oct 24, 2006 7:38 am

joehail wrote:ok I deleted everything but conf.php and the img directory. uploaded the roster. started and got you need to upgrade. Clicked upgrade, then set to 1.70 and hit upgrade

received the error
Code: Select all
Upgrade Error
 
You have already upgraded Roster
Or you have a newer version than this upgrader


That is as far as I can get :(

btw a new install works flawlessly

i had to edit the upgrade.php to change:

Code: Select all
if( $version >= $DEFAULTS['version'] )


to

Code: Select all
if( $version >= 171 )


since my $version returns 170.
calrayray
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 03, 2006 10:50 am

Issue on upgrade from 1.70 to 1.7.1

Postby zanix » Tue Oct 24, 2006 7:39 am

Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Next

Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron