Problem mit Charakterseite

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

Problem mit Charakterseite

Postby Coldfinger » Tue Oct 24, 2006 6:41 pm

Leider muss ich hier in deutsch schreiben da mein Englisch nicht ausreicht um das Problem genau zu beschreiben.

Und zwar hab ich den WoWroster auf meiner entstehenden Gildenseite installiert, und einige Chars hochgeladen, das Problem allerdings, wen ich auf die Charseite gehe, kommt die Fehlermeldung das Der Datenbankeintrag mit Nick und Server nicht gefunden wurde, der Server ist Un'Goro, die Seite sucht allerdings nach Un/'Goro. Der Server wurde in den Settings korrekt angegeben. Ich denke der Fehler leigt daran, den lösche ich aus der Adresszeile den Befehl für den Server, findet er den Charakter, leider kenne ich mich nicht gut genug aus um das Problem selbst zu beheben, deswegen frage ich ob mir jemand sagen kann wo ich den Befehl finde das er auch nach dem Server sucht, und wo ich diesen löschen kann, damit müsste das Problem ja gelösst sein, da wir nur Member auf dem einen Server haben.
Coldfinger
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Oct 24, 2006 6:28 pm

Problem mit Charakterseite

Postby RainRider » Tue Oct 24, 2006 7:03 pm

ui ui hab genau dasselbe problem, mein server ist Aman'Thul. Hast Du frisch installiert oder upgradet? Klappt der Upload von Charaktere (werden z.B. die Schlüssel-Seite, Rezeptensuche usw. angezeigt)?

Ich habe schon woanders dies bzgl. geschrieben und werde Deinen Beitrag da verlinken.

Mein Beitrag befindet sich hier ist jedoch auf Englisch.
RainRider
WR.net Apprentice
WR.net Apprentice
 
Posts: 50
Joined: Thu Jul 20, 2006 11:47 pm

Problem mit Charakterseite

Postby Coldfinger » Tue Oct 24, 2006 7:18 pm

Frisch installiert, da ich die Seite gerade erst aufbaue.

Eigentlich funktioniert der Komplette roster, nur eben die Charakterseite macht mir Probleme, die funkioniert nur wenn ich aus der Adresszeile den Befehl &server=Un'Goro lösche
Coldfinger
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Oct 24, 2006 6:28 pm

Problem mit Charakterseite

Postby RainRider » Tue Oct 24, 2006 7:50 pm

Heh, danke Coldfinger, ich poste das mal dann im anderen Thread, Zanix schaut da rein und das wird ihn bestimmt auf den Fix bringen :)
RainRider
WR.net Apprentice
WR.net Apprentice
 
Posts: 50
Joined: Thu Jul 20, 2006 11:47 pm

Problem mit Charakterseite

Postby Coldfinger » Tue Oct 24, 2006 8:01 pm

Jo kein Problem, hilft mir ja auch weiter wenn er den Bug findet
Coldfinger
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Oct 24, 2006 6:28 pm

Problem mit Charakterseite

Postby luciver » Tue Oct 24, 2006 9:04 pm

Hey !

Also ich habe erstmal versucht upzudaten, leider ohne erfolg, hab mich denke mal nur zu doof angestellt :)

dann habe ich neuinstalliert und siehe da alles ohne pros, bin auch auf Aman'Thul , bei der server angabe mache ich es immer so, das ich von der WoW seite den Realmstatus mir anzeigen lasse und den server namen kopieren, dann sollte es gehn :)
The German Community
wowroster.de
Akecheta of Frostwolf
User avatar
luciver
WR.net Apprentice
WR.net Apprentice
 
Posts: 26
Joined: Wed Jul 05, 2006 12:28 am
Location: Berlin

Problem mit Charakterseite

Postby Coldfinger » Tue Oct 24, 2006 9:33 pm

Hmm, vielleicht packt das deine Datenbank, also ich habs probiert, Serverstatus frage ich ja auch von WoW ab, richtig geschrieben ist s sonst könnte ich die Daten nicht hochladen, nur eben die Charakterseite packt er ned.
Coldfinger
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Oct 24, 2006 6:28 pm

Problem mit Charakterseite

Postby RainRider » Tue Oct 24, 2006 9:40 pm

Luciver poste mal bitte ein Link zu Deinem Roster.
Welche Version von MySQL hast Du? Meine ist 4.1.5.
RainRider
WR.net Apprentice
WR.net Apprentice
 
Posts: 50
Joined: Thu Jul 20, 2006 11:47 pm

Re: Problem mit Charakterseite

Postby luciver » Wed Oct 25, 2006 1:28 pm

Hey !

http://horde.boten-des-zorns.org ist der link zum gildenroster
The German Community
wowroster.de
Akecheta of Frostwolf
User avatar
luciver
WR.net Apprentice
WR.net Apprentice
 
Posts: 26
Joined: Wed Jul 05, 2006 12:28 am
Location: Berlin

Problem mit Charakterseite

Postby RainRider » Thu Oct 26, 2006 7:33 am

Luciver, cool, danke.
Du hast magic_quotes_gpc an, das verursacht das Problem angeblich.

Mach Euch ne Text-Datei mit dem Namen htaccess und schreib das folgende rein:
Code: Select all
php_flag magic_quotes_gpc on

Kopiert dann diese Datei in Euer /roster-Verzeichnis auf Eurem Server. Nennt die Datei auf .htaccess um (also mit nem Punkt am Anfang) (und achtet darauf, dass kein .txt am Ende des Namen ist)

Das ist alles. Wer Zugriff auf php.ini hat, kann den Flag da ändern (also keine .htaccess dann machen).

Die Lösung ist von Zanix, ich leite es bloss hier weiter.
RainRider
WR.net Apprentice
WR.net Apprentice
 
Posts: 50
Joined: Thu Jul 20, 2006 11:47 pm

Problem mit Charakterseite

Postby Coldfinger » Thu Oct 26, 2006 5:26 pm

Also wenn ich die .htaccess hochlade ins Rosterverzeichniss bekomme ich ne Fehlermeldung von meinem Server und die Seite öffnet sich garnicht mehr
Coldfinger
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Oct 24, 2006 6:28 pm

Problem mit Charakterseite

Postby zanix » Fri Oct 27, 2006 1:57 am

All this german is giving me a headache...lol

All kidding aside...what's going on here?
Anything we need to fix that isn't already been posted in english?
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Problem mit Charakterseite

Postby Coldfinger » Fri Oct 27, 2006 4:00 am

Thats the same thing in other forum, with the char-site and the /' in the db-search
Coldfinger
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Oct 24, 2006 6:28 pm

Problem mit Charakterseite

Postby RainRider » Fri Oct 27, 2006 6:04 am

PleegWat hat die folgende Lösung im englische Thread gepostet:

Findet in memberdetails.php:
Code: Select all
// Slash char name and server name
if( get_magic_quotes_gpc() )
{
    
$name stripslashes$name );
    
$server stripslashes$server_name_escape );
}
 


Und ersetzt es durch:

Code: Select all
// Slash char name and server name
    
$name stripslashes$name );
    
$server stripslashes$server_name_escape );
 


Es wurde bestätigt dass, das funtioniert.
RainRider
WR.net Apprentice
WR.net Apprentice
 
Posts: 50
Joined: Thu Jul 20, 2006 11:47 pm

Problem mit Charakterseite

Postby Coldfinger » Sat Oct 28, 2006 5:50 am

Jepp, funktioniert einwandfrei
Coldfinger
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Oct 24, 2006 6:28 pm


Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 0 guests

cron