Error

CharacterProfiler.lua file uploading issues

Error

Postby Tamoot » Sun Dec 17, 2006 10:49 pm

When I try to upload my CharacterProfiler.lua file, I am recieving the following error: "Could not find guild in database. Please update members first."

I just set this up for the first time today on my server, so therefore I currently do not have a roster up, so this would be the first upload of my roster. I went into the configuration, the guild name and the server are spelled correctly with case sensitivity if this has any matter.

I was reading in these forums a bit, I saw some people getting errors when they were trying to upload; they tried deleting their CharacterProfiler.lua file and creating a new one, and trying to export there data into the new file, and it seemed to be working for a few of them. I opened my .lua file and deleted all the content, saved it, exported the info. using CP addon and GP addon, and tried uploading again. Before and after i tried this, i was getting the same error.

Any suggestions?
Last edited by Tamoot on Sun Dec 17, 2006 10:51 pm, edited 1 time in total.
Tamoot
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sun Dec 17, 2006 10:44 pm

Error

Postby Anaxent » Sun Dec 17, 2006 10:55 pm

To update the guild data there is a password field on the update page that needs the admin password entered before you update.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

Error

Postby Tamoot » Sun Dec 17, 2006 10:59 pm

Is the admin password the same as roster password? That is the only password I remember creating.

When I enter it in the text filed "Roster Update Password" and try to upload my .lua file, i get the following error:

Could not find guild in database. Please update members first.

Could not update "". Maybe its not set in configuration?
Last edited by Tamoot on Sun Dec 17, 2006 11:02 pm, edited 2 times in total.
Tamoot
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sun Dec 17, 2006 10:44 pm

Error

Postby Anaxent » Mon Dec 18, 2006 1:39 am

ok what version of roster, character profiler, guild profiler are you using? When it tells you that the guild has not been updated yet in the log area it should show you the exact spelling of both the server and guild you belong to please double check that to make sure it is really correct. If this all fails please post a link to your site. and yes the roster password would be the same as what i called the admin password, for kicks and giggles also try resetting it with in the admin control panel.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

Error

Postby ragnartx » Tue Dec 19, 2006 2:29 pm

I'm getting the same problem.
ragnartx
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Sat Jul 15, 2006 11:12 am

Re: Error

Postby foreverevil » Wed Dec 20, 2006 1:39 pm

The 1.7.2 beta patch fixes this issue. Go download it now.
Last edited by foreverevil on Wed Dec 20, 2006 1:45 pm, edited 1 time in total.
foreverevil
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Wed Dec 20, 2006 1:35 pm

Re: Error

Postby Scorn » Wed Dec 20, 2006 6:00 pm

As a viable solution I would never suggest downloading a beta to fix an issue some one is experiencing in a released version of the roster. Besides, as far as we are concerned the Beta 1.7.2 could be finished in the next few days and that way you are downloading the 1.7.2 for nothing unless you like bugs.

In all actuality I would suggest going to config page and ensuring that your guild name is in the Guild Name box exactly as you see it in game. There can be issues with special characters being used in guild names.

URL your looking for:

http://<server address>/<roster installation>/admin.php (1.7.2)
(can't remember the path for the old one)
User avatar
Scorn
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Wed Jul 12, 2006 4:09 am
Location: Toronto, Ontario

Error

Postby zanix » Thu Dec 21, 2006 12:09 am

Yes, but Roster 1.7.1 will not accept data from CP and GP 2.0

So files are needed to get Roster 1.7.1 running and the patch for 1.7.1 is not supported and considered beta
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Error

Postby mfoley » Thu Dec 21, 2006 1:06 am

I had downloaded the roster172_b2_svn-351 (fresh install), was able to upload the roster...then I did a direct update from the Roster Diag page with this generated file: WoWRoster_UpdatePackage_YARR_20061221_0857.zip and now the roster update fails with:

NOT Updating character [Character]
Data is from CharacterProfiler v
The version of CharacterProfiler used to capture data for this character is older than the minimum version allowed for upload.
Please ensure you are running at least v2.0.0 and have logged onto this character and saved data using this version.

Could not update "". Maybe its not set in configuration?


GuildProfiler and CharacterProfiler are 2.0.1
User avatar
mfoley
WR.net Apprentice
WR.net Apprentice
 
Posts: 55
Joined: Tue Aug 08, 2006 11:27 am

Error

Postby zanix » Thu Dec 21, 2006 3:01 am

Why did you do that for?
The updater in Roster Diag is only for release installs, you just downgraded your Roster back to 1.7.1
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Error

Postby mfoley » Thu Dec 21, 2006 8:01 pm

zanix wrote:Why did you do that for?
The updater in Roster Diag is only for release installs, you just downgraded your Roster back to 1.7.1


Probably because in a beta situation, it seems more appropriate or likely to take advantage of the incremental changes that occur with more frequency in a beta period. (i.e. nightly gets from SVN)

It seems more appropriate to actually perform a bonafide upgrade in the situation of a released version (i.e. download the archive, post the changed files, run any SQL scripts that might be required, etc.)

I'd actually ask why anyone would update their release from the DiagPage. ;)
Last edited by mfoley on Thu Dec 21, 2006 8:05 pm, edited 1 time in total.
User avatar
mfoley
WR.net Apprentice
WR.net Apprentice
 
Posts: 55
Joined: Tue Aug 08, 2006 11:27 am

Error

Postby zanix » Thu Dec 21, 2006 10:03 pm

Well, our beta/svn/release tactics are not quite refined as of yet :(

But you are correct, I suppose if I were to look at the Roster Diag page and see that there may be updates, I would try to do the same thing

Maybe next time, we should create a new URL for the beta updater code in Roster Diag
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Error

Postby Keerlke » Sat Dec 23, 2006 4:30 am

I have the same problem too :scratch:

Could not update "". Maybe its not set in configuration?

WoW Roster 1.7.1
GP & CP both 2.0.1

Also tried UniUploader, same problem.

Maybe because there is a ' (apostrophe) in the realm name (Quel'Thalas) ??
Last edited by Keerlke on Sat Dec 23, 2006 4:41 am, edited 1 time in total.
Keerlke
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sat Dec 23, 2006 4:19 am

Error

Postby zanix » Sat Dec 23, 2006 4:56 am

Did you get the patch for Roster 1.7.1?
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Error

Postby Keerlke » Sat Dec 23, 2006 5:05 am

just updated, it works now ... thx
Last edited by Keerlke on Sat Dec 23, 2006 5:21 am, edited 1 time in total.
Keerlke
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sat Dec 23, 2006 4:19 am


Return to Uploading

Who is online

Users browsing this forum: No registered users and 0 guests

cron