[1.7.0] Roster Pic Problems

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

1.7 Roster Pic Problems

Postby PleegWat » Mon Sep 25, 2006 12:59 pm

It breaks off execution when it fetches the first equipment piece. Dunno what's causing it. Anything in the error log, if you have access to that?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: 1.7 Roster Pic Problems

Postby mystic-dragon » Mon Sep 25, 2006 7:11 pm

PleegWat wrote:It breaks off execution when it fetches the first equipment piece. Dunno what's causing it. Anything in the error log, if you have access to that?


Log? Is there a log in this PHP script??
Dint find it....
And yes.. I have full access to my server...
It's to the left from me ;)
ghehhe
Running Linux.
mystic-dragon
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Sat Sep 23, 2006 6:37 pm

1.7 Roster Pic Problems

Postby mystic-dragon » Mon Sep 25, 2006 8:04 pm

In my Apache Log I found this


Code: Select all
[Mon Sep 25 18:08:02 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Sep 25 18:08:02 2006] [notice] Digest: generating secret for digest authentication ...
[Mon Sep 25 18:08:02 2006] [notice] Digest: done
[Mon Sep 25 18:08:02 2006] [notice] Apache/2.0.54 (Mandriva Linux/PREFORK-13.3.20060mdk) configured -- resuming normal operations
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/index.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/index.php?s=class
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/indexalt.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/guildinfo.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/indexstat.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/indexpvp.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/indexhonor.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/guildbank.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/membersinst.php on line 68, referer: http://mystic-dragon.nl/wow/wowroster/guildbank.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/indexinst.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/tradeskills.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/admin/update.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/indexquests.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/indexsearch.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/credits.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/admin/config.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/rosterdiag.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/admin/update.php
[client 192.168.1.33] PHP Warning:  array_keys() [<a href='function.array-keys'>function.array-keys</a>]: The first argument should be an array in /var/www/html/wow/wowroster/lib/wowdb.php on line 937, referer: http://mystic-dragon.nl/wow/wowroster/admin/update.php
[client 192.168.1.33] PHP Warning:  Invalid argument supplied for foreach() in /var/www/html/wow/wowroster/lib/wowdb.php on line 937, referer: http://mystic-dragon.nl/wow/wowroster/admin/update.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/admin/update.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/index.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/lib/item.php on line 108, referer: http://mystic-dragon.nl/wow/wowroster/index.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/index.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/lib/item.php on line 108, referer: http://mystic-dragon.nl/wow/wowroster/index.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/index.php
[client 192.168.1.33] PHP Fatal error:  Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/realmstatus.php on line 37, referer: http://mystic-dragon.nl/wow/wowroster/index.php
mystic-dragon
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Sat Sep 23, 2006 6:37 pm

1.7 Roster Pic Problems

Postby PleegWat » Mon Sep 25, 2006 9:15 pm

Hm, interesting. The warnings are probably caused by uploading an empty bank or a bank with empty bags. The interesting ones are the errors:

[client 192.168.1.33] PHP Fatal error: Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/lib/item.php on line 108, referer: http://mystic-dragon.nl/wow/wowroster/index.php

utf8_decode() is used in serveral places in roster. This error is probably the one breaking your character page, realmstatus, and your keys page. It probably also breaks the bank and the automatic sig generation of siggen.

The weird thing is that according to the manual it's available by default starting PHP3.0.6, and in all versions of PHP4 and PHP5, but rosterdiag reports you are using 5.0.4, so you should have it.

You don't have it turned off somewhere for some reason do you?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: 1.7 Roster Pic Problems

Postby mystic-dragon » Mon Sep 25, 2006 9:25 pm

PleegWat wrote:Hm, interesting. The warnings are probably caused by uploading an empty bank or a bank with empty bags. The interesting ones are the errors:

[client 192.168.1.33] PHP Fatal error: Call to undefined function utf8_decode() in /var/www/html/wow/wowroster/lib/item.php on line 108, referer: http://mystic-dragon.nl/wow/wowroster/index.php

utf8_decode() is used in serveral places in roster. This error is probably the one breaking your character page, realmstatus, and your keys page. It probably also breaks the bank and the automatic sig generation of siggen.

The weird thing is that according to the manual it's available by default starting PHP3.0.6, and in all versions of PHP4 and PHP5, but rosterdiag reports you are using 5.0.4, so you should have it.

You don't have it turned off somewhere for some reason do you?




Nope not disabled... or turned off...
All my other PHP websites are working fine.
mystic-dragon
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Sat Sep 23, 2006 6:37 pm

1.7 Roster Pic Problems

Postby mystic-dragon » Tue Sep 26, 2006 2:33 pm

The thing that is most strange is that character stats = not working
Spellbook is working fine.
Bag is not working
Bank is not working
Mailbox not working
Quest not working
Recipes not working
BG Log working fine
PvP Log working fine
Duel Log not working.
&
Server status also not working.


Really strange..
You can add me to MSN if you have an idea how to fix this.
So I can fix is sooner than waiting all day long on this forum.. :P
Than we can post the solution on here later.
My MSN adress is draco.mystic.dragon@Gmail.com

Tahnx :D
Last edited by mystic-dragon on Tue Sep 26, 2006 2:35 pm, edited 1 time in total.
mystic-dragon
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Sat Sep 23, 2006 6:37 pm

1.7 Roster Pic Problems

Postby Skarsnik » Wed Sep 27, 2006 7:52 pm

I have been waiting 2 months matey =)
Skarsnik
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Mon Jul 10, 2006 2:43 pm

1.7 Roster Pic Problems

Postby mystic-dragon » Fri Sep 29, 2006 1:09 pm

Oke I fixed the problem..
I just found out.. With all the newly released Linux Distro's..
When you install apache and all the modules...
It wont install PHP XML by standart even tho you see it's configuration in apache.conf or httpd.conf files...
I fixed the problem by installing PHP XML.
And dont forget the PHP GD Lib's.
Everything works after those packages.


My next mission is getting WOW Roster ported to Nuke Evolution.
(I found some stuff about it on this website but wont work yet)
http://www.wowroster.net/Forums/viewtopic/t=398.html
See ya later...
mystic-dragon
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Sat Sep 23, 2006 6:37 pm

Re: 1.7 Roster Pic Problems

Postby dewce » Wed Oct 04, 2006 5:15 pm

yeah i'm still having the // issue and i've reuploaded everything deleted all my character profiler junk and reuploaded that, and added the new wowdb deal... nothing seems to be working for me. :(
dewce
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Tue Aug 29, 2006 11:06 pm

1.7 Roster Pic Problems

Postby dewce » Wed Oct 04, 2006 8:16 pm

i got it working... reuploaded everything again and realized the image pack was uploaded to the wrong path... whoops! :)


thanks guys
dewce
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Tue Aug 29, 2006 11:06 pm

Re: 1.7 Roster Pic Problems

Postby Skarsnik » Wed Oct 18, 2006 8:44 pm

dewce wrote:yeah i'm still having the // issue and i've reuploaded everything deleted all my character profiler junk and reuploaded that, and added the new wowdb deal... nothing seems to be working for me. :(


shamless bump
Skarsnik
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Mon Jul 10, 2006 2:43 pm

Previous

Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 2 guests

cron