PHP Errors After Uploading

CharacterProfiler.lua file uploading issues

PHP Errors After Uploading

Postby homiebrah » Mon Jan 08, 2007 6:59 pm

The following errors are generated after trying to upload data:

Warning: array_keys(): The first argument should be an array in /home/********/public_html/wow/update.php on line 311

Warning: Invalid argument supplied for foreach() in /home/********/public_html/wow/update.php on line 311

Warning: Division by zero in /home/********/public_html/wow/lib/menu.php on line 108

The update log after trying to update:
Parsing files

* Parsed CharacterProfiler in 1.37 seconds


Updating Character [Kazzara]

* Kazzara is not in the list of guild members so their data will not be inserted.


Updating Guild [Project Mayhem]

* Member Log
o Updated: 0
o Added: 0
o Removed: 0

* Updating Members

This is a fresh 1.7.2 load and a fresh DB.

Site: http://wow.heatherscorner.com
PHPInfo: http://wow.heatherscorner.com/phpinfo.php

I am using the current versions of CharacterProfiler and PVPLog.
Last edited by homiebrah on Mon Jan 08, 2007 7:00 pm, edited 2 times in total.
homiebrah
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Thu Oct 26, 2006 1:10 am

PHP Errors After Uploading

Postby zanix » Mon Jan 08, 2007 10:04 pm

This error tells me that the members array is empty for your guild in CP.lua

Try doing a
Code: Select all
/cp purge all
/gp purge all

In wow, grab your data, and try to upload again
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: PHP Errors After Uploading

Postby homiebrah » Mon Jan 08, 2007 10:56 pm

zanix wrote:This error tells me that the members array is empty for your guild in CP.lua

Try doing a
Code: Select all
/cp purge all
/gp purge all

In wow, grab your data, and try to upload again


Looks like that corrected the errors. Kinda odd that the profiler wasn't picking up the data like it should. Anyways, my thanks for the help.
Last edited by homiebrah on Mon Jan 08, 2007 10:57 pm, edited 1 time in total.
homiebrah
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Thu Oct 26, 2006 1:10 am


Return to Uploading

Who is online

Users browsing this forum: No registered users and 0 guests

cron