Cat Guild Bank fix

Categorizes items in your guildbank(s)

Moderator: Mathos

Cat Guild Bank fix

Postby Fistula » Fri Jan 12, 2007 6:50 pm

Any idea when we can figure out a fix so Categorized guild Bank will work? I would really like to use it.. but it is still broken.

Thanks

Fistula
Fistula
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Wed Jan 03, 2007 9:40 am

Cat Guild Bank fix

Postby Adariel » Sat Jan 13, 2007 1:40 pm

what's broken? I'm using it just fine?
User avatar
Adariel
WR.net Apprentice
WR.net Apprentice
 
Posts: 36
Joined: Tue Jul 25, 2006 9:14 am

Re: Cat Guild Bank fix

Postby kaleyn » Sat Jan 13, 2007 3:17 pm

Can you try to be more specific as to what the problems are that you are experiencing?

Error codes, descriptions, version numbers, they are all very helpful. ;)
Johann Wolfgang Von Goethe --
Treat people as if they were what they ought to be and you help them to become what they are capable of being.
User avatar
kaleyn
WR.net Apprentice
WR.net Apprentice
 
Posts: 37
Joined: Mon Jan 08, 2007 7:59 pm

Re: Cat Guild Bank fix

Postby Fistula » Sat Jan 13, 2007 8:46 pm

kaleyn wrote:Can you try to be more specific as to what the problems are that you are experiencing?

Error codes, descriptions, version numbers, they are all very helpful. ;)


I run Cat. Guild bank.. and get lines of this:

Notice: Undefined offset: 1 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Notice: Undefined offset: 2 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Notice: Undefined offset: 1 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Notice: Undefined offset: 2 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Notice: Undefined offset: 1 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Notice: Undefined offset: 2 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Notice: Undefined offset: 1 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Notice: Undefined offset: 2 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247


All my pictures show up ok.. I just have all those error lines before the graphics and its terrible looking.

And i have all the latest updates installed. Even the parser.
Fistula
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Wed Jan 03, 2007 9:40 am

Re: Cat Guild Bank fix

Postby Fistula » Sun Jan 14, 2007 12:15 pm

Any ideas? If not I am going to scrap this and go to something else. Its not worth my time
Fistula
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Wed Jan 03, 2007 9:40 am

Re: Cat Guild Bank fix

Postby kaleyn » Sun Jan 14, 2007 4:07 pm

I'm not sure if it is fixed or not. Have you tried searching the other topics?

Other than that, when the put up the new patch WoW 2.0.4 (i think that's the version we're on now.) They may have added stuff or changed the things, and thus the CGB database has not yet been updated to accomadate for this.

So, patience is all that may be required for the fix.
Johann Wolfgang Von Goethe --
Treat people as if they were what they ought to be and you help them to become what they are capable of being.
User avatar
kaleyn
WR.net Apprentice
WR.net Apprentice
 
Posts: 37
Joined: Mon Jan 08, 2007 7:59 pm

Cat Guild Bank fix

Postby Azzarac » Sun Jan 14, 2007 6:34 pm

I'm having the same issues as posted above. I'm using Roster 1.7.1 and it worked fine until the last WoW patch. Now my bank inventory shows only a few items and a lot of:

Notice: Undefined offset: 1 in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 247

Any thoughts would be greatly appreciated. I love the ease of WowRoster!
Azzarac
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sun Dec 17, 2006 1:15 am

Cat Guild Bank fix

Postby zanix » Sun Jan 14, 2007 8:26 pm

WoWRoster 1.7.1 is no longer supported and I would suggest getting 1.7.2 and the luaparser/wowdb patch
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Cat Guild Bank fix

Postby biomere » Mon Jan 15, 2007 3:00 am

quick fix: in gbank.php (in the addons guildbank folder)

in line 247 find:
$real_itemid = $itemid_array[0].':'.$itemid_array[1].':'.$itemid_array[2];

change to:

$real_itemid = $itemid_array[0];
Last edited by biomere on Mon Jan 15, 2007 3:02 am, edited 1 time in total.
biomere
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Mon Jan 15, 2007 2:17 am

Cat Guild Bank fix

Postby Argot » Mon Jan 15, 2007 9:48 am

Last edited by Argot on Mon Jan 15, 2007 9:49 am, edited 1 time in total.
User avatar
Argot
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Tue Jul 04, 2006 7:16 pm

Cat Guild Bank fix

Postby Deckyon » Mon Jan 15, 2007 10:13 am

The Quick Fix above seemed to have taken care of my issues.
Image

"Widdershins go when the Moon doth wane, and the werewolf howls by the dread wolfsbane."
User avatar
Deckyon
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Fri Jan 12, 2007 10:36 am
Location: Louisville, KY

Re: Cat Guild Bank fix

Postby Fistula » Mon Jan 15, 2007 11:01 am

biomere wrote:quick fix: in gbank.php (in the addons guildbank folder)

in line 247 find:
$real_itemid = $itemid_array[0].':'.$itemid_array[1].':'.$itemid_array[2];

change to:

$real_itemid = $itemid_array[0];


Didn't work for me. Now I dont' even get the bank to come up.. I get this instead:

Parse error: syntax error, unexpected T_IF in /home/pstwosou/public_html/wowrpg/FutureKings/roster/addons/guildbank/gbank.php on line 1


I am just deleting this addon all together.. its too much hassle and takes too long to get answers. Nothing seems to work so I'm not going to mess with it. My regular guild bank works so thats fine for now.
Last edited by Fistula on Mon Jan 15, 2007 11:09 am, edited 1 time in total.
Fistula
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Wed Jan 03, 2007 9:40 am

Cat Guild Bank fix

Postby Azzarac » Mon Jan 15, 2007 4:03 pm

Thanks Biomere!! That, along with updating the wowdb.php and Luaparser.php files solved my problem. I know 1.7.1 is no longer supported and I will eventually upgrade but as long as its working I see no reason to. We appreciate your help!! Now I can log in and not get 1k tells that the bank is broken... lol
Azzarac
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sun Dec 17, 2006 1:15 am

Cat Guild Bank fix

Postby biomere » Mon Jan 15, 2007 5:37 pm

np :)

fistula, make sure you do the wowdb.php and Luaparser.php files update...
biomere
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Mon Jan 15, 2007 2:17 am

Re: Cat Guild Bank fix

Postby julienetspock » Mon Jan 15, 2007 6:56 pm

This is the good gbank.php. No error messages.
julienetspock
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sun Dec 10, 2006 1:20 pm

Next

Return to Categorized Guild Bank

Who is online

Users browsing this forum: No registered users and 0 guests