Everyone is a main...

Scans for, and displays main/alt relations in your Guild

Moderator: PleegWat

Everyone is a main...

Postby 776Sputnik » Tue Jul 11, 2006 9:38 pm

attached are the settings I'm using as well as my public note samples...

this is the sql output after update relations

Ralnok has main Ralnok

Ralnok is a main

Ralnok has no alts

Avele has main Avele

Avele is a main

Avele has no alts


what am I doin wrong?
Attachments
table.jpg
note samples
table.jpg (5.56 KiB) Viewed 472 times
User avatar
776Sputnik
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Thu Jul 06, 2006 1:23 am

Everyone is a main...

Postby PleegWat » Wed Jul 12, 2006 2:19 am

The regex. You're using the broken default regex that came with version 1.0. add a \ in front of the w.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Everyone is a main...

Postby 776Sputnik » Wed Jul 12, 2006 2:53 am

It won't let me for some odd reason... I add the slash and hit save settings, it brings me back to settings page, but the change is no longer there. It says settings have been changed sometimes and no changes have been made others...

weird...
Last edited by 776Sputnik on Wed Jul 12, 2006 2:55 am, edited 1 time in total.
User avatar
776Sputnik
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Thu Jul 06, 2006 1:23 am

Re: Everyone is a main...

Postby 776Sputnik » Wed Jul 12, 2006 4:30 am

Video of it...

used quicktime, nero showtime, or videolan to view it.
Attachments
altmonitor.mp4.zip
video of altmonitor weirdness
(587.18 KiB) Downloaded 84 times
User avatar
776Sputnik
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Thu Jul 06, 2006 1:23 am

Re: Everyone is a main...

Postby PleegWat » Wed Jul 12, 2006 2:29 pm

Add 2 backslashes. As I said, it's a bug in the original config page that I adapted, it never had to handle data where backslashes were an issue.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Everyone is a main...

Postby PleegWat » Wed Jul 12, 2006 3:07 pm

Traced and fixed. It was, as I had been expecting, the magic_quotes_gpc setting, which is on in the default configuration. If it's off I need an extra addslashes.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Everyone is a main...

Postby 776Sputnik » Wed Jul 12, 2006 8:19 pm

Awesome, that fixed it.

any easy way to make the intial roster page show in this alt/main format?
User avatar
776Sputnik
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Thu Jul 06, 2006 1:23 am

Everyone is a main...

Postby PleegWat » Thu Jul 13, 2006 1:30 pm

Changing the way you link to it.

You can theoretically replace the membersList.php by the altlist.php from AltMonitor, but you'd have to ensure altmonitor's conf.php and localization.php are included.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm


Return to AltMonitor

Who is online

Users browsing this forum: No registered users and 0 guests

cron