Error Msg for CGB

Categorizes items in your guildbank(s)

Moderator: Mathos

Error Msg for CGB

Postby Blacksangre » Sun Feb 04, 2007 2:08 am

Hi to you...

Here is the error msg.
Notice: Undefined offset: 1 in /home/gr/public_html/roster/addons/guildbank/gbank.php on line 247

and I get a WHOLE page of these error msg... My page can be viewed at
http://guildrazor.com/roster/addon.php? ... =guildbank

AND Also... it is not recording all of our bank items...

Do you know what I can do to fix These 2 problems...

Thx so much...
Attachments
picture1.jpg
here is what I see.
picture1.jpg (173.79 KiB) Viewed 787 times
Black Sangre
Leader of RAZOR
Whisperwind
User avatar
Blacksangre
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Thu Dec 14, 2006 7:15 am

Error Msg for CGB

Postby sturmy » Sun Feb 04, 2007 3:32 am

ensure that you applied all of the following:
=> all bank owners use CharacterProfiler 2.0.5b and have cp /purge all and saved bank contents again
=> you've updated the luaparser as per the 1.7.2 / WoW 2.0.3 thread elsewhere here
=> you've updated CGB with the fix hanging around close by here to cope for negative item IDs

With all those, normally, there should be no such warnings (at least I don't have any with 3 guilds on different rosters).
sturmy
WR.net Expert
WR.net Expert
 
Posts: 160
Joined: Wed Aug 16, 2006 9:07 pm

Error Msg for CGB

Postby Blacksangre » Sun Feb 04, 2007 11:53 am

Nope... Just went bank in and dont all of that... JUST to make sure... Purged and downloaded all the latest stuff... and nope... Get the same error...

thx tho... Might ya or someone else have a idea why it will not work...

http://guildrazor.com/roster/addon.php? ... =guildbank
Black Sangre
Leader of RAZOR
Whisperwind
User avatar
Blacksangre
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Thu Dec 14, 2006 7:15 am

Error Msg for CGB

Postby sturmy » Sun Feb 04, 2007 12:26 pm

Really no other clue, sorry...

It looks so much like http://www.wowroster.net/Forums/viewtopic/t=2330.html that I would have bet on the fix at the end of that thread not being applied...
sturmy
WR.net Expert
WR.net Expert
 
Posts: 160
Joined: Wed Aug 16, 2006 9:07 pm

Error Msg for CGB

Postby vbdh » Sun Feb 04, 2007 1:20 pm

ok im getting this after i did the fix

Fatal error: Cannot redeclare itemarray_merge() (previously declared in /var/www/vhosts/thrillseekers.live-host.org/httpdocs/roster/addons/guildbank/searcharrays.php:75) in /var/www/vhosts/thrillseekers.live-host.org/httpdocs/roster/addons/guildbank/searcharrays.php on line 75

so no i can upload anything for bank plz help :(

i may be wornk but it updating the bank but just getting this
Last edited by vbdh on Sun Feb 04, 2007 1:22 pm, edited 1 time in total.
Long Live The Fighters
User avatar
vbdh
WR.net Apprentice
WR.net Apprentice
 
Posts: 45
Joined: Wed Jan 03, 2007 12:48 pm

Re: Error Msg for CGB

Postby sturmy » Sun Feb 04, 2007 3:55 pm

try the attached file.

Remember luaparser must be updated to cope with the "new" way wow saves data in characterprofiler, and that CP must be 2.0.5b (addon & saved content).

Let me know how this turns out. So far I've had no problem at all, but it may be I simply do not store the item causing problems in my banks...
Attachments
guildbank.zip
guildbank, jewelcrafting recipes fix, negative item IDs included
(67.65 KiB) Downloaded 178 times
sturmy
WR.net Expert
WR.net Expert
 
Posts: 160
Joined: Wed Aug 16, 2006 9:07 pm

Error Msg for CGB

Postby Blacksangre » Sun Feb 04, 2007 5:50 pm

DUDE>>> U ROCK... that worked... Thx much... Now I just need to get my problem fixed with that all of my stuff is not being loged in and also the icons icons for mis. are not showing up... I thought all go to the /img flolder... ya...

ONECE again... thx for your help.
Black Sangre
Leader of RAZOR
Whisperwind
User avatar
Blacksangre
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Thu Dec 14, 2006 7:15 am

Error Msg for CGB

Postby vbdh » Sun Feb 04, 2007 7:51 pm

yeah that fixed it did a purge and it works thx for the help
Long Live The Fighters
User avatar
vbdh
WR.net Apprentice
WR.net Apprentice
 
Posts: 45
Joined: Wed Jan 03, 2007 12:48 pm

Error Msg for CGB

Postby sturmy » Mon Feb 05, 2007 2:15 am

glad to be of some help ;-)
sturmy
WR.net Expert
WR.net Expert
 
Posts: 160
Joined: Wed Aug 16, 2006 9:07 pm

Error Msg for CGB

Postby vbdh » Mon Feb 05, 2007 6:58 pm

ok got it again do i have to purge all the time
Long Live The Fighters
User avatar
vbdh
WR.net Apprentice
WR.net Apprentice
 
Posts: 45
Joined: Wed Jan 03, 2007 12:48 pm

Error Msg for CGB

Postby sturmy » Tue Feb 06, 2007 3:31 am

what locale are you in? it seem there's a missing category of some kind... German is not fully translated for categories in the files I uploaded (yeah, my german is poor)
sturmy
WR.net Expert
WR.net Expert
 
Posts: 160
Joined: Wed Aug 16, 2006 9:07 pm

Error Msg for CGB

Postby Fifi » Tue Feb 06, 2007 4:55 am

I applied Sturmy file posted above

got following msg

Notice: Undefined variable: item_color in /mnt/138/sdc/c/f/hordeuxheureux/roster/addons/guildbank/gbank.php on line 568

Notice: Undefined variable: item_color in /mnt/138/sdc/c/f/hordeuxheureux/roster/addons/guildbank/gbank.php on line 568

and then my bank content correctly shown.
Fifi
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Sun Nov 12, 2006 11:32 pm

Error Msg for CGB

Postby Romosh » Wed Feb 07, 2007 3:03 am

Notice: Undefined index: bankitem_34 in /addons/guildbank/gbank.php on line 327

Notice: Undefined variable: item_color in /addons/guildbank/gbank.php on line 570

Notice: Undefined variable: item_color in /addons/guildbank/gbank.php on line 573

Notice: Undefined variable: item_color in /addons/guildbank/gbank.php on line 576

Notice: Undefined variable: item_color in /addons/guildbank/gbank.php on line 579


this is the error message after "patching" the sript
Last edited by Romosh on Wed Feb 07, 2007 3:04 am, edited 1 time in total.
Romosh
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Wed Jul 26, 2006 12:58 pm

Re: Error Msg for CGB

Postby Zelete » Sat Feb 10, 2007 4:01 pm

Zelete
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Thu Jan 11, 2007 8:32 am

Error Msg for CGB

Postby Snipes » Sat Feb 17, 2007 1:23 am

I receive the same error message:

Code: Select all
Notice: Undefined variable: item_color in /var/www/roster/addons/guildbank/gbank.php on line 570
Notice: Undefined variable: item_color in /var/www/roster/addons/guildbank/gbank.php on line 573
Notice: Undefined variable: item_color in /var/www/roster/addons/guildbank/gbank.php on line 576
Notice: Undefined variable: item_color in /var/www/roster/addons/guildbank/gbank.php on line 579


Any idea how to fix this? If you want to see yourself: http://www.vaeter-der-horde.de/roster/a ... =guildbank
User avatar
Snipes
WR.net Apprentice
WR.net Apprentice
 
Posts: 20
Joined: Wed Jul 05, 2006 7:22 pm


Return to Categorized Guild Bank

Who is online

Users browsing this forum: No registered users and 0 guests

cron