Items with wrong or missing images

Theme, template, layout, or image issues

Items with wrong or missing images

Postby Wyren » Wed Feb 07, 2007 4:35 am

I've noticed a couple of items that either have the wrong image linked in WoW Roster, or no image included in the latest image pack. Not sure if this is a CharacterProfiler or WoW Roster issue tho.

Warped Flesh (http://www.thottbot.com/?i=Warped%20Flesh) has a icon that is different to the one in-game, and although the filename for it is the same as the one Thottbot uses, they are different (

Ancient Lichen (http://www.thottbot.com/?i=Ancient%20Lichen) tries to use a image INV_MISC_HERB_ANCIENTLICHEN.jpg when the correct filename is INV_Misc_Herb_AncientLichen.jpg, but that file contains a different graphic than the in-game one.

Ring of the Martyr (http://www.thottbot.com/?i=Ring%20of%20the%20Martyr) tries to use a image INV_jewelry_ring_AhnQiraj_01.jpg when the file in the image pack is called INV_Jewelry_Ring_AhnQiraj_01.jpg. I noticed Thottbot also uses the lower case name for the image, and their image pack also is with Caps, so they don't show the icon for this :)

As I said, this might be a CP issue, but I'm not sure:
Last edited by Wyren on Wed Feb 07, 2007 4:43 am, edited 1 time in total.
Wyren
WR.net Journeyman
WR.net Journeyman
 
Posts: 81
Joined: Wed Jul 26, 2006 3:07 pm

Items with wrong or missing images

Postby zanix » Wed Feb 07, 2007 5:00 am

We extract icons directly from the game's mpq files
And CP uses the games API to get the filename of the icon requested

IMHO, thottbot is wrong
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Items with wrong or missing images

Postby Wyren » Wed Feb 07, 2007 6:52 am

zanix wrote:We extract icons directly from the game's mpq files
And CP uses the games API to get the filename of the icon requested

IMHO, thottbot is wrong


If thottbot is wrong, so is wow roster, since you're using the same images/filenames :)
Wyren
WR.net Journeyman
WR.net Journeyman
 
Posts: 81
Joined: Wed Jul 26, 2006 3:07 pm

Items with wrong or missing images

Postby Steampark » Wed Feb 07, 2007 7:59 am

You can easily bypass this by using two files with both names, as Unix servers will manage these files as two separate ones.
You can keep one with the normal name and one with the capital letters side to side, whenever thottbot or CP or anything will change your pictures will be ok.

Ok, my english is rusty and i don't know if i can be understood so here's an example, on my server i have two files :
One is
INV_MISC_HERB_ANCIENTLICHEN.jpg
The other one is
INV_Misc_Herb_AncientLichen.jpg

So if any name provider changes its base name, my picture will be good.
Steampark
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Feb 05, 2007 1:56 pm

Re: Items with wrong or missing images

Postby Wyren » Wed Feb 07, 2007 8:44 am

Steampark wrote:You can easily bypass this by using two files with both names, as Unix servers will manage these files as two separate ones.
You can keep one with the normal name and one with the capital letters side to side, whenever thottbot or CP or anything will change your pictures will be ok.

Ok, my english is rusty and i don't know if i can be understood so here's an example, on my server i have two files :
One is
INV_MISC_HERB_ANCIENTLICHEN.jpg
The other one is
INV_Misc_Herb_AncientLichen.jpg

So if any name provider changes its base name, my picture will be good.


Yes, and that is what I've done. But for the Anchient Lichen, the image is not corresponding to the in-game image for some reason.
Wyren
WR.net Journeyman
WR.net Journeyman
 
Posts: 81
Joined: Wed Jul 26, 2006 3:07 pm

Items with wrong or missing images

Postby zanix » Wed Feb 07, 2007 6:59 pm

Wyren
LoL, I though you were comparing ours to thott's

When I have some time, I'll get the icon re-extracted and re-processed
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Items with wrong or missing images

Postby robojerk » Wed Feb 21, 2007 9:54 am

http://www.blacktemplars.org/index.php? ... ction=mail

INV_MISC_HERB_ANCIENTLICHEN.jpg still not showing up.. I have the 2.05 image pack


Image
Last edited by robojerk on Wed Feb 21, 2007 9:55 am, edited 1 time in total.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Re: Items with wrong or missing images

Postby robojerk » Fri Feb 23, 2007 6:53 pm

Here is a 40x40 jpg..
Attachments
icons.zip
(1.49 KiB) Downloaded 93 times
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Re: Items with wrong or missing images

Postby Dohko » Mon Apr 16, 2007 5:52 pm

Hello,

I've noticed "Couronne du savoir infini" (Crown of Endless Knowledge in english) have no image included in the image pack.

image
Dohko
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Mon Jan 08, 2007 6:29 am

Items with wrong or missing images

Postby LaughingJon » Fri May 11, 2007 8:08 pm

I am finding that there are quite a few icons which have slight discrepancies in their names specifically the letter case

Few examples of could include:

Name being linked to
INV_Weapon_Shortblade_05.jpg
image name
INV_Weapon_ShortBlade_05.jpg

Name being linked to
INV_Weapon_Shortblade_15.jpg
image name
INV_Weapon_ShortBlade_15.jpg

Name being linked to
INV_Misc_Stonetablet_11.jpg
Image name
INV_Misc_StoneTablet_11.jpg

Name being linked to
ABILITY_POISONS.jpg
Image name
Ability_Poisons.jpg

There are many more.

These variations seem to differ between files which are included in the icon pack to varying degrees.

These errors are occurring for characters uploaded via Character Profiler and also via a Bliz Armory import.

Any Ideas?
Cheers

*edit

i am hosting via Linux servers which is why this is an issue i assume.
Last edited by LaughingJon on Fri May 11, 2007 8:09 pm, edited 1 time in total.
LaughingJon
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Mon Jul 17, 2006 1:33 pm

Items with wrong or missing images

Postby PleegWat » Fri May 11, 2007 8:29 pm

We're aware of this problem. It's a fairly recent issue where the referenced icon name and the actual name don't always match, and it originates with blizzard.

Starting roster 1.8.0, this is fixed in exactly the same way blizz's armory gets around it: We use lowercase only names.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Items with wrong or missing images

Postby LaughingJon » Fri May 11, 2007 8:44 pm

lol awsome

if i run a script to change all the icon files to lower case and update item.php out() function to set lower case for $item_texture that would get them working for now right?

if you know off the top of your head is there anywhere else i would need to add the lowercase within the roster code?

cheers
Jon
LaughingJon
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Mon Jul 17, 2006 1:33 pm

Items with wrong or missing images

Postby PleegWat » Fri May 11, 2007 11:30 pm

Well, that's the solution we're using for 1.8. In a current install, I think you're better off copying the icon with the wrong case in the few cases where it happens. The icon packs are referenced all over roster.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Items with wrong or missing images

Postby LaughingJon » Fri May 11, 2007 11:48 pm

arrr kk think i may leave it then hehe.. over 400 chars is going to take some time to sort out the bad links ><

thanks for ya time and the heads up on 1.8!
LaughingJon
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Mon Jul 17, 2006 1:33 pm


Return to Appearance

Who is online

Users browsing this forum: No registered users and 1 guest

cron