[A FIX FOR] The remote server returned an error: (403)

Support and feedback for UniUploader
UniUploader requires microsoft .net runtimes!

[A FIX FOR] The remote server returned an error: (403)

Postby MattM » Thu Jul 13, 2006 7:16 am

Code: Select all
System.Net.WebException: The remote server returned an error: (403) Forbidden.


I made a file named
Code: Select all
.htaccess
with the contents
Code: Select all
<Files *.*>
allow from all
</Files>
and it fixed it.

dont know if it will work for anyone else, but here ya go :flower:
Last edited by MattM on Sun Dec 24, 2006 12:29 am, edited 1 time in total.
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

[A FIX FOR] The remote server returned an error: (403)

Postby blackslash » Thu Jul 13, 2006 12:09 pm

where i must put this file?
blackslash
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Wed Jul 05, 2006 8:11 pm

Re: [A FIX FOR] The remote server returned an error: (403)

Postby majhlex » Fri Jul 14, 2006 11:18 pm

I have a new install of UA. I encountered the 403 error and came to the forums.

I replaced an existing, empty .htaccess file with one having the fix. Still getting:

[2006/07/14 14:51:50] Uploading to Primary URL...: http://xxxxxxxx.com/roster/admin/update.php
[2006/07/14 14:51:50] CharacterProfiler.lua - No Compression. Upload Size: 0 KB
[2006/07/14 14:51:51] Upload Error: The remote server returned an error: (403) Forbidden.
[2006/07/14 14:51:51] Data Retrieval Error: The remote server returned an error: (403) Forbidden.
[2006/07/14 14:51:51]
[2006/07/14 14:51:51] RetrData: url: http://xxxxxxxxx.com/uniadmin/interface.php
[2006/07/14 14:51:51] RetrData: param1: OPERATION
[2006/07/14 14:51:51] RetrData: val1: GETDATA
[2006/07/14 14:51:51] RetrData: param2: username
[2006/07/14 14:51:51] RetrData: val2: uuuuuuuu
[2006/07/14 14:51:51] RetrData: param3: password
[2006/07/14 14:51:51] RetrData: val3: ppppppp
[2006/07/14 14:51:51] RetrData: Timeout: -1
[2006/07/14 14:51:51] RetrData: ------------------------------------------------------------------------
[2006/07/14 14:51:51]
[2006/07/14 14:51:51] RetrData: ------------------------------------------------------------------------
[2006/07/14 14:51:51]


There are additional htaccess files in my public_html folder. These have data:

htm.htaccess
html.htaccess
phtml.htaccess
Last edited by majhlex on Fri Jul 14, 2006 11:56 pm, edited 2 times in total.
majhlex
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Fri Jul 14, 2006 8:34 pm
Location: MA

[A FIX FOR] The remote server returned an error: (403)

Postby Darzoul » Mon Sep 04, 2006 2:05 am

My whole guild is getting this error since the end of August.

Code: Select all
[2006/09/03 17:01:19] MD5SUM of local LICENSE.TXT: 3e51ce44ec803bd6bc42e7d8870f5962
[2006/09/03 17:01:19] v2.4.1 Ready.
[2006/09/03 17:01:20]  UpdateAddons Debugging process started
[2006/09/03 17:01:20] Retrieving XML data.
[2006/09/03 17:01:20] Data Retrieval Error: The remote server returned an error: (403) Forbidden.
[2006/09/03 17:01:20]
[2006/09/03 17:01:20] RetrData: url: http://www.sircasm.com/UniUploader/interface.php
[2006/09/03 17:01:20] RetrData: param1: OPERATION
[2006/09/03 17:01:20] RetrData: val1: GETADDONLIST
[2006/09/03 17:01:20] RetrData: Timeout: -1
[2006/09/03 17:01:20] RetrData: ------------------------------------------------------------------------
[2006/09/03 17:01:20]
[2006/09/03 17:01:20] RetrData: ------------------------------------------------------------------------
[2006/09/03 17:01:20]
[2006/09/03 17:01:20] Beginning the XML document parsing
[2006/09/03 17:01:20] UpdateAddons: The root element is missing.

I have checked permissions and added the .htaccess suggesed fix.
Any suggestion as to what root element it thinks is missing?
Darzoul
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Sat Sep 02, 2006 3:18 am

[A FIX FOR] The remote server returned an error: (403)

Postby MattM » Mon Sep 04, 2006 2:34 am

not sure, i think it may be that your server might have implemented another security module for your apache server?
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

[A FIX FOR] The remote server returned an error: (403)

Postby Darzoul » Mon Sep 04, 2006 3:28 am

hmmm I will check into that, thanks.
Darzoul
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Sat Sep 02, 2006 3:18 am

Re: [A FIX FOR] The remote server returned an error: (403)

Postby carlpalmer » Wed Sep 06, 2006 9:24 pm

I am still having problems with this. Did anyone find more information about it?
User avatar
carlpalmer
WR.net Apprentice
WR.net Apprentice
 
Posts: 24
Joined: Fri Jul 21, 2006 4:27 am

Re: [A FIX FOR] The remote server returned an error: (403)

Postby MattM » Thu Sep 14, 2006 7:48 am

MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

[A FIX FOR] The remote server returned an error: (403)

Postby Darzoul » Sun Sep 17, 2006 6:17 am

Well I tried working with my web host on this issue.

Code: Select all
Subject: permission error
Details: I have a program that I need to connect to my site it uses a ftp to send information up and to get certain information and download if needed.
It was working just fine till august 23rd. I have not had a lot of time till lately to dig into it.

[2006/09/16 08:53:26] UpdateAddons Debugging process started
[2006/09/16 08:53:26] Retrieving XML data.
[2006/09/16 08:53:26] Data Retrieval Error: The remote server returned an error: (403) Forbidden.
[2006/09/16 08:53:26]
[2006/09/16 08:53:26] RetrData: url: http://www.sircasm.com/UniUploader/interface.php
[2006/09/16 08:53:26] RetrData: param1: OPERATION
[2006/09/16 08:53:26] RetrData: val1: GETADDONLIST
[2006/09/16 08:53:26] RetrData: Timeout: -1
[2006/09/16 08:53:26] RetrData: ------------------------------------------------------------------------
[2006/09/16 08:53:26]
[2006/09/16 08:53:26] RetrData: ------------------------------------------------------------------------
[2006/09/16 08:53:26]
[2006/09/16 08:53:26] Beginning the XML document parsing
[2006/09/16 08:53:26] UpdateAddons: Root element is missing.

It is the 403 error that has me puzzled. I do not see where it would be blocked. So it is not able to read the root element. I was wondering if for some reason my program got blocked. The program connects to two different folder locations one is www.sircasm.com/roster/admin/ the other is http://www.sircasm.com/UniUploader/

Thank you for your time and anything you can find out to help me reslove this.


--------------------------------------------------------------------------------

Support Replies

From: Sukesh
Reply Time: 9/16/2006 9:05:52 AM
Reply: Hi Glynn,

We have access your domain and provided URL's without any error. We are able to connect FTP using provided username and password. Files and folders permission are fine on server.

Thank you,
Sukesh
Technical Support


Still get the 403 error even after a reinstall of the uniadmin. I looked at the link do I need to just wait for the uni 7.0?
Darzoul
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Sat Sep 02, 2006 3:18 am

[A FIX FOR] The remote server returned an error: (403)

Postby zanix » Sun Sep 17, 2006 6:58 am

UU doesn't use ftp, at all
It uses http to download, and post data
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

[A FIX FOR] The remote server returned an error: (403)

Postby MattM » Sun Sep 17, 2006 8:29 pm

the host misinterpreted Darzoul's problem, and gave him a canned response.

Darzoul, UU2.5RC4 should NOT give you the
Code: Select all
The remote server returned an error: (403) Forbidden.
no matter what version of UA you have set up.
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

[A FIX FOR] The remote server returned an error: (403)

Postby Darzoul » Thu Sep 28, 2006 10:58 pm

I still have not found a fix, there is nothing on the webhost side according to them that would do this. Also I can get to the urls with no problems that uniuploader is supposed to connect to.

http://www.sircasm.com/UniUploader/interface.php

also here is code just trying to upload data for the profiler
Code: Select all
[2006/09/28 13:59:52] Uploading to Primary URL...: http://www.sircasm.com/roster/admin/update.php
[2006/09/28 13:59:52] CharacterProfiler.lua - No Compression. Upload Size: 577 KB
[2006/09/28 13:59:52] PvPLog.lua - No Compression. Upload Size: 227 KB
[2006/09/28 14:00:20] Upload Error: The remote server returned an error: (403) Forbidden.


I would really like to see this working, but so far my whole guild is out of luck. It does seem like to me that it would be with the webhost.
Last edited by Darzoul on Thu Sep 28, 2006 11:02 pm, edited 1 time in total.
Darzoul
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Sat Sep 02, 2006 3:18 am

[A FIX FOR] The remote server returned an error: (403)

Postby Darzoul » Thu Sep 28, 2006 11:11 pm

I am again sending another request to the webhost, as I have tried it to a local server and it worked fine. So again it is pointing to some sort fo permission issue on the webhost ( which is getting very frustrating now).

The server is running apache on a linux box.
Last edited by Darzoul on Thu Sep 28, 2006 11:12 pm, edited 1 time in total.
Darzoul
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Sat Sep 02, 2006 3:18 am

[A FIX FOR] The remote server returned an error: (403)

Postby PleegWat » Thu Sep 28, 2006 11:26 pm

mod_security might be doing it. It might block unknown user agents. I assume the malformed post issue is resolved in this version?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

[A FIX FOR] The remote server returned an error: (403)

Postby Darzoul » Fri Sep 29, 2006 1:14 am

Oh how I am really not liking the response I shot back at them. Here is the response the IT dept gave me.

Code: Select all
We are able to upload the files using your provided URL http://www.sircasm.com/roster/admin/update.php. We are not getting "Upload Error: The remote server returned an error: (403) Forbidden." error, please provide exact URL where you are facing problem so, that we can investigate further.

Please let us know if there is anything else we can do to help.

Thank you,
Technical Support

Now the first thing is I provided the links to them so they had them. Next is that I tried to make the connection at other spots of my domain and got the 403 error, so I have replied detialing that is clearly a server side issue and i included some of your thougths to this mod_security blocking agents from connecting if they are not known. Maybe this time they will actually take the time to look into it. Or maybe it might be better to just change webhosts.

Thanks for your input again!
Last edited by Darzoul on Fri Sep 29, 2006 1:15 am, edited 1 time in total.
Darzoul
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Sat Sep 02, 2006 3:18 am

Next

Return to UniUploader

Who is online

Users browsing this forum: No registered users and 0 guests

cron