Problem since last update

CharacterProfiler.lua file uploading issues

Problem since last update

Postby Vortilion » Sat Feb 10, 2007 3:35 pm


since my last roster-update I get following error-message and I can't see any members anymore:

Warning: array_keys(): The first argument should be an array in /www/htdocs/w0080356/roster/update.php on line 311

Warning: Invalid argument supplied for foreach() in /www/htdocs/w0080356/roster/update.php on line 311

Warning: Division by zero in /www/htdocs/w0080356/roster/lib/menu.php on line 10

I didn't change anything, before it worked, then, suddenly, this error appeared.
Last edited by Vortilion on Sat Feb 10, 2007 4:29 pm, edited 1 time in total.
Vortilion Apprentice Apprentice
Posts: 8
Joined: Thu Aug 10, 2006 6:17 am

Re: Problem since last update

Postby Vortilion » Mon Feb 12, 2007 2:14 pm

Vortilion Apprentice Apprentice
Posts: 8
Joined: Thu Aug 10, 2006 6:17 am

Problem since last update

Postby pyrran » Mon Feb 12, 2007 4:55 pm


I also have this problem. Roster had been working fine for some time now (with all the wowbd and luaparser fixes in place) - then all of a sudden the errors listed above appeared.

Checking the member log showed everyone in the guild being removed at exactly the same time and day. I'm using the latest CP and GP addons (2.0.5) as are my guild members (although they arent using GP atm - that's just me as i dont want to throw open the roster/guild-update password to everyone in the guild).

Digging into the sql database shows practically all the core roster tables as being empty - as perhaps they should be if they have been "removed" as shown in the member log. It would appear at first glance that it's the "empty" database that's causing the errors listed above in the OP.

I have deleted my CharacterProfiler.lua files, and forced an export of the data from within the game in an attempt to repopulate the database and get Roster behaving normally once again - but to no avail. :-(

Uploading the data manually (as opposed to using UU) - shows that all characters arent in the guild so the parser doesnt insert their data. Checking the lua file shows that the guild name in both the lua data file and the roster config is identical - so therefore should match. RosterDiag shows "No Issues" for all files.

I have not tried dropping the tables and re-installing Roster as yet, as I feel unless I know what caused this to happen, it could easily happen again at some future point. Is it a user trying to upload an incorrect/corrupted file? (An update log accessible in the admin screen would help here!) Has CP/GP developed a bug with the current patch of the game itself?

If you need further info - just let me know as currently my Roster is still "broken" (The Irresponsibles Site)

Any ideas?

Many thanks.
pyrran Apprentice Apprentice
Posts: 2
Joined: Thu Dec 21, 2006 5:44 am

Return to Uploading

Who is online

Users browsing this forum: No registered users and 0 guests