Greeting Everyone!

A signature and avatar generator addon

Moderator: zanix

Greeting Everyone!

Postby Haiasi » Wed Feb 14, 2007 3:06 pm

Now this might be because I'm an idiot at this sort of thing, but here's what I did. I uploaded the folder to the addons folder and when I refreshed my roster, it showed a button labeled "Roster Config." naturally I clicked that, installed the tables, and was in the config page. I was able to adjust the avatar and preview it. However I switched to Signature and found this.

(see siggenerror1 and siggenerror2)

I dont know what to do or how to change the setting in the second picture. Help would be very appreciated.
Attachments
siggenerror2.jpg
second screenshot, depicting setting that is locked.
siggenerror2.jpg (20.14 KiB) Viewed 396 times
siggenerror1.jpg
1st screenshot, depicting errors, or at least things that aren't right.
siggenerror1.jpg (97.22 KiB) Viewed 396 times
Haiasi
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Feb 13, 2007 3:11 am

Greeting Everyone!

Postby vbdh » Wed Feb 14, 2007 5:29 pm

Im getting the same prob it will show Avatar when you have it showing in config mode but will will not show sig .

any help would be great

thanks
Long Live The Fighters
User avatar
vbdh
WR.net Apprentice
WR.net Apprentice
 
Posts: 45
Joined: Wed Jan 03, 2007 12:48 pm

Greeting Everyone!

Postby zanix » Wed Feb 14, 2007 9:03 pm

There is no regular SigGen button
If you read the documentation, you would know this and also how to check for errors
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Greeting Everyone!

Postby Haiasi » Wed Feb 14, 2007 10:13 pm

Ok then why do I see other rosters with a button labeled "SigGen?"

I'm trying to figure out what's wrong, but this addon is becoming a major pain to set up. Can you at least explain in more detail what that locked setting on the config page is looking for (i.e. specific folder name) and how to repair it?
Haiasi
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Feb 13, 2007 3:11 am

Greeting Everyone!

Postby zanix » Wed Feb 14, 2007 10:20 pm

Ok then why do I see other rosters with a button labeled "SigGen?"

Because they have an older version of SigGen

Hover over the text "Save Image Functions Disabled" to get a tooltip and it will tell you why they are locked

There may also be a message under the roster menu

Try viewing the image itself in a separate window
roster/addons/siggen/sig.php?name=CharName

If you get a blank screen, hit view source
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Greeting Everyone!

Postby Haiasi » Thu Feb 15, 2007 12:39 am

I dont know, maybe it was just the current installation. I uninstalled and put it up fresh and now it's operating properly. I just have to put the new version up now.

One question that is bugging me though. How can other guild members edit their sig? does it have to be within the siggen config which requires a password or can they go to a public editor?
Last edited by Haiasi on Thu Feb 15, 2007 12:41 am, edited 1 time in total.
Haiasi
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Feb 13, 2007 3:11 am

Greeting Everyone!

Postby zanix » Thu Feb 15, 2007 4:25 am

SigGen's settings are global
The only per-character setting is the upload of the custom images

SigGen was never designed with this in mind since Roster doesn't provide a user auth system
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Greeting Everyone!

Postby Haiasi » Thu Feb 15, 2007 1:04 pm

Alright. And I've been fiddling with the sig and avatar, and maybe there's something I'm missing, but how do you save them to the folder and use them in forums and such?
Haiasi
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Feb 13, 2007 3:11 am

Greeting Everyone!

Postby zanix » Thu Feb 15, 2007 11:29 pm

Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to SigGen

Who is online

Users browsing this forum: No registered users and 0 guests

cron