Error with sync (with uniadmin)

Support and feedback for UniUploader
UniUploader requires microsoft .net runtimes!

Error with sync (with uniadmin)

Postby Strahd » Mon Feb 26, 2007 11:40 pm

Hi!

I've reported this bug in uniadmin forum, but a dev told me to put it here.

When I upload a new addon to uniadmin everything goes OK (in database and the zip file is complete) but when I sync with uniuploader, only 4 files out of many go into the addon folder (the main 4 ones).

The URL of the addon is: http://ui.worldofwar.net/ui.php?id=3972
Name: GuildBankAccount

The debug code is in the attachment and, as u can see, there are more files besides the ones extracted in the zip file (accesible, so you may download it to check). The files getting extracted are:

GuildBankAccount.lua
GuildBankAccount.toc
GuildBankAccount.xml
GuildBankAccountTemplates.xml

The rest aren't unzipped and, if they where previusly there (from a manual unzip) they are erased

Any ideas?

Thanks!
Attachments
debug.txt
Debug info
(11.16 KiB) Downloaded 73 times
Strahd
WR.net Apprentice
WR.net Apprentice
 
Posts: 15
Joined: Thu Feb 22, 2007 2:45 pm

Re: Error with sync (with uniadmin)

Postby Strahd » Mon Feb 26, 2007 11:54 pm

Aditional info:

There was a file missing in the zip file called Readme-GuildBankAccount.txt. I've putted the file and now everything got extracted (after, by the way, creating the directory Images manually, but I know it's a fixed bug in the next version).

I think UU should extract the *rest* of the files, if an error occurs, shouldn't it?

either way, sorry for not noticing the missing .txt file
Strahd
WR.net Apprentice
WR.net Apprentice
 
Posts: 15
Joined: Thu Feb 22, 2007 2:45 pm

Error with sync (with uniadmin)

Postby jlaplaca » Mon Feb 26, 2007 11:56 pm

The developer of UniUploader is working hard on fixing this problem. The problem is that UU is only creating 1 folder for the addon, but it's not creating the other sub-folders in that addon folder. I have made a hotfix that fixed the problem, but plz wait for the developer to release a update to UU.
User avatar
jlaplaca
WR.net Apprentice
WR.net Apprentice
 
Posts: 18
Joined: Sun Feb 18, 2007 6:03 am
Location: Rocheser,NY

Re: Error with sync (with uniadmin)

Postby Strahd » Tue Feb 27, 2007 12:01 am

Yes, that's why i said the subdir thing was an issue solved in the next release. They're doing a perfect job, it's a must-have in my opinion, sorry if my english gave the wrong impresion.

Now that I know it was the missing file thing, the devs can see this, and maybe do something with it.

But it's a minor error, cause all it has to be done is to upload propper zip files, not crappy-file-missing ones! :P
Strahd
WR.net Apprentice
WR.net Apprentice
 
Posts: 15
Joined: Thu Feb 22, 2007 2:45 pm

Error with sync (with uniadmin)

Postby MattM » Tue Feb 27, 2007 2:16 am

all fixed in 2.6.2 guys! thanks for hanging in there :)
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA


Return to UniUploader

Who is online

Users browsing this forum: No registered users and 0 guests

cron