[FIXED] WebStart fails on Mac, requires Java 6

Support and feedback for NetherPanel
AKA java UniUploader

Re: Need help getting it to run at all on a mac

Postby Auronani » Sun Apr 15, 2007 2:54 am

I am running on a Mac as well. Mac Mini 1.43 PPC with a gig of ram and running 10.4.9 with JRE 1.5.0_07. I get the splash screen and then it dies.

This is what i get in Console:

#### Java Web Start Error:
#### The application has requested a version of the JRE (version 1.6+) that currently is not locally installed. Java Web Start is unable to automatically download and install the requested version. This JRE must be installed manually.
2007-04-14 13:41:33.207 Camino[597] JEP creating applet testvm (http://java.com/applet/)
TestVM 3.1 kc
Copyright (c) 2005 Sun Microsystems, Inc.
All Rights Reserved.


As JRE 1.6 is only released as a development pack on mac I feel uncomfortable installing it. I'm hearing it will be standard issue in Leopard though.

I am unsure if there is anything else I might be able to do to get it to run. thanks
Auronani
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Sun Sep 03, 2006 11:46 pm

[FIXED] Need help getting it to run at all on a mac

Postby zanix » Sun Apr 15, 2007 3:53 am

On Windows it had a similar error
lhunath said he released 0.9.6.1 that should fix this problem

Try re-downloading jUU
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

[FIXED] Need help getting it to run at all on a mac

Postby Auronani » Sun Apr 15, 2007 4:23 am

I just downloaded it today and have tried downloading it three different times...no go.

I've been looking for an archive of 0.9.6.1 to see if that would work but can't find one.
Last edited by Auronani on Sun Apr 15, 2007 4:25 am, edited 1 time in total.
Auronani
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Sun Sep 03, 2006 11:46 pm

[FIXED] Need help getting it to run at all on a mac

Postby zanix » Sun Apr 15, 2007 4:45 am

Hmm, I remember him talking about it :(
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

[FIXED] Need help getting it to run at all on a mac

Postby lhunath » Sun Apr 15, 2007 5:20 pm

The problem I fixed in 0.9.6.1 is unrelated with the problem you're experiencing. It is also still fixed in the latest version, so there's no need to dig for archived versions.

Your problem is that my WebStart is configured to request Java 6 installed; while it is not available for Mac. I will adjust the WebStart settings to be satisfied with a Java 5.

Please be aware that Java 5 does not support all the features built into jUU. Some things will not be available to you, such as launching browser windows using the homepage and forum buttons, using the System Tray icon, sending an email bug report, and several more things here and there.

Also; this problem is ONLY in the WebStart version. You can still just download the zip and start it that way. Only my WebStart configuration is set to "require" Java 6.

I will adjust the WebStart configuration now to allow Java 5.
"OK, so ten out of ten for style, but minus several million for good thinking, yeah?"
-- Zaphod Beeblebrox


= NetherPanel: home - launch - tickets =
User avatar
lhunath
UA/UU Developer
UA/UU Developer
 
Posts: 201
Joined: Sat Jul 22, 2006 12:32 pm

[FIXED] WebStart fails on Mac, requires Java 6

Postby Auronani » Mon Apr 16, 2007 12:20 am

I actually tried downloading the non-webstart and it did the same thing. Might be worth double checking. I only tried the webstart as a last resort.
Auronani
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Sun Sep 03, 2006 11:46 pm

Re: Need help getting it to run at all on a mac

Postby lhunath » Mon Apr 16, 2007 3:44 am

Auronani wrote:This is what i get in Console:

#### Java Web Start Error:
#### The application has requested a version of the JRE (version 1.6+) that currently is not locally installed. Java Web Start is unable to automatically download and install the requested version. This JRE must be installed manually.
2007-04-14 13:41:33.207 Camino[597] JEP creating applet testvm (http://java.com/applet/)
TestVM 3.1 kc
Copyright (c) 2005 Sun Microsystems, Inc.
All Rights Reserved.

This can only happen with Web Start.

If you had a problem with downloading it normally; then try provide me specific details for that. If something's not working well with jUU on Mac, I need to fix it too.
"OK, so ten out of ten for style, but minus several million for good thinking, yeah?"
-- Zaphod Beeblebrox


= NetherPanel: home - launch - tickets =
User avatar
lhunath
UA/UU Developer
UA/UU Developer
 
Posts: 201
Joined: Sat Jul 22, 2006 12:32 pm


Return to NetherPanel

Who is online

Users browsing this forum: No registered users and 0 guests

cron