Fatal Error

A signature and avatar generator addon

Moderator: zanix

Fatal Error

Postby Missdwarf » Fri Apr 20, 2007 3:18 am

I have just remade a fresh example of Roster 1.7.3 and installed the addons I use - here is the problem. I installed Siggen 0.2.4 too, but when I click "Siggen Config" button I get this:

Fatal Error
GD Functions are not available
SigGen REQUIRES GD with FreeType support

The "More Info" gives me this info:
Roster Diag
Logged in:[Logout]

Realm Status GD image mode enabled (rs_mode = on) in Config but FreeType support was not found.
Either load the Freetype extension in PHP or set (rs_mode = off) in Roster Config
MOTD GD image mode enabled (motd_display_mode = on) in Config but FreeType support was not found.
Either load the Freetype extension in PHP or set (motd_display_mode = off) in Roster Config

Someone knows what I can do? Or what I did wrong? :D

Regards,
Missdwarf
Missdwarf
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 24, 2006 11:15 am

Fatal Error

Postby zanix » Fri Apr 20, 2007 4:34 am

GD isn't enabled on your server
If this is a personal server, you need to edit php.ini to enable GD
If this is a webhost (not a personal server) then you must ask them to enable GD, and hopefully, they will
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Fatal Error

Postby Missdwarf » Fri Apr 20, 2007 4:50 am

TY for your quick responce. I will try contact hoster. :)
Missdwarf
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 24, 2006 11:15 am

Fatal Error

Postby Missdwarf » Mon Apr 23, 2007 2:48 pm

Hoster has now enabled GD at the server and it still aint working. About Freetype he says, that the security will be broken if he adds that, and that I have to edit it myself. But how? :o
Really would love to have the Siggen up working again.
Missdwarf
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 24, 2006 11:15 am

Fatal Error

Postby zanix » Mon Apr 23, 2007 3:29 pm

SigGen will not work without freetype
There is no way around that, sorry

Do they give a reason why security is broken if it is enabled?
I know that many, many major web hosts that have freetype enabled any they are just fine
Last edited by zanix on Mon Apr 23, 2007 3:30 pm, edited 1 time in total.
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Fatal Error

Postby Missdwarf » Mon Apr 23, 2007 4:03 pm

The hoster says, that he added Freetype support and Imagemagic (my mistake I said he didnt).
When I then showed him the Fatal Error he replied, that it will be to huge risk to ruin something in the controlpanel, and that I have to do it myself in config file.. ehm.. :-|
Missdwarf
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 24, 2006 11:15 am


Return to SigGen

Who is online

Users browsing this forum: No registered users and 0 guests

cron