High Latency with UU

Support and feedback for UniUploader
UniUploader requires microsoft .net runtimes!

High Latency with UU

Postby Holgiranemsi » Sun Apr 29, 2007 6:46 pm

Hi Folks,
one more time I would need your help plz for some of our Guild Members. Some of them, not only one, is reporting that when they run the UU (2.6.4) in the background (detect WOW-Exe, find changes, etc.) the latency of the game increases dramatically until the game is unplayable anymore.

When they then go to the desktop and kill the process of UU which is running and waiting for activity the situation comes back to normilization and the game runs fine again.

We tested it and once we restart UU in latency increases again dramatically. It looks as UU might also be a tool to switch ond and switch off latency, but of course thats not true but the effect for them is like this.

What does UU in the background what could effect the messaging of the game? Are there any settings or choices in the option which might cause an ongoing data transmission or at least this bad side effect of a high latency?

Thanks a lot from Germany for some hints
Holgiranemsi
Holgiranemsi
WR.net Journeyman
WR.net Journeyman
 
Posts: 88
Joined: Fri Feb 16, 2007 12:28 pm

High Latency with UU

Postby bbj911 » Sun Apr 29, 2007 8:00 pm

ok running for a location with very flakey latency, i tried exiting uu aswell to see if it makes a diff. it did not.

An ethereal trace shows nothing from uu while it is "idle", only the burst when a file changes, and i think this is what might be their problem. Take a look at cpu load during the time that uu is running and not. I have a suspition its to do with the filesystem notification of a file change ( the ones that uu is watching )

Also, check the debug log and see if uu is doing any uploads during game time ( ie it falsely got a file changed event )
Last edited by bbj911 on Sun Apr 29, 2007 8:00 pm, edited 1 time in total.
User avatar
bbj911
WR.net Apprentice
WR.net Apprentice
 
Posts: 61
Joined: Mon Oct 23, 2006 6:47 pm

High Latency with UU

Postby MattM » Mon Apr 30, 2007 12:23 am

I used to get that climbing latency problem whenever I enter an instance. I wasnt using UU though.
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

High Latency with UU

Postby foreseit » Tue May 01, 2007 5:50 am

I also have a latency problem, although it appears to be different. I have 2 computers running on my dsl connection. I have UU set to upload whenever the file changes. Every time I log off & the lag on the other computer becomes tremendous. After a few seconds (after UU completes its upload) the lag disappears.

If I manually upload the characterprofiler.lua & pvplog.lua files, there is no noticable lag on the other computer. What in UU is so different about manually uploading the files?

Thanks!
<a href="thehateguild.com"><img src="/anetheron/addons/siggen/sig.php?name=Foreseit"></a>
User avatar
foreseit
WR.net Journeyman
WR.net Journeyman
 
Posts: 139
Joined: Tue Jul 25, 2006 10:03 pm

High Latency with UU

Postby MattM » Wed May 02, 2007 2:46 pm

please post the debug log
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

Re: High Latency with UU

Postby foreseit » Fri May 04, 2007 7:32 am

Hope this tells something. Attaching my log.
Attachments
debug log.txt
(251.89 KiB) Downloaded 73 times
<a href="thehateguild.com"><img src="/anetheron/addons/siggen/sig.php?name=Foreseit"></a>
User avatar
foreseit
WR.net Journeyman
WR.net Journeyman
 
Posts: 139
Joined: Tue Jul 25, 2006 10:03 pm

High Latency with UU

Postby MattM » Fri May 04, 2007 9:47 pm

thats your problem right there

Code: Select all
[2007/05/02 18:52:31] CharacterProfiler.lua - No Compression. Upload Size: 1072 KB


turn GZIP compression on and the lag should diminish greatly
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

High Latency with UU

Postby foreseit » Mon May 07, 2007 11:58 am

If I turn GZIP compression on, do I need to change any settings on the website? Does the roster software, with a default install, normally gzip compress when uploading through the update profile webpage?
<a href="thehateguild.com"><img src="/anetheron/addons/siggen/sig.php?name=Foreseit"></a>
User avatar
foreseit
WR.net Journeyman
WR.net Journeyman
 
Posts: 139
Joined: Tue Jul 25, 2006 10:03 pm

High Latency with UU

Postby zanix » Mon May 07, 2007 12:42 pm

Roster will handle gzip compressed lua uploads just fine
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to UniUploader

Who is online

Users browsing this forum: No registered users and 0 guests

cron