"Run Update Triggers" missing from update page

Installation issues with WoWRoster

"Run Update Triggers" missing from update page

Postby corporeal » Tue May 15, 2007 10:19 pm

I have recently updated to the latest version (1.73), setup from scratch, no migration of old files or data.

I did have the problem where my files were renamed to be lower case, I resolved this by renaming the files to include upper case characters where necessary (localization files and fonts).

Everything seems to be working well with the exception of the check box to run update triggers on my update page.

I realize this is probably something simple I am missing, but I have been combing through the forums without finding a solution. Can anyone clue me in, or possibly give me a better idea what to query the forums for?

I should mention the reason I want to run update triggers is to prompt siggen to do it's image creation process.

Thanks in advance
Last edited by corporeal on Tue May 15, 2007 10:21 pm, edited 2 times in total.
corporeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Mon Jul 17, 2006 3:12 am

"Run Update Triggers" missing from update page

Postby PleegWat » Tue May 15, 2007 10:37 pm

This is not a switch in the update page. It is an option in the roster config page, main config tab.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: "Run Update Triggers" missing from update page

Postby corporeal » Tue May 15, 2007 10:47 pm

PleegWat wrote:This is not a switch in the update page. It is an option in the roster config page, main config tab.


Yah, I have the "Addon Update Triggers" option set to yes on that page, sorry I forgot to mention that.

My old version had a check box I would check when doing guild updates. Maybe it does not work that way anymore and I'm just not understanding the new way it works?
corporeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Mon Jul 17, 2006 3:12 am

"Run Update Triggers" missing from update page

Postby PleegWat » Tue May 15, 2007 11:20 pm

Ah, for guild updates. There is only 1 update page since 1.7.0, at roster/update.php. You have to enter your pass to update the guild list, otherwise only your characters are uploaded.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: "Run Update Triggers" missing from update page

Postby corporeal » Tue May 15, 2007 11:29 pm

PleegWat wrote:Ah, for guild updates. There is only 1 update page since 1.7.0, at roster/update.php. You have to enter your pass to update the guild list, otherwise only your characters are uploaded.


hmmmm... and that is the process that kicks the siggen triggers in the butt?

I wonder why mine is not generating images when I do it than... I'll keep playing with it....
corporeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Mon Jul 17, 2006 3:12 am

"Run Update Triggers" missing from update page

Postby zanix » Wed May 16, 2007 12:08 am

SigGen also has a config for the update triggers as well
Make sure you look there
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: "Run Update Triggers" missing from update page

Postby corporeal » Wed May 16, 2007 1:03 am

zanix wrote:SigGen also has a config for the update triggers as well
Make sure you look there



Yah, I have "Auto-save images on guild update" and "Auto-save image on character update" set to yes as well... However, no image creation. I combed through the original zip to see if I missed any other files that would have been affected by the lowercase / upper case thing, but the fonts and the localization stuff seems to be the only things affected by that.

I'm puzzled, is there an actual addon I have to install to perform these triggers? Or is in incorporated with the main install pack? :scratch:
corporeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Mon Jul 17, 2006 3:12 am

Re: "Run Update Triggers" missing from update page

Postby corporeal » Wed May 16, 2007 1:05 am

Is there a way to run the triggers from a url? Other than performing updates I mean? I suppose they are part of the same process...
corporeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Mon Jul 17, 2006 3:12 am

Re: "Run Update Triggers" missing from update page

Postby corporeal » Wed May 16, 2007 1:25 am

It is working now, there is no checkbox, the options I listed above are sufficient. You can not re-upload the same .lua file over and over again or it does not trigger anything, once I logged into game and updated my .lua to be current it did the triggers.

Perhaps someone else will learn from my noobism :blackeye:

Thanks for your help!
Last edited by corporeal on Wed May 16, 2007 1:27 am, edited 1 time in total.
corporeal
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Mon Jul 17, 2006 3:12 am

"Run Update Triggers" missing from update page

Postby PleegWat » Wed May 16, 2007 4:21 am

Yeah, there's a check in so guild data in older CP files isn't accepted, which doesn't reprocess guild data from the same one a second time either. (or did we add that one after 1.7.3?)

There is no way to launch all update triggers on existing data. Addons may offer that feature though (AltMonitor does).
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron