Errors when clicking links on char page and others.

Dragonfly integration forum

Errors when clicking links on char page and others.

Postby robinvfr » Tue Jul 18, 2006 7:40 pm

I've installed WoWRoster and most every thing works great except for a few things.

(1) When clicking on the links at the top of the Char page (Character Status, Spellbook, Bags...) I get the error like:
Not Found
The requested URL /start/cvsroster/char/cname=Bluerox/server=Bonechewer.html&action=character was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.36 Server at www.bovinasancta.us Port 80


Notice the path, it's looking for a /char/ dir that doesn't exist.

(2) I get a similare error with the "Addons" links on the main page:

Not Found
The requested URL /start/cvsroster/addon.html&roster_addon_name=ItemSets&tierselect&classfilter was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.



(3) In RosterDiag I get the follwowing error under "List of Table in [dragonfly]":

includes/db/db.php
* CMS Warning line 51: On /start/cvsroster/rosterdiag.html While executing query "SHOW TABLES FROM dragonfly" the following error occured: Access denied for user 'bovina_dfuser'@'localhost' to database 'dragonfly' In: /home/bovina/public_html/start/modules/cvsroster/lib/wowdb.php on line: 59




I'm not a programmer, but working with Dragonfly and formerly PHPNuke for a couple years, I've become familiar with the basics of PHP and mySQL. If someone can point me in the write direction, I would be very grateful.

A bit about my install:

URL: bovinasancta.us
Dragonfly Version: 9.0.6.1

Main Settings

SQL Debug Output = on
Min CP Version = 1.5.2
Min GP version = 1.5.1
Min PvPLog version = 0.5.0
Roster Main Language = >enUS<
URL for header logo = img/wowroster_logo.jpg
Website Address = bovinasancta.us/start/
Roster URL = modules/cvsroster
char.php Compatibility Mode = off
Interface Directory URL = modules/cvsroster/img/
Interface Image Extension = >jpg<
Roster Images Directory URL = modules/cvsroster/img/
Timezone = pst
Time Offest = >0<
Allow upload of PvPLog Data = yes
Addon Update Triggers = on


Basic Server Info:
OS Linux
Server Software Apache/1.3.36 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.11 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.27 OpenSSL/0.9.7a
MySQL Version 4.1.19-standard


PHP Settings phpinfo() page
PHP Version 4.3.11
PHP API Type apache
safe_mode Off
open_basedir Off
allow_url_fopen On
file_uploads On
upload_max_filesize 2M


Config Values Show Entire $roster_conf array
version 1.7.0
db_version 2
db_name dragonfly
db_host localhost
db_prefix cms_cvsroster_
sqldebug On
roster_lang enUS
roster_dir modules/cvsroster
img_url modules/cvsroster/img/
interface_url modules/cvsroster/img/
img_suffix jpg
server_name_comp Off
guild_name Bovina Sancta
server_name Bonechewer
use_update_triggers On
realmstatus_url http://www.worldofwarcraft.com/realmstatus/status.xml
realmstatus Uses server_name
rs_mode On
User avatar
robinvfr
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Fri Jul 07, 2006 3:20 am

Errors when clicking links on char page and others.

Postby Anaxent » Tue Jul 18, 2006 11:20 pm

This is due to the leo linking engine. The leo engine will rewrite all the dynamic php urls to .html and this does not support to many switches. I have been working on a fix for this, but still do not have one. The roster will fully work for you with the leo link engine turned of from with in admin>main settings.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

Errors when clicking links on char page and others.

Postby robinvfr » Wed Jul 19, 2006 7:29 pm

Great! That fixed most of it. I'm still having a problem with the "Addons" links. For some reason, clicking on them brings up my current DF Poll results.

The link that is generated, for Item Sets for example, looks correct:

http://www.bovinasancta.us/start/index.php?name=cvsroster&file=addon&roster_addon_name=ItemSets&tierselect&classfilter


But this shows up under the menu box (with graph bars instead of 0 %0 %0 %):

What do you think of the new site!

It's awsome! Don't change a thing.
0 %0 %0 %
I like it, but I have some suggestions.
50 %50 %50 %
I'd rather be surfing porn!
0 %0 %0 %
I am surfing porn.
50 %50 %50 %
Results :: Polls

Votes: 2
Comments: 0
User avatar
robinvfr
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Fri Jul 07, 2006 3:20 am

Errors when clicking links on char page and others.

Postby Bedevere » Mon Jul 31, 2006 6:23 am

Yeah I noticed the LEO thing and wasn't sure if anyopne had mentioned it yet.

I don't know how it works, so I can't help, but I can poke around and see what I find.
Image
User avatar
Bedevere
WR.net Apprentice
WR.net Apprentice
 
Posts: 47
Joined: Thu Jul 06, 2006 6:25 pm

Errors when clicking links on char page and others.

Postby robinvfr » Thu Aug 03, 2006 10:38 am

I was able to get everything working by disabling my Survey module. If I turn it back on, I get the error again. I guess I don't need polls on my site anyway. :-)

I love this module! Thank to Anaxent for taking the time to convert it to DF. Great job!
Image
User avatar
robinvfr
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Fri Jul 07, 2006 3:20 am

Re: Errors when clicking links on char page and others.

Postby robinvfr » Thu Aug 10, 2006 10:38 pm

robinvfr wrote:I was able to get everything working by disabling my Survey module. If I turn it back on, I get the error again. I guess I don't need polls on my site anyway. :-)

I love this module! Thank to Anaxent for taking the time to convert it to DF. Great job!


Quick update. I moved the Poll block to the right side and everything works. Very strange problem.
Image
User avatar
robinvfr
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Fri Jul 07, 2006 3:20 am

Errors when clicking links on char page and others.

Postby Bedevere » Thu Aug 24, 2006 7:27 am

Wait if the polls are off LEO works with the cvsroster?
Image
User avatar
Bedevere
WR.net Apprentice
WR.net Apprentice
 
Posts: 47
Joined: Thu Jul 06, 2006 6:25 pm

Errors when clicking links on char page and others.

Postby Hexer » Thu Aug 24, 2006 3:40 pm

Its a shame as I like leo, but the majority of the roster seems to work for me.

BTW, where do you get your groovy signatures?
Hexer
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Wed Aug 23, 2006 7:20 pm

Errors when clicking links on char page and others.

Postby Bedevere » Thu Aug 24, 2006 4:35 pm

Its autocreated by the Siggen addon in cvs roster. Siggen lets the admin customize the template and add on custome backgrounds and faces for individual users.
Image
User avatar
Bedevere
WR.net Apprentice
WR.net Apprentice
 
Posts: 47
Joined: Thu Jul 06, 2006 6:25 pm

Errors when clicking links on char page and others.

Postby robinvfr » Sat Aug 26, 2006 3:20 am

No I've left LEO off. I just moved the poll block to the right side.
Image
User avatar
robinvfr
WR.net Apprentice
WR.net Apprentice
 
Posts: 13
Joined: Fri Jul 07, 2006 3:20 am

Errors when clicking links on char page and others.

Postby Anaxent » Sat Aug 26, 2006 8:00 am

Im working on getting ths fixed for the main release. I will need to add about 2 lines of mod_rewrite code to the top lv .htaccess file and before I just go ahead and add it for release im asking the devs of DF for any issues that it may cause and if they will add it to there main release.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az


Return to Dragonfly

Who is online

Users browsing this forum: No registered users and 0 guests