Epiphany GNOME web browser Unknown user-agent

Make suggestions, report bugs, or anything else about the website
DO NOT post bugs/feature requests for WoWRoster, PvPLog, UniUploader, or UniAdmin here

Epiphany GNOME web browser Unknown user-agent

Postby giftclown » Fri Jun 08, 2007 11:15 pm

Hello,

i just tried to get onto http://www.wowroster.net with the GNOME web broswer 2.14.3 also called Epiphany. I got the error

Unknown user-agent
You are banned from this site due to a unknown user-agent.
[ Go Back ]

Maybe you can add this browser to the allowed ones?

Thank you and kind regards
giftclown
giftclown
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Fri Jun 08, 2007 11:10 pm

Epiphany GNOME web browser Unknown user-agent

Postby zanix » Sat Jun 09, 2007 9:49 am

I need the exact user agent GNOME uses
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Epiphany GNOME web browser Unknown user-agent

Postby giftclown » Mon Jul 02, 2007 6:45 am

Hello,

this is what i get when i connect to a local fake web server run with "netcat -l -p 80" xD

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070508 (Debian-1.8.0.12-0etch1) Epiphany/2.14

Honestly i don't know which part exactly is user agent and which is just versioning info.

Sorry for the late reply.

Thank you for your quick answer :)

giftclown
giftclown
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Fri Jun 08, 2007 11:10 pm

Epiphany GNOME web browser Unknown user-agent

Postby zanix » Mon Jul 02, 2007 8:56 am

I'm not sure to be honest... :scratch:
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Epiphany GNOME web browser Unknown user-agent

Postby djsmeg » Tue Mar 04, 2008 2:18 am

The user agent test is failing because of the Epiphany 2.14 part of the user agent string, probably. Do you know what software you're using to "stop" bad user agents? If it's an apache mod, which one? What config do you have? It should be easy to replicate. And by the way, User agent is a very silly thing to block on. I can more easily access this website with wget than I can with a bona-fide web browser (Epiphany) now, because of this. (Because most useful web toolkits can fake any user agent you'd care to mention, after all, its not like its secure or secret or something).

Christian
djsmeg
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Tue Feb 12, 2008 12:51 am

Epiphany GNOME web browser Unknown user-agent

Postby zanix » Tue Mar 04, 2008 3:40 am

The site shouldn't be blocking unknown user agents any more

/checks the settings

:shock: it was enabled, oops
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to Web Site Issues

Who is online

Users browsing this forum: No registered users and 0 guests

cron