update error ???

Scans for, and displays main/alt relations in your Guild

Moderator: PleegWat

update error ???

Postby wowodo » Tue Jul 18, 2006 8:18 pm

I've an error when I would update alt's...
In the game we have defined rerolls in guildrank and we have note "Reroll - name" in public note but it don't work corectly?
in the config regex I've tested :
Reroll - ([\w]+)
Reroll - ([\w]+)\i
\Reroll - ([\w]+)\
Reroll - ([\\w]+)
([\w]+)

Image


Image

Help me please
User avatar
wowodo
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Fri Jul 07, 2006 6:47 pm

update error ???

Postby PleegWat » Tue Jul 18, 2006 9:19 pm

The errors tell it all actually. The regex consists of serveral parts: A delimeter, the regex, the delimeter again, and then optionally switches. The delimeter is / by default, | is used in other places in roster as well. You're using R there and that's not valid.

Try again with /Reroll - ([\w]+)/i and give me the errors you get that time round.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: update error ???

Postby wowodo » Tue Jul 18, 2006 9:43 pm

the next error with your modif is that :


Image
User avatar
wowodo
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Fri Jul 07, 2006 6:47 pm

update error ???

Postby PleegWat » Wed Jul 19, 2006 6:35 pm

OK I'm hating the db framework right now. Doesn't produce a useful line number like that :(

Which page is it occurring on? Do you get any HTML before the error? What's the last bit of HTML before the error?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: update error ???

Postby wowodo » Wed Jul 19, 2006 11:05 pm

this error appened when I clic on update button in alt-setting page...
it's a blanc page open in a new window. that's all...
you would like that I paste the source of the HTML error here?


edit : this is the source of the error page (http://.../roster/addon.php?roster_addo ... ion=update).
Code: Select all
<!--SELECT `name`, `member_id` FROM `roster_members` as members-->
<!--SELECT `members`.`member_id`, `members`.`name` FROM `roster_members` as `members` WHERE `members`.`name`='Sphynx'-->
<!--SELECT `member_id`, `main_id`, `alt_type` FROM `roster_addon_altmonitor` WHERE `member_id`=7-->
<!--SELECT `members`.`member_id`, `members`.`name` FROM `roster_members` as `members` WHERE `members`.`name`='Septime'-->
<!--SELECT `member_id`, `main_id`, `alt_type` FROM `roster_addon_altmonitor` WHERE `member_id`=11-->
<!--SELECT `members`.`member_id`, `members`.`name` FROM `roster_members` as `members` WHERE `members`.`name`='Trashalt'-->
<!--SELECT `members`.`member_id`, `members`.`name` FROM `roster_members` as `members` WHERE `members`.`name`='Marek'-->
<!--SELECT `member_id`, `main_id`, `alt_type` FROM `roster_addon_altmonitor` WHERE `member_id`=18-->
<br />
<b>Fatal error</b>:  mysql_free_result(): supplied argument is not a valid MySQL result resource in <b>/.../.../.../roster/lib/wowdb.php</b> on line <b>205</b><br />
Last edited by wowodo on Wed Jul 19, 2006 11:27 pm, edited 3 times in total.
User avatar
wowodo
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Fri Jul 07, 2006 6:47 pm

update error ???

Postby PleegWat » Thu Jul 20, 2006 1:36 am

I have no idea what could be causing it to be honest. Can I get your site URL so I can compare some data?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: update error ???

Postby wowodo » Thu Jul 20, 2006 6:43 am

User avatar
wowodo
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Fri Jul 07, 2006 6:47 pm


Return to AltMonitor

Who is online

Users browsing this forum: No registered users and 0 guests

cron