javascript not working

This mod will allow any part of DragonFly that uses bbcode to be able to use ItemStats
No longer maintained

javascript not working

Postby Fosfor » Thu Jun 14, 2007 9:03 am

Hello sorry 2 disturb you all but
i have a small problem with the installation

i just took the download from the site all installed well no complications
now i can link items on my main page of my site.

But it dusent show item quality and when i hover it
there is no popup what did i do wrong ?

ore is me that just forgot soothing
in that case sorry
Fosfor
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Tue Apr 24, 2007 10:56 pm

javascript not working

Postby zanix » Thu Jun 14, 2007 9:33 am

Most likely you didn't edit header.html of your theme
5a) All Packs File Edits
Requires edits to 1 file
  • {df_root}/themes/{THEME_NAME}/templates/header.html
  • Note: You MUST edit every theme's header.html file that you want to use

------------------
OPEN
For every theme you want ItemStatsDF to work with
------------------
{df_root}/themes/{THEME_NAME}/templates/header.html


------------------
FIND
Note: This is not exact for every theme, but it's similar
------------------
Code: Select all
<link rel="stylesheet" type="text/css" href="{THEME_PATH}/style/style.css" />



------------------
ADD-AFTER
------------------
Code: Select all
<link rel="stylesheet" href="modules/item_stats/templates/itemstats.css" type="text/css" />
<script type="text/javascript" src="modules/item_stats/overlib/overlib.js"><!-- overLIB © Erik Bosrup --></script>



------------------
SAVE AND CLOSE
------------------
{df_root}/themes/{THEME_NAME}/templates/header.html


------------------
COPY
For themes other than default and dragonfly

Note: To get the bbcode button images for the Module-Only pack, download the 'itemstats_bbcode.zip' file
* Place these images in every theme's image/ directory

------------------
{df_root}/themes/default/images/item.gif
{df_root}/themes/default/images/item1.gif
{df_root}/themes/default/images/itemico.gif
{df_root}/themes/default/images/itemico1.gif


------------------
PASTE
------------------
{df_root}/themes/{THEME_NAME}/images/item.gif
{df_root}/themes/{THEME_NAME}/images/item1.gif
{df_root}/themes/{THEME_NAME}/images/itemico.gif
{df_root}/themes/{THEME_NAME}/images/itemico1.gif
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

javascript not working

Postby Fosfor » Thu Jun 14, 2007 10:48 am

thanks you for the quick reply
and yeah you are 100% right
i forgot that part.

Sorry for the waste of your time.
Fosfor
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Tue Apr 24, 2007 10:56 pm

javascript not working

Postby zanix » Thu Jun 14, 2007 11:03 am

It's alright
It better that you got it working

Plus I already had this written out...
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

javascript not working

Postby Fosfor » Thu Jun 14, 2007 7:08 pm

Sorry 2 disturb you again but the fault was indeed corrected
but when you hover it it pops up about 20 30 px away from cursor
is that normal behavior ore just me again

King regard F.
Fosfor
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Tue Apr 24, 2007 10:56 pm

javascript not working

Postby zanix » Fri Jun 15, 2007 1:26 am

This is probably the theme you use.
I don't know what causes it unfortunately.
Last edited by zanix on Fri Jun 15, 2007 1:26 am, edited 1 time in total.
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to ItemStatsDF

Who is online

Users browsing this forum: No registered users and 0 guests

cron