Solved: UniUploader: Distribution - Not Working.

Support and feedback for UniUploader
UniUploader requires microsoft .net runtimes!

Solved: UniUploader: Distribution - Not Working.

Postby cyberbane » Mon Jul 16, 2007 12:10 am

Hi there,

I have used NSIS in the past to create a script for guildies. All worked fine and was very useful.

I am now running Vista 64 rather than XP and I am having some problems creating an exe.

I have downloaded and installed the latest NSIS version from sourceforge.

Installed the latest UniUploader. Configured all the settings. Edited the settings file.

I have downloaded the script from here. Placed it in the directory and uncommented the relevant line.

When I right click and choose compile I get this.

Code: Select all
MakeNSIS v2.29 - Copyright 1995-2007 Contributors
See the file COPYING for license details.
Credits can be found in the Users Manual.

Processing config:
Processing plugin dlls: "C:\Banes Program Files\NSIS\Plugins\*.dll"
 - AdvSplash::show
 - Banner::destroy
 - Banner::getWindow
 - Banner::show
 - BgImage::AddImage
 - BgImage::AddText
 - BgImage::Clear
 - BgImage::Destroy
 - BgImage::Redraw
 - BgImage::SetBg
 - BgImage::SetReturn
 - BgImage::Sound
 - Dialer::AttemptConnect
 - Dialer::AutodialHangup
 - Dialer::AutodialOnline
 - Dialer::AutodialUnattended
 - Dialer::GetConnectedState
 - InstallOptions::dialog
 - InstallOptions::initDialog
 - InstallOptions::show
 - LangDLL::LangDialog
 - Math::Script
 - NSISdl::download
 - NSISdl::download_quiet
 - Splash::show
 - StartMenu::Init
 - StartMenu::Select
 - StartMenu::Show
 - System::Alloc
 - System::Call
 - System::Copy
 - System::Free
 - System::Get
 - System::Int64Op
 - System::Store
 - TypeLib::GetLibVersion
 - TypeLib::Register
 - TypeLib::UnRegister
 - UserInfo::GetAccountType
 - UserInfo::GetName
 - UserInfo::GetOriginalAccountType
 - VPatch::vpatchfile
 - nsDialogs::Create
 - nsDialogs::CreateItem
 - nsDialogs::GetUserData
 - nsDialogs::OnBack
 - nsDialogs::OnChange
 - nsDialogs::OnClick
 - nsDialogs::OnNotify
 - nsDialogs::SelectFileDialog
 - nsDialogs::SelectFolderDialog
 - nsDialogs::SetUserData
 - nsDialogs::Show
 - nsExec::Exec
 - nsExec::ExecToLog
 - nsExec::ExecToStack

!define: "MUI_INSERT_NSISCONF"=""

Changing directory to: "C:\Banes Program Files\UniUploader"

Processing script file: "C:\Banes Program Files\UniUploader\UniUploader_NSIS_Script.nsi"
!define: "PRODUCT_NAME"="UniUploader"
!define: "PRODUCT_VERSION"="2.6.7"
!define: "PRODUCT_PUBLISHER"="Matt Miller"
!define: "PRODUCT_WEB_SITE"="http://www.wowroster.net"
!define: "PRODUCT_DIR_REGKEY"="Software\Microsoft\Windows\CurrentVersion\App Paths\UniUploader.exe"
!define: "PRODUCT_UNINST_KEY"="Software\Microsoft\Windows\CurrentVersion\Uninstall\UniUploader"
!define: "PRODUCT_UNINST_ROOT_KEY"="HKLM"
!define: "PRODUCT_STARTMENU_REGVAL"="NSIS:StartMenuDir"
SetCompressor: /SOLID lzma
!define: "URL_DOTNET"="http://download.microsoft.com/download/5/6/7/567758a3-759e-473e-bf8f-52154438565a/dotnetfx.exe"
Var: "DOTNET_RETURN_CODE"
!include: "C:\Banes Program Files\NSIS\Include\MUI.nsh"
!include: "C:\Banes Program Files\NSIS\Contrib\Modern UI\System.nsh"
NSIS Modern User Interface version 1.78 - © 2002-2007 Joost Verburg (C:\Banes Program Files\NSIS\Contrib\Modern UI\System.nsh:11)
!define: "MUI_VERBOSE"="3"
!include: closed: "C:\Banes Program Files\NSIS\Contrib\Modern UI\System.nsh"
!include: closed: "C:\Banes Program Files\NSIS\Include\MUI.nsh"
!define: "MUI_ABORTWARNING"=""
!define: "MUI_UNABORTWARNING"=""
!define: "MUI_ICON"="NEWUUIcon.ico"
!define: "MUI_UNICON"="NEWUUIcon.ico"
!define: "MUI_LANGDLL_REGISTRY_ROOT"="HKLM"
!define: "MUI_LANGDLL_REGISTRY_KEY"="Software\Microsoft\Windows\CurrentVersion\Uninstall\UniUploader"
!define: "MUI_LANGDLL_REGISTRY_VALUENAME"="NSIS:Language"
!insertmacro: MUI_PAGE_WELCOME
Error while setting icon to "NEWUUIcon.ico": can't open file
Error in macro MUI_INTERFACE on macroline 61
Error in macro MUI_PAGE_INIT on macroline 3
Error in macro MUI_PAGE_WELCOME on macroline 5
Error in script "C:\Banes Program Files\UniUploader\UniUploader_NSIS_Script.nsi" on line 59 -- aborting creation process


Can anyone with a bit more knowledge of this NSIS package help me out here?

Cheers,

Imo.
Last edited by cyberbane on Fri Jul 20, 2007 2:43 am, edited 1 time in total.
Image
User avatar
cyberbane
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Mon Jul 10, 2006 6:35 am

UniUploader: Distribution - Not Working.

Postby Jellow » Mon Jul 16, 2007 3:57 am

The error code precisely tells you, that the NSIS compiler can't find the NEWUUIcon.ico.

What you have to do is putting the NEWUUIcon.ico (included in the script zip file) into the script directory.
Jellow
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Jun 11, 2007 8:11 am

UniUploader: Distribution - Not Working.

Postby MattM » Mon Jul 16, 2007 5:00 am

Error while setting icon to "NEWUUIcon.ico": can't open file
MattM
UA/UU Developer
UA/UU Developer
Gimpy Developer
Gimpy Developer
 
Posts: 886
Joined: Tue Jul 04, 2006 9:53 pm
Location: USA

UniUploader: Distribution - Not Working.

Postby cyberbane » Fri Jul 20, 2007 2:42 am

Ah I feel just like a noob again. :D Thanks guys.

All working well now.
Image
User avatar
cyberbane
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Mon Jul 10, 2006 6:35 am


Return to UniUploader

Who is online

Users browsing this forum: Bing [Bot] and 1 guest