Noob questions

Support and feedback for UniAdmin

Noob questions

Postby Bama » Thu Aug 02, 2007 11:13 pm

OK, I just decided to try the uniadmin and uniuploader modules for the first time. I've installed them and they seem to be working properly (no visible errors) but there are a few things that aren't happening. I've read all the user manuals on the Wiki and it's entirely possible that I'm just not fully understanding how to use them, so I figured I'd ask here.

Here's my biggest goal:
This is probably completely contrary to what this was designed for, but I'd like to use these applications as basically an addon auto-installer; the addons are stored in uniadmin and when I load UU with the proper settings it'll check for newer versions of my addons and download/install them on my machine.

Even if I have a fesh install of WoW with no addons installed I'd like it to 'force install' the addons. In UA I've selected a handful of addons that I'd like to use and made them Required Downloads and I've even thrown my guild logo in the config, but when I run UU it doesn't appear to do anything.

So, my first question...does UA/UU have this capability to do what I'd like it to do or am I barking up the wrong tree?

And my next question...what should my first troubleshooting steps be? I'm pretty confident that all of the URL's are correct both on the site and on the client, but I'm not sure what else to check. I'm brand new to web design, WoW Roster and UA/UU, so any help would be greatly appreciated.

My home page is http://www.thecircleofpain.com and the UA site is http://www.thecircleofpain.com/wowhorde ... in/?p=pref

Thanks in advance for any help.
Last edited by Bama on Thu Aug 02, 2007 11:14 pm, edited 1 time in total.
Bama
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 02, 2007 11:01 pm

Noob questions

Postby zanix » Fri Aug 03, 2007 3:31 am

On the updater tab in UU, keep addons updated needs to be enabled
Then you can hit the get addons button in the first tab when you expand the addons section

It should be automatic though, you seems to have all your settings in UA set correctly

As for debugging, open the debugger tab in UU

Also, a note about your settings
RETRDATAFROMSITE is on, this is for web => wow data syncing
I went to the url set in RETRDATAURL
http://www.thecircleofpain.com/wowhorde ... to_wow.php

And it said page not found, so I guess you enabled this to see what it was
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Noob questions

Postby Bama » Fri Aug 03, 2007 10:38 am

I'm not real sure what's going on, so let me start with the easy one...

RETRDATAFROMSITE is turned off. You were correct, I wasn't sure what it was so I enebled it to see if it would help.

Now, as for UU; I have 'keep addons updated' enabled, and I have the link to the interface.php directory on the updater tabe as well as the default tab. When I synchronize it downloads the logos and appears to be downloading the addons, but it happes very quickly and then goes away. I did see the logos get downloaded, but they just sit on my hard drive and don't get displayed within the app.

As for the addons I don't see where they're getting downloaded to if at all. I don't think they're being downloaded because I've got a couple Mb of them set up as required addons and UU only downloads my addons for about 15 seconds before it tells me that it's done.

Now, for the last part...whenever I hit the synchronize button 2 things happen. The UU Application resets to all default settings back on the default tab and 'basic' enabled. The other thing is that the url on the default tab changes to my wowroster url, not the UA interface url which is what I set it to.

I've attached my UU log in case this helps.
Does any of this make sense?
Attachments
uulog.txt
(279.84 KiB) Downloaded 92 times
Last edited by Bama on Fri Aug 03, 2007 10:59 am, edited 1 time in total.
Bama
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 02, 2007 11:01 pm

Noob questions

Postby zanix » Fri Aug 03, 2007 12:36 pm

UU downloads addons directly into your WoW/Interface/AddOns/ folder

I do see an error in the upload log
[2007/08/02 21:31:20] UpdateAddons: This is an unexpected token. The expected token is 'SEMICOLON'. Line 349, position 136.

I think the line is
<addon name="FuBar - DPS" version="2.0.$Rev: 29438 $" required="1" homepage="http://www.wowinterface.com/downloads/fileinfo.php?s=&id=5013"

Try removing this addon in UA FuBar - DPS
And tell me if it works
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Noob questions

Postby Bama » Fri Aug 03, 2007 10:11 pm

That did it!

Thank you so much for your help!


OK, I've got one more stupid question, then I should be good to go from here.

I can set the addons to Optional or Required. Obviously 'Required' means that the client will download them regardless of the user's preferences...but how does UA know if the client wants to download/install the optional addons?

Is it a matter of having the addon already installed and UA/UU will keep it updated, or is there another setting that gives my users the ability to pick and choose which optional mods they want?
Last edited by Bama on Fri Aug 03, 2007 10:59 pm, edited 1 time in total.
Bama
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 02, 2007 11:01 pm

Noob questions

Postby zanix » Fri Aug 03, 2007 11:14 pm

UU has an interface for selecting addons on the main tab
Click the Show Addons button
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Noob questions

Postby Bama » Fri Aug 03, 2007 11:33 pm

That's absolutely Perfect! Thank you so much.
Bama
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Aug 02, 2007 11:01 pm


Return to UniAdmin

Who is online

Users browsing this forum: No registered users and 0 guests

cron