July 20 nuke port update! installation fix

phpNuke integration forum

July 20 nuke port update! installation fix

Postby Rahtak » Thu Jul 20, 2006 4:38 pm

www.shadow-prophecy.com/download/Roster17.zip

I fixed the install.php and tested abotu 4-5 installation and there were successfull without any file editing.

Step 1. upload the content into [root]/modules/Roster directory

Step 2. Go in your nuke setting and make sure Roster module appear there

Step 3. Activate the module but make it invisible so only admin can see while you work on it.

Step 4. click the roster link from the menu. it should access this link [yoursite]/modules.php?name=Roster

Step 5. Perform the installation and fill the DB settings

Step 6. Delete install.php and /install/ folder from the Roster

Step 7. Click Maximum Resist addon and perform the installation to update the table.

Step 8. Go in Roster config and set your guild name and server

Step 9. go in Roster update and upload your guild roster

Step 10. at this point if it'S working right you can upload the image pack from www.wowroster.net

Step 11. have fun changing settings.



THING TO DO:

-Making sure there is no hard coded modules/Roster link (so you could install roster in Roster17 folder if you wanted
-Fix Siggen ( if someoen can fix it go ahead don't wait for me)
-Fix more addon if they broken by nuke
-Figure why uniuploader not working on my install (is the the same for you guys? )
-Fix motd image generation (texte mode work)
-Fix a few still broken link



Well atleast now people should have a working installable version for poeple not php literate. GL i'll post change update and don't be shy to fix and put update of your own.
Rahtak
WR.net Journeyman
WR.net Journeyman
 
Posts: 78
Joined: Fri Jul 14, 2006 11:54 am

July 20 nuke port update! installation fix

Postby Bugilt » Thu Jul 20, 2006 8:46 pm

I got to here and have deleted the install.php file, but I still get this.

Please delete the install.php and install folder file from your server!
Bugilt
WR.net Apprentice
WR.net Apprentice
 
Posts: 32
Joined: Fri Jul 14, 2006 2:00 am

Re: July 20 nuke port update! installation fix

Postby methadoneklinic » Thu Jul 20, 2006 9:32 pm

I made some changes to your code to make roster work in Nuke-Evolution. If you are interested, I have posted the details here.
methadoneklinic
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Tue Jul 11, 2006 12:45 am

Re: July 20 nuke port update! installation fix

Postby Rahtak » Thu Jul 20, 2006 10:31 pm

make sure your delete install.php AND /install/ folder
Rahtak
WR.net Journeyman
WR.net Journeyman
 
Posts: 78
Joined: Fri Jul 14, 2006 11:54 am

July 20 nuke port update! installation fix

Postby Bugilt » Thu Jul 20, 2006 10:48 pm

Rahtak thanks alot for the help.
Bugilt
WR.net Apprentice
WR.net Apprentice
 
Posts: 32
Joined: Fri Jul 14, 2006 2:00 am

Re: July 20 nuke port update! installation fix

Postby Rahtak » Thu Jul 20, 2006 10:55 pm

np now lets figure how to fix siggen :P

just need to figure how to call siggen while keeping nuke type link
Rahtak
WR.net Journeyman
WR.net Journeyman
 
Posts: 78
Joined: Fri Jul 14, 2006 11:54 am

Re: July 20 nuke port update! installation fix

Postby gimp8gimp » Fri Jul 21, 2006 1:19 am

Hi Rahtak
thanks for all your work dude. installed roster sucessful but when i click on the roster module i get a my website within the website as shown in link.
Last edited by gimp8gimp on Sat Jul 22, 2006 3:36 pm, edited 1 time in total.
gimp8gimp
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Fri Jul 07, 2006 10:47 pm

Re: July 20 nuke port update! installation fix

Postby Rahtak » Fri Jul 21, 2006 4:20 am

umm strange

index.php from roster include phpnuke header and footer so make sure it's not include anytime before reaching the roster index.php.

do you use auto theme or something like that?
Last edited by Rahtak on Fri Jul 21, 2006 4:21 am, edited 1 time in total.
Rahtak
WR.net Journeyman
WR.net Journeyman
 
Posts: 78
Joined: Fri Jul 14, 2006 11:54 am

Re: July 20 nuke port update! installation fix

Postby undood » Fri Jul 21, 2006 12:15 pm

This is what I have so far for Siggen :monkey:

At least it's opening now, so I guess it's a start
Attachments
siggen.rar
Siggen nuked
(47.03 KiB) Downloaded 146 times
User avatar
undood
WR.net Apprentice
WR.net Apprentice
 
Posts: 16
Joined: Tue Jul 04, 2006 1:29 pm

July 20 nuke port update! installation fix

Postby Vilkku » Fri Jul 21, 2006 1:37 pm

For a phpNuke installation, what should I set the path to phpBB to?

EDIT: To make things more clear, when entering the admisn password on the upload page it just redirects me back to the upload page asking for the password, so I suppose it's something with the update.php access options.
Last edited by Vilkku on Fri Jul 21, 2006 1:49 pm, edited 1 time in total.
Vilkku
WR.net Apprentice
WR.net Apprentice
 
Posts: 10
Joined: Wed Jul 19, 2006 12:48 pm

July 20 nuke port update! installation fix

Postby zang » Fri Jul 21, 2006 5:08 pm

hey rahtak thanks for your help its working fine and after i removed the header/footer it worked :) i will see what i can do with siggen i took undood zip if this works we will have a stable ver of 1.7.0 of wowroster ^^
zang
WR.net Apprentice
WR.net Apprentice
 
Posts: 27
Joined: Wed Jul 05, 2006 12:57 pm

July 20 nuke port update! installation fix

Postby zang » Fri Jul 21, 2006 5:31 pm

oh and there is one thing when i try to Upload the Guild profile umm it doesnt did i forget something ?
zang
WR.net Apprentice
WR.net Apprentice
 
Posts: 27
Joined: Wed Jul 05, 2006 12:57 pm

Re: July 20 nuke port update! installation fix

Postby kobseryqum » Fri Jul 21, 2006 8:12 pm

Thanks Rahtak

got it working for me, as far as the update for the uni loader

yourdomain.com/modules.php?name=Roster&op=updateprofile

that url works if you dont have the module set to registered users.

if we can figure out how to get it to work for registered users that would be great

I kept getting the respose of this is for registered users only
Last edited by kobseryqum on Fri Jul 21, 2006 8:13 pm, edited 2 times in total.
kobseryqum
WR.net Apprentice
WR.net Apprentice
 
Posts: 6
Joined: Wed Jul 19, 2006 6:57 am

Re: July 20 nuke port update! installation fix

Postby Rahtak » Fri Jul 21, 2006 11:42 pm

the current path is alwase the root folder with nuke so if you want to point to the forum dir for phpbb you need to point

"modules/Forum/" probably


for updating only for registered version we could try to add the code from 1.5 nuked. he added a uniuploader.php that was checking password and such
Last edited by Rahtak on Fri Jul 21, 2006 11:43 pm, edited 1 time in total.
Rahtak
WR.net Journeyman
WR.net Journeyman
 
Posts: 78
Joined: Fri Jul 14, 2006 11:54 am

July 20 nuke port update! installation fix

Postby Vilkku » Sat Jul 22, 2006 1:58 am

I tried both of those URLs, and it still doesn't do anything when I enter the password.
Vilkku
WR.net Apprentice
WR.net Apprentice
 
Posts: 10
Joined: Wed Jul 19, 2006 12:48 pm

Next

Return to phpNuke

Who is online

Users browsing this forum: No registered users and 0 guests

cron