Realm Status

Here you can find plenty of help with your general coding needs and projects
If it is about a specific program, use the corresponding forum
DO NOT ask basic questions such as "How do I print a variable", use Google for that

Realm Status

Postby secretone » Fri Aug 24, 2007 8:03 am

Hi,

Not sure if this is the correct place to post this question or not.

Is there away to use the Realm Status outside of Roster, i.e. on the main page of our website?

Many thanks in advance.
Image
User avatar
secretone
WR.net Apprentice
WR.net Apprentice
 
Posts: 62
Joined: Wed Feb 28, 2007 6:33 pm
Location: Kent, UK

Realm Status

Postby microbone » Fri Aug 24, 2007 9:17 am

sure......just make an img link ref to:

theurlforyourroster/realmstatus.php?r=EUorUS-Servername

for me would that be:
Code: Select all
[img]http://trdo.dk/roster/realmstatus.php?r=EU-Turalyon[/img]


on my forum...works like a charm for me :)
Last edited by microbone on Fri Aug 24, 2007 9:18 am, edited 1 time in total.
User avatar
microbone
WR.net Apprentice
WR.net Apprentice
 
Posts: 26
Joined: Thu Jul 13, 2006 12:00 am

Realm Status

Postby zanix » Fri Aug 24, 2007 10:56 am

Remember, this is the realmstatus for Roster 2.0 which as of this post is still in beta
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Realm Status

Postby secretone » Fri Aug 24, 2007 4:20 pm

Thanks guys for the replies.

Shame it's not for 1.7.3.

I think I will install Roster 2.0 in preperation for when it's made public and then use the code snippet above.
Image
User avatar
secretone
WR.net Apprentice
WR.net Apprentice
 
Posts: 62
Joined: Wed Feb 28, 2007 6:33 pm
Location: Kent, UK

Re: Realm Status

Postby secretone » Sat Aug 25, 2007 2:41 am

Installed Roster 2b1 and have it working but the Realm Status is not. Looking at Blizzard Realms Status our server EU-Lightbringer is not even
listed ?!?!?!?

Works on the 1.7.3 roster though ?!?!?!?

Oh well back to the drawing board.
Image
User avatar
secretone
WR.net Apprentice
WR.net Apprentice
 
Posts: 62
Joined: Wed Feb 28, 2007 6:33 pm
Location: Kent, UK

Realm Status

Postby ds » Sat Aug 25, 2007 2:49 am

Did you set up the default guild in the upload rules? Correct me if I am wrong but Realm Status uses Default Guild config for display if no scope is set.
Image
ds
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 297
Joined: Sat Jul 08, 2006 9:58 am

Re: Realm Status

Postby secretone » Sat Aug 25, 2007 2:59 am

ds wrote:Did you set up the default guild in the upload rules? Correct me if I am wrong but Realm Status uses Default Guild config for display if no scope is set.


Yep our Guild is the default in the Upload rules and display on entry to the roster.

I am using an old version of Roster2 that I downloaded ages ago. I will update to the latest version soon. Just wanted the Realm Status to be available on our front page.
Image
User avatar
secretone
WR.net Apprentice
WR.net Apprentice
 
Posts: 62
Joined: Wed Feb 28, 2007 6:33 pm
Location: Kent, UK

Realm Status

Postby ds » Sat Aug 25, 2007 3:03 am

Yeah, update to latest SVN version and let us know.... If you still are having problems, this is the time to fix these errors.
Image
ds
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 297
Joined: Sat Jul 08, 2006 9:58 am

Re: Realm Status

Postby secretone » Mon Sep 10, 2007 3:43 am

Hi,

I updated to the latest version and it still did not show the Realm Status.

I even installed Dragonfly and that did not show the Realm Status either.

I had to copy the info needed into the database to get it to work.

Also as I said above my server was not listed in the Blizzard Realm Status list. A post was made on their forum and it was fixed.

All seems to be OK now.

I am now using Dragonfly as the basis of my whole website and have created a block to show the status on the front page of our website. see the follow post http://wowroster.net/Forums/viewtopic/p ... html#26442

Many thanks for everyones input.
Last edited by secretone on Mon Sep 10, 2007 3:44 am, edited 1 time in total.
Image
User avatar
secretone
WR.net Apprentice
WR.net Apprentice
 
Posts: 62
Joined: Wed Feb 28, 2007 6:33 pm
Location: Kent, UK

Re: Realm Status

Postby diggler » Thu Sep 13, 2007 9:02 pm

Hi,

my server is listed but it doesn't work...
I tried a query with almost all server names in EU and in US and two of the doesn't work:
-Arak-arahm (EU and also our server)
-Azjol-Nerub (US)

Could it be a problem with the "-" ?
diggler
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue May 29, 2007 10:21 pm

Realm Status

Postby zanix » Thu Sep 13, 2007 10:32 pm

If you are using Roster 2.0 beta, then you would need EU-Arak-arahm
The region code must come first

I also looked at the code, the - shouldn't be a problem
Last edited by zanix on Thu Sep 13, 2007 10:32 pm, edited 1 time in total.
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Realm Status

Postby diggler » Thu Sep 13, 2007 10:46 pm

Yes, I am using Roster 2 Beta...

In order to avoid some kind of error in my website I used the link given above:

http://trdo.dk/roster/realmstatus.php?r=EU-Turalyon -> Server status OK
http://trdo.dk/roster/realmstatus.php?r=EU-Arathi -> Server status OK

But with this one:
http://trdo.dk/roster/realmstatus.php?r=EU-Arak-arahm -> Server status NOK :(

What could it be? Any clue?

Thanks for your help
diggler
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue May 29, 2007 10:21 pm

Realm Status

Postby zanix » Thu Sep 13, 2007 11:28 pm

Hmm, guess we need to look into this more
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to General Code Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron