Installing WoWRosterDF

Dragonfly integration forum

Installing WoWRosterDF

Postby aalwein » Sun Jul 23, 2006 10:20 pm

After reading through the install.txt, I copied up all my directories (three) to the root web directory (/) and now not only am I not getting WoWRoster working my Dragonfly is also not working. Now I'm sure it's because I haven't run any install.php script but I can't go to newguild.splitzero.net/roster/install.php because it doesn't exist. When I try to run newguild.splitzero.net/modules/WoWRosterDF/install.php it says I can't access it. It is set to chmod 777 so I don't understand what is going on.

I'm sure I'm just missing some simple first step here but I can't figure what I'm forgetting to do. Any help?
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Installing WoWRosterDF

Postby zanix » Mon Jul 24, 2006 1:19 am

Do you know how to install modules for Dragonfly?

Get WoWRosterDF beta from the downloads area and install it like you install any other module in DF
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Installing WoWRosterDF

Postby aalwein » Mon Jul 24, 2006 3:22 am

Honestly, never used Dragonfly I've always used PHPNuke, so I don't know how to install modules in Dragonfly. I copied the module to the module directory and tried to go into the admin section to click the install link in the modules admin, but i get this error:

Code: Select all
Parse error: parse error, unexpected ')' in /homepages/1/d119671401/htdocs/newguild/modules/WoWRosterDF/admin/adlinks.inc on line 20


So I can't click install. There's a step in this whole process I'm missing and I'm sure its so simple I will hate myself later.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Installing WoWRosterDF

Postby jimig1 » Mon Jul 24, 2006 10:13 pm

User avatar
jimig1
WR.net Apprentice
WR.net Apprentice
 
Posts: 36
Joined: Fri Jul 07, 2006 10:48 pm

Re: Installing WoWRosterDF

Postby aalwein » Tue Jul 25, 2006 5:22 am

Followed the steps and still no dice. I've done the following:

1) Uploaded files to \modules\wowroster
2) Set every last file in the \modules\wowroster folder (including the folder itself) to 755.
3) Database is created (I'm going to be sharing the DF database)
4) Can't run the install.php because I get the below error:
Access to the URL that you requested, /modules/wowroster/install.php, is forbidden.

See http://newguild.splitzero.net/modules/wowroster/install.php
5) Can't access the admin section of DF (or any of the DF site for that matter) due to the below error:
Parse error: parse error, unexpected ')' in /homepages/1/d119671401/htdocs/newguild/modules/wowroster/admin/adlinks.inc on line 20

See http://newguild.splitzero.net/

I don't want to sound like a complete newbie at this. I have done many installations of NukePHP and NukePHP Platinum. It just seems like the normal process for installating a module in DF just isn't working right. I can't get to the admin panel to "install" the modules nor can I get to the install.php script to get the roster loaded.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Re: Installing WoWRosterDF

Postby aalwein » Tue Jul 25, 2006 5:34 am

Sorry, jimig1, I didn't read all the way down to the bottom. I just made the corrections to the code like you mentioned and at least the site is working now. I'll let you know if it fixed the install also :)

Ok got it all installed... but here's the new problem. I still can't run the install.php. Now I'm assuming that clicking "install" in the modules admin did what the install.php file was gonna do.

Here's the question... what is the password to my wowroster now? Do I (and my guildies) need a username and password to upload their data to the roster or do they just use their Dragonfly username/password to upload?
Last edited by aalwein on Tue Jul 25, 2006 9:01 am, edited 2 times in total.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Installing WoWRosterDF

Postby jimig1 » Tue Jul 25, 2006 9:17 pm

when you install the module it runs the install.php

the admin for roster is tied to the DF admin and the guilds should be able to just upload to it without a user/pass
User avatar
jimig1
WR.net Apprentice
WR.net Apprentice
 
Posts: 36
Joined: Fri Jul 07, 2006 10:48 pm

Re: Installing WoWRosterDF

Postby aalwein » Sat Jul 29, 2006 5:07 am

ok the roster is working swimingly, however, I've run into a UniUploader glitch now. When I hit upload it seems as though everything works fine. I get this message in the debugger log:

Code: Select all
[2006/07/28 07:07:25] Uploading to Primary URL...: http://newguild.splitzero.net/modules/wowroster/admin/update.php
[2006/07/28 07:07:25] CharacterProfiler.lua - No Compression. Upload Size: 173 KB
[2006/07/28 07:07:25] GuildProfiler.lua - No Compression. Upload Size: 0 KB
[2006/07/28 07:07:25] PvPLog.lua - No Compression. Upload Size: 10 KB


But the page doesn't update. I can update via the webpage link, but UniUploader doesn't seem to update it. In the server repsonse window, I get this message:

Code: Select all
<b>Fatal error</b>:  Call to a member function on a non-object in <b>/homepages/1/d119671401/htdocs/newguild/modules/wowroster/lib/wowdb.php</b> on line <b>59</b><br />
I saw some posts with this error but nothing in relation to updating via UniUploader. Anyone know what's going on?
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Installing WoWRosterDF

Postby Deeo » Sat Jul 29, 2006 7:12 am

try this link using in you uniuploader:
Code: Select all
http://newguild.splitzero.net/index.php?name=wowroster&file=update
Deeo
WR.net Journeyman
WR.net Journeyman
 
Posts: 80
Joined: Mon Jul 10, 2006 2:02 pm

Re: Installing WoWRosterDF

Postby Anaxent » Sat Jul 29, 2006 8:04 am

Deeo wrote:try this link using in you uniuploader:
Code: Select all
http://newguild.splitzero.net/index.php?name=wowroster&file=update


Have you been able to get Uniuploader work by passing cookies to wowrosterdf.


Hey guys im sorry for slacking a bit on this, but im just about ready to update the the beta release of this to beta 2.... so close. With in the beta 2 most of all the addons will function and the installation has also been fixed. I have been building this package to allow multi installs of roster with out havning to do much code editing... from here on out this package will be mainly a single version and has the ability to install multi times unfortanatly there may be some minor code editing that will be needed to get this done.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

Re: Installing WoWRosterDF

Postby aalwein » Sat Jul 29, 2006 8:04 am

Ok that fixed it I think, but I've run into a problem I think can't be solved here (unless someone has done the same thing).

I was using the domain newguild.splitzero.net temporarily until my domain became available. Now i've moved everything over to www.lastrites.us and I'm getting the "no cookies" error like I haven't cleared the cache.

Code: Select all
<!-- ############ Uploading to Primary URL...
     ############ http://www.lastrites.us/index.php?name=wowroster&file=update -->

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
<title>ERROR</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="robots" content="noindex" />
<meta name="robots" content="noarchive" />
<link rel="stylesheet" href="includes/css/cpg.css" type="text/css" />
</head>
<body><center>
<table class="headtable"><tr><td>
  <table class="head">
  <tr>
<!--<td width="212" align="left"><img src="images/logo.gif" border="0" alt="CPG-Nuke" title="CPG-Nuke" /></td> -->
    <td align="center" class="header">ERROR</td>
<!--<td width="212" valign="bottom"><img align="right" height="22" width="202" src="images/shout.gif" alt="" title="" /></td> -->
  </tr>
  </table>
  <table class="table1"><tr><td align="center">
<center>Please enable cookies to post on this site. If you feel that you have reached this message in error please refresh the preceding page once and post again</center><br /><br />[ <a href="javascript:history.go(-1)"><strong>Go Back</strong></a> ]
  </td></tr></table>
</td></tr></table>
</center></body></html>


I've gotten all the website to switch over and the cookies to work, but the damn uniuploader doesn't seem to want to follow suit.

On another note, I managed to get installed the itemstats for EQDKP and the Dragonfly setup (found here) and it works great... in EQDKP and Dragonfly (and the forums). Problem is, it messed up WoWRoster's mouse overs. See the site (www.lastrites.com) for the result.
Last edited by aalwein on Sat Jul 29, 2006 8:07 am, edited 1 time in total.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Installing WoWRosterDF

Postby Anaxent » Sat Jul 29, 2006 8:07 am

you not only need to clear the cache but also need to manually edit the dragonfly database making the necessery cookie changes to the prefix_custom_config changing all the data that assosiates to the old domain name and may even have to change the cookie path as well.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

Re: Installing WoWRosterDF

Postby Anaxent » Sat Jul 29, 2006 8:12 am

aalwein wrote:I've gotten all the website to switch over and the cookies to work, but the damn uniuploader doesn't seem to want to follow suit.

On another note, I managed to get installed the itemstats for EQDKP and the Dragonfly setup (found here) and it works great... in EQDKP and Dragonfly (and the forums). Problem is, it messed up WoWRoster's mouse overs. See the site (www.lastrites.com) for the result.


Have you ever been able to get UU to upload as It does not pass cookies at this time. I was trying to find some one that new .net and c# to see what it would take to enable cookie handling. and for the itemstats for eqdkp you would want to remove rosters overlib files there are 2 of them and add them main themes header replacing the itemstats overlib file.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

Re: Installing WoWRosterDF

Postby aalwein » Sat Jul 29, 2006 8:25 am

I emptied the cache and did a search of my entire database for references to the old domain and changed them to the new domain. I think it must be working right but it's just not utilizing the cookies like you are saying. Guess it will just have to wait until you can figure that part out. The "manual update" mode works fine (ie. through the webpage). UU never worked from the start, btw.

For the overlib.js, could you explain it a bit more. Should I just remove the overlib.js for the roster and just use the one with itemstats? I deleted the overlib.js file from the roster directory and the mouseovers started to work, but they are working with no background (well a bright blue one anyway) that makes them hard to read.

Nevermind, I copied the overlib.js from the roster over to the dragonfly/forums overlib.js and all is well!

and btw, this is some awesome work, Anaxent, I wish I knew alot more about coding so I could help. As it stands, all I can do is minor changes and code updates :cyclops: That dkp integration is gonna be awesome!
Last edited by aalwein on Sat Jul 29, 2006 8:35 am, edited 4 times in total.
aalwein
WR.net Apprentice
WR.net Apprentice
 
Posts: 25
Joined: Sun Jul 23, 2006 8:41 pm

Installing WoWRosterDF

Postby jimig1 » Wed Aug 02, 2006 10:43 pm

to make it work correctly you want to delete overlib.js and overlib_hideform.js from modules/roster/css/js/ then the item stat will follow the mouse like it should
User avatar
jimig1
WR.net Apprentice
WR.net Apprentice
 
Posts: 36
Joined: Fri Jul 07, 2006 10:48 pm

Next

Return to Dragonfly

Who is online

Users browsing this forum: No registered users and 0 guests

cron