2.0 Requirements

Installation issues with WoWRoster

2.0 Requirements

Postby Corbism » Thu Oct 25, 2007 1:40 pm

We currently run roster 1.7.3. I was looking at requirements for 2.0 public beta and don't think we meet them.

We have:
PHP Version: 4.4.2
MYSQL Client API version: 4.0.26
GD support: Enabled (2.0.28 compatible, PNG Support enabled)
sql.safe_mode is Off

Would you recommended not to upgrade to Roster 2.0 due to our MYSQL version?

Thanks.
User avatar
Corbism
WR.net Apprentice
WR.net Apprentice
 
Posts: 51
Joined: Fri Sep 29, 2006 10:48 pm
Location: Seattle, WA

2.0 Requirements

Postby PleegWat » Thu Oct 25, 2007 3:02 pm

Can you list the mysql server version? A 4.0.x client version is not necessarily problematic.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: 2.0 Requirements

Postby Corbism » Thu Oct 25, 2007 10:43 pm

That initial info was what I got back from a phpinfo query.

I went into phpmyadmin and selected the database and went into "Server variables and settings" and next to Version it shows: 4.0.26-standard
Last edited by Corbism on Thu Oct 25, 2007 10:45 pm, edited 2 times in total.
User avatar
Corbism
WR.net Apprentice
WR.net Apprentice
 
Posts: 51
Joined: Fri Sep 29, 2006 10:48 pm
Location: Seattle, WA

2.0 Requirements

Postby GreenyHT » Thu Oct 25, 2007 11:18 pm

Hi PleegWat - I have a similar issue, however I'm getting an error that it won't install due to the fact that MySQL is 4.0.27 and not 4.1.x

Is there a way to force the install, or will server version 5.0.24 work?
GreenyHT
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Tue Oct 10, 2006 7:41 am

2.0 Requirements

Postby PleegWat » Thu Oct 25, 2007 11:21 pm

Didn't we fix that already?

It should only be checking mysql server version. Server version 4.1.x and 5.x work. Server version 3.x or 4.0.x do not work. Client version 3.x with server 4.x or 5.x is asking for trouble as well, IMHO, but we don't call restrictions there.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

2.0 Requirements

Postby zanix » Fri Oct 26, 2007 12:19 am

Yes we did fix that, but the installer will still notify anyway no matter what version you have and it won't let you install if you server version is lower than 4.1
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron