Help needed with Server Status

Joomla/Mambo integration forum

Help needed with Server Status

Postby psychic » Wed Nov 07, 2007 12:21 am

Righto, first thing to note is im on EU WoW and thats basically the problem

The Realm Status module allows you set an xml right, and US WoW is

http://www.worldofwarcraft.com/realmstatus/status.xml

However, i cant find Europes, the only one i can grab is

http://www.wow-europe.com/en/serverstatus/index.xml

And that isnt compatable

http://www.wow-europe.com/en/serverstatus/status.xml
http://www.wow-europe.com/en/serverstat ... status.xml
http://www.wow-europe.com/en/serverstat ... status.xml

None work.

So my question is, what is WoW-Europes XML link for the Realm Status?
Last edited by psychic on Wed Nov 07, 2007 12:25 am, edited 1 time in total.
psychic
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Nov 06, 2007 7:19 pm

Help needed with Server Status

Postby zanix » Wed Nov 07, 2007 2:32 am

Are you using 1.7.3 realmstatus or 2.0 beta realmstatus?
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Help needed with Server Status

Postby psychic » Wed Nov 07, 2007 2:52 am

From the XML file

- <mosinstall type="module" version="1.0.0">
<name>WoW Server Status</name>
<author>GameNuke.org</author>
<creationDate>Dec 2006</creationDate>

So i guess, neither? :P

According to their website i downloaded from, File Version:1.1

Any idea where I can download the versions you speak of?
psychic
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Nov 06, 2007 7:19 pm

Help needed with Server Status

Postby zanix » Wed Nov 07, 2007 3:05 am

I was assuming you were using the realmstatus the comes with Roster

You might need to get help from the place you downloaded it from
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Help needed with Server Status

Postby psychic » Wed Nov 07, 2007 3:09 am

Can the Realmstatus that comes with Roster be used seperately? Don't want to create too much bandwidth for myself so gotta thin down on the big extras
psychic
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Nov 06, 2007 7:19 pm

Help needed with Server Status

Postby zanix » Wed Nov 07, 2007 5:08 am

No, it uses the roster core to run
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Help needed with Server Status

Postby reznor » Fri Nov 09, 2007 7:00 pm

I've done a module for Joomla for this using code from Nick Schaffner.
You can download it from http://www.obscura-gilde.de/component/o ... lect/id,9/
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm

Help needed with Server Status

Postby zanix » Fri Nov 09, 2007 11:26 pm

Our Realm Status code is also based on Nick Schaffner's Realm Status
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Help needed with Server Status

Postby psychic » Sat Nov 10, 2007 2:10 am

reznor wrote:I've done a module for Joomla for this using code from Nick Schaffner.
You can download it from http://www.obscura-gilde.de/component/o ... lect/id,9/


Isn't working with my realm ¬_¬

Karazhan (EU Realm/English) - just comes back with "No Status Source"

Edit: I lie, its Blizzards fault " http://www.wow-europe.com/en/serverstatus " is down, hats off to them

EDIT2: nope, definately doesnt work with the realm Karazhan
Last edited by psychic on Sat Nov 10, 2007 6:15 am, edited 2 times in total.
psychic
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Tue Nov 06, 2007 7:19 pm

Help needed with Server Status

Postby reznor » Wed Nov 14, 2007 3:10 pm

Updated the module to make it browser cache safe.
I tested it with Karazhan and it's working.
Dependent on the selected refresh time it could take this time to update the image correctly.
The reason for this: the serverstatus page is not at anytime reachable when the module tries to update its status.
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm


Return to Joomla/Mambo

Who is online

Users browsing this forum: No registered users and 0 guests

cron