Ongoing Changes in the Armory break some ArmorySync function

Sync Blizzards' Armory data with WoWRoster (addon depreciated no longer works see ApiSync)

Moderators: Ulminia, poetter

Ongoing Changes in the Armory break some ArmorySync function

Postby Keviel » Tue Nov 27, 2007 1:06 am

Hmmm, it's buggered in the database too it seems - it seems it's already going wrong at the XML-parsing from Armory. (which I guess is what you're saying - I'm not too much into how and when the itemparser goes into effect - whether it's only during the XML-parsing, or also during the parsing of the view elements from the database.)

e.g.
Rawhide Shoulderpads Shoulders Leather58 ArmorDurability: 40 / 45Requires Level 20
Keviel
WR.net Apprentice
WR.net Apprentice
 
Posts: 60
Joined: Fri Oct 19, 2007 7:53 pm
Location: Copenhagen, Denmark

Ongoing Changes in the Armory break some ArmorySync function

Postby poetter » Wed Nov 28, 2007 7:02 am

Hi, seems like the construction site Armory is still in progress. Today i got a lot of 500 error and the entry page told me that i will need flashplayer.

I was able to fix the item tool tips but right now testing is a mess. I will wait until there is state i can analyze without changing every second day.

Stay tuned
Image
User avatar
poetter
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 462
Joined: Sat Jun 30, 2007 9:41 pm
Location: Germany/Hamburg

Re: Ongoing Changes in the Armory break some ArmorySync func

Postby tuigii » Wed Nov 28, 2007 7:14 am

Thanks for the '500' tip.
It must be that, or me going to Bliz HeadQuarters and waiting outside for this Armory-Dept programer coming out..... :D

Running a sync now on the test site ( :wink: ) with the speed of a, well, a turtle !?
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

Ongoing Changes in the Armory break some ArmorySync function

Postby moofa » Wed Nov 28, 2007 1:17 pm

After updating to the latest version using Roster Diag, then uploading ArmorySync i get this under manage addons.

The install definition file for armorysync did not contain a correct installation class
User avatar
moofa
WR.net Apprentice
WR.net Apprentice
 
Posts: 34
Joined: Thu Dec 07, 2006 3:04 am
Location: Canada

Ongoing Changes in the Armory break some ArmorySync function

Postby zanix » Wed Nov 28, 2007 2:08 pm

This is because of the changes required for the install class name

install.def.php
Find
Code: Select all
class armorysync


Change to
Code: Select all
class armorysyncInstall
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Ongoing Changes in the Armory break some ArmorySync func

Postby moofa » Thu Nov 29, 2007 8:05 am

zanix wrote:This is because of the changes required for the install class name

install.def.php
Find
Code: Select all
class armorysync


Change to
Code: Select all
class armorysyncInstall



Thank You!
User avatar
moofa
WR.net Apprentice
WR.net Apprentice
 
Posts: 34
Joined: Thu Dec 07, 2006 3:04 am
Location: Canada

Previous

Return to ArmorySync - Depreciated

Who is online

Users browsing this forum: No registered users and 0 guests

cron