ARC Display Issue

Posts from previous Beta sessions

ARC Display Issue

Postby Vlorn » Sat Dec 01, 2007 3:38 pm

I've been having a strange display problem with the ARC function to create better looking checkboxes and radio buttons. I originally thought it was just my addon but it seems to happen in any table with lots of buttons or checkboxes.

Attached is a screen shot from the per-character display table from the admin section of Character Information. Notice the unhidden checkboxes on the left side of the image, these represent the radio buttons on the right side of the table, the "clean" buttons still work but it is very annoying in large tables.

It only seems to happen with IE, as Firefox does not have the issue (big shocker there I know)



-Vlorn
Attachments
arcbug.jpg
arcbug.jpg (68.16 KiB) Viewed 351 times
User avatar
Vlorn
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Tue Jul 04, 2006 7:57 pm

ARC Display Issue

Postby zanix » Sat Dec 01, 2007 7:16 pm

I wonder if the left setting is too low
What is your monitor resolution?
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: ARC Display Issue

Postby tuigii » Sun Dec 02, 2007 12:24 am

zanix wrote:I wonder if the left setting is too low
What is your monitor resolution?


This is an old issue. Still present in Roster beta, as it was in 1.7.3 and before.

http://www.wowroster.net/Forums/viewtop ... html#17079

But I think Zanix is right.
When blowing up the screen res - and switching to English - or any other language that will make fit the entire image on the screen (horizontally) - the ‘error’ doesn't show up.

This is a java thing, making the code wrapping the X-base because output is being put beyond the right screen size.

Try it out yourself: max your resolution - switch the English (the most compact language - so columns will be smaller) and the row with buttons on the left side will vanish.
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

Re: ARC Display Issue

Postby Vlorn » Wed Dec 05, 2007 12:20 am

Hmm, the problem I'm seeing is almost the inverse of what you've described, if I make the IE window smaller, I almost (but not quite) get rid of all but the edge of the last row of buttons getting displayed on the left side of the screen. When I blow up IE such that there is more screen than needed is when I see the greatest number of buttons recreated on the left side. And I'm not seeing the issue at all with Firefox.

-Vlorn
User avatar
Vlorn
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Tue Jul 04, 2006 7:57 pm

Re: ARC Display Issue

Postby tuigii » Wed Dec 05, 2007 12:57 am

Yeah, we all love IE for these kind of performances, now don't we ?! :D :D
Last edited by tuigii on Wed Dec 05, 2007 12:58 am, edited 1 time in total.
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

ARC Display Issue

Postby zanix » Wed Dec 05, 2007 1:59 am

I'll try to adjust arc so the buttons are pushed further off screen
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: ARC Display Issue

Postby Vlorn » Sat Dec 08, 2007 10:31 am

Issue appears resolved with the .1500 build.

Thanks

-Vlorn
User avatar
Vlorn
WR.net Apprentice
WR.net Apprentice
 
Posts: 29
Joined: Tue Jul 04, 2006 7:57 pm

ARC Display Issue

Postby zanix » Sat Dec 08, 2007 10:37 am

NP
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US


Return to Archived

Who is online

Users browsing this forum: No registered users and 0 guests

cron