Guild information does not have submenu

Posts from previous Beta sessions

Guild information does not have submenu

Postby elvince » Thu Dec 13, 2007 12:14 am

Hello,
I am pulling my hair out, for some unknown reason, my guild information menu is inactive, I can click on it but not submenus icons... any hint?

http://www.rbones.net/wowroster/rosterc ... tion=guild

thank you

Vinchus
elvince
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Wed Jan 24, 2007 6:21 am

Guild information does not have submenu

Postby PleegWat » Thu Dec 13, 2007 3:01 am

Did you install any addons?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: Guild information does not have submenu

Postby elvince » Thu Dec 13, 2007 4:31 am

yes 3 addons:
- guild vaults
- Armory sync
- Character informations

but it was already like that before I installed them.

my admin password is: roster

feel free to have a look!

thank you for your help

vinchus
elvince
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Wed Jan 24, 2007 6:21 am

Guild information does not have submenu

Postby boyo » Thu Dec 13, 2007 5:32 am

I'm going to go as far as to say it's because your database isn't letting the script create temporary tables. It seems like it's stopping every time on install or uninstall of an addon. I'm not sure of the order in which things are processed when an install is run, but it's probably safe to assume that the temporary tables are created as a backup on install, so it's doing that before attempting to do the rest of the install..

There may be a way of disabling creating temporary tables, but I'm not sure how, or you may want to check your permissions for your database user and make sure it can create them.
boyo
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 103
Joined: Wed Jan 24, 2007 7:37 am

Guild information does not have submenu

Postby zanix » Thu Dec 13, 2007 6:02 am

Yes, you can disable the use of temporary tables in RosterCP -> Configure Main Roster -> Main Settings -> "Use temporary tables"
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Guild information does not have submenu

Postby zanix » Thu Dec 13, 2007 6:09 am

Yep
When trying to install the memberslist addon

1044: Access denied for user 'web75-wowroster'@'%' to database 'web75-wowroster'
SQL:
CREATE TEMPORARY TABLE `backup_roster_addon_config` LIKE `roster_addon_config`
File: lib/dbal/mysql.php
Line: 207


Then changing the setting allows it to be installed

I left the temp table setting off
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Guild information does not have submenu

Postby elvince » Fri Dec 14, 2007 2:35 am

great thank you that did it!
elvince
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Wed Jan 24, 2007 6:21 am


Return to Archived

Who is online

Users browsing this forum: No registered users and 0 guests