com_wowroster - Joomla 1.0.x Integration

Joomla/Mambo integration forum

Looking for some BETA Testers for Joomla component!

Postby Slyver » Fri Jan 25, 2008 10:56 pm

The SQL thing happens to the regular beta application so it can always be tested right now. I think they leave it on by default no matter what the setting.
Slyver
WR.net Apprentice
WR.net Apprentice
 
Posts: 31
Joined: Tue Jul 11, 2006 10:27 pm

Looking for some BETA Testers for Joomla component!

Postby Nefuh » Fri Jan 25, 2008 11:21 pm

Hey

to 1. this is original roster based and not modified by me

and 2. this is normal in the BETA Version this could´nt be disabled, read the BETA Info´s.

For the php error i will take a look at the file.

Nefuh
Administrator of the german User2User Community for WoWRoster.
Guild Master from Scum from Hell - Horde @ EU-Anetheron.
User avatar
Nefuh
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 213
Joined: Fri Sep 15, 2006 8:34 pm
Location: Krefeld Germany

Re: Looking for some BETA Testers for Joomla component!

Postby Lyco » Sat Jan 26, 2008 12:45 am

yeah i cant figure out how to disable ajax in joomla on the armorysync page how would i do that
Lyco
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 40
Joined: Sun Oct 14, 2007 10:28 pm

Re: Looking for some BETA Testers for Joomla component!

Postby Lyco » Tue Jan 29, 2008 12:20 am

/bump
Lyco
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 40
Joined: Sun Oct 14, 2007 10:28 pm

Looking for some BETA Testers for Joomla component!

Postby Nefuh » Tue Jan 29, 2008 12:36 am

Go to your Roster configuration -> Manage Addons -> Armory Sync there is a config item "Use AJAX" where you can disable AJAX in ArmorySync.
Administrator of the german User2User Community for WoWRoster.
Guild Master from Scum from Hell - Horde @ EU-Anetheron.
User avatar
Nefuh
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 213
Joined: Fri Sep 15, 2006 8:34 pm
Location: Krefeld Germany

Looking for some BETA Testers for Joomla component!

Postby Lyco » Fri Feb 01, 2008 10:26 pm

Hey just wanted to let you know it works great i would like to know how to port siggen over to the com_wowroster version
Lyco
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 40
Joined: Sun Oct 14, 2007 10:28 pm

Looking for some BETA Testers for Joomla component!

Postby zanix » Sat Feb 02, 2008 12:13 am

Lyco wrote:Hey just wanted to let you know it works great i would like to know how to port siggen over to the com_wowroster version
You shouldn't have to
Unless this port of Roster didn't change the makelink() function
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Looking for some BETA Testers for Joomla component!

Postby Nefuh » Sat Feb 02, 2008 1:16 am

The only changes on cmslink.lib.php are:

Adding 3 Lines on top of the File to get the Itemid of Joomla from the URL
on Line 39: Adding Joomla-Parameter to URL
on Line 51 and 62: Make ROSTER_URL and ROSTER_PATH Joomla compatible (added components/com_wowroster/ to URL´s)

So i think most of the roster addons should work, without problems.

Nefuh
Administrator of the german User2User Community for WoWRoster.
Guild Master from Scum from Hell - Horde @ EU-Anetheron.
User avatar
Nefuh
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 213
Joined: Fri Sep 15, 2006 8:34 pm
Location: Krefeld Germany

Looking for some BETA Testers for Joomla component!

Postby zanix » Sat Feb 02, 2008 2:34 am

Yeah, Anaxent did the same for the port of Roster to DragonFly
As long as the edits to cmslink.lib.php are made and the addon use the functions, variables, and constants defined there, the addon should work without conversion
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Looking for some BETA Testers for Joomla component!

Postby Lyco » Sat Feb 02, 2008 4:53 am

I am getting this php error when updating my character list and saving sigs to server
addons/siggen/inc/update_hook.php
Notice line 96: Undefined variable: sigdata

And all the images of the avatars and signatures do not show up
Lyco
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 40
Joined: Sun Oct 14, 2007 10:28 pm

Looking for some BETA Testers for Joomla component!

Postby Nefuh » Sat Feb 02, 2008 11:46 pm

There´s a new version of com_wowroster available at http://dl.wowroster.de -> Roster Integration -> Joomla.

If you have an previous version installed you need first to uninstall it. Remember to delete all tables inserted by addons must delete manually, before installing the new version.

Changes:

There was an issue when using siggen. Now it should work.
The deplaced images should be fixed.
com_wowroster now based upon Roster 2.0 SVN1625
SQL-Queries now in the installer XML file.


Nefuh
Administrator of the german User2User Community for WoWRoster.
Guild Master from Scum from Hell - Horde @ EU-Anetheron.
User avatar
Nefuh
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 213
Joined: Fri Sep 15, 2006 8:34 pm
Location: Krefeld Germany

Looking for some BETA Testers for Joomla component!

Postby Lyco » Sun Feb 03, 2008 6:43 am

I dont think the addon is using the settings defined there because upon saving the images in the update profile but they show everywhere else. even after the svn update it is not saving to my server.
Code: Select all
Displaying:
http://www.tuahq.org/components/com_wowroster/index.php?option=com_wowroster&Itemid=26&p=util-siggen-signature&etag=0&member=1
Instead of
http://www.tuahq.org/index.php?option=com_wowroster&Itemid=26&p=util-siggen-signature&etag=0&member=1

The Last one would allow it to save to my server if it was used in sequence with the guild update but it is putting the first one in instead i really dont know how to fix it. It is acting almost like seo is activated in siggen when saving
Last edited by Lyco on Sun Feb 03, 2008 7:33 am, edited 1 time in total.
Lyco
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 40
Joined: Sun Oct 14, 2007 10:28 pm

Looking for some BETA Testers for Joomla component!

Postby Nefuh » Sun Feb 03, 2008 9:03 am

Thanks for info, i take a look and give you notice when i have a fix.

Nefuh
Administrator of the german User2User Community for WoWRoster.
Guild Master from Scum from Hell - Horde @ EU-Anetheron.
User avatar
Nefuh
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 213
Joined: Fri Sep 15, 2006 8:34 pm
Location: Krefeld Germany

Looking for some BETA Testers for Joomla component!

Postby Nefuh » Mon Feb 04, 2008 5:20 am

It looks like i have a solutions for the wrong text link ;)

Open /addons/siggen/char/index.php

Look at line 75 it should begin with:

Code: Select all
str_replace('.html''.' $row['image_type']... 


change this to:

Code: Select all
$roster->config['website_address'] . str_replace('.html''.' $row['image_type']... 


and in the same line (75) look for:

Code: Select all
...makelink('util-' $addon['basename'] . '-' $row['config_id'] . '&member=' $member_str,true)... 


change this to:

Code: Select all
...makelink('util-' $addon['basename'] . '-' $row['config_id'] . '&member=' $member_str,false)... 


Now set in your roster configuration the "Website Address" to your path to joomla (for example: http://localhost/joomla/).

Only use with com_wowroster not with the normal roster versions.

Now siggen should display the right URL to the images.

Nefuh
Attachments
new_index_file_for_siggen.zip
Only to use with com_wowroster not with the normal versions. Make a backup of the original /addons/siggen/char/index.php and replace the original file with this one.
(1.41 KiB) Downloaded 75 times
Administrator of the german User2User Community for WoWRoster.
Guild Master from Scum from Hell - Horde @ EU-Anetheron.
User avatar
Nefuh
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 213
Joined: Fri Sep 15, 2006 8:34 pm
Location: Krefeld Germany

Re: Looking for some BETA Testers for Joomla component!

Postby Nefuh » Mon Feb 04, 2008 5:38 am

Ok here´s the next fix ;)

Now on my local testsystem (com_wowroster, Joomla) all images will be displayed and saved.

Open ./addons/siggen/inc/update_hook.php.

Look at line 147 and 153 there you should find:

Code: Select all
...makelink('util-' $this->data['basename'] . '-' $config '&etag=0&member=' $member_id,true)... 


Change this (in each line) to:

Code: Select all
...$roster->config['website_address'].makelink('util-' $this->data['basename'] . '-' $config '&etag=0&member=' $member_id,false)... 


Line 147 seems to be for upload cp.lua manually and Line 153 seems to be for cp.lua upload over uniuploader.

Nefuh
Attachments
update_hook.zip
New update_hook.php to make siggen work in com_wowroster. Do not use it for normal versions.
(2.09 KiB) Downloaded 79 times
Administrator of the german User2User Community for WoWRoster.
Guild Master from Scum from Hell - Horde @ EU-Anetheron.
User avatar
Nefuh
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 213
Joined: Fri Sep 15, 2006 8:34 pm
Location: Krefeld Germany

PreviousNext

Return to Joomla/Mambo

Who is online

Users browsing this forum: No registered users and 0 guests

cron