Errors when displaying some characters individual PVP info

Forum Dedicated to PvPLog, (The WoW PvP data collector addon), and PvPLog related topics

Moderator: bsmorgan

Errors when displaying some characters individual PVP info

Postby Argusi » Tue Mar 18, 2008 11:12 pm

I have an issue where a couple of different characters error when viewing their PVP information. So far this is on 2 different accounts. I get the error when clicking on a member to get their character page, then clicking on the PvP button to look at their individual stats.

We have been running CP 2.3.1a and now running the PvPLog rev 21 from SVN. Running WoWRoster 1.9.9.1733.

This happened on the earlier version of PvPLog and WoWRoster with earlier SVN revs. I've deleted the database and installed everything fresh with the same issue with the same characters. The other people experiencing this have not had a chance to upload since the rebuild today.

It's a database error of some sort. I've attached the output. Thank you for any suggestions on this. You guys do a great job!
Attachments
sql_error.txt
(3.97 KiB) Downloaded 108 times
Argusi
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Mar 04, 2008 11:28 pm

Errors when displaying some characters individual PVP info

Postby Argusi » Wed Mar 19, 2008 2:55 am

Hmm, it appears to be an error handling routine or debug exit. I'm no expert, by any means in php, but this is what I see, right or wrong.

pvp.lib.php has several lines to find "get world best zone", "get world worst zone" etc. Now, if it appears that in these two sections for instance, best zone works, worst zone fails (line 728). If I look at the database it is grabbing the following:

best zone: enemy 1, bg 0, win 1
worst zone: enemy 1, bg 0, win 0

The case for worst zone does not exist for that memberid, so it errors out. This looks like a debug statement. The handling of no case is where the problem is.

I changed the DB query to look for 1, 0, 1 and it passed that and went to the next error. I changed that and the page came up albeit with incorrect stats, but that is what I expected. Hope this helps?

I've attached a pdf with that members tables. If you prefer another format, I can do most.
Attachments
roster_addons_pvplog_pvp2.pdf
(217.54 KiB) Downloaded 110 times
Last edited by Argusi on Wed Mar 19, 2008 3:00 am, edited 2 times in total.
Argusi
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Mar 04, 2008 11:28 pm

Errors when displaying some characters individual PVP info

Postby bsmorgan » Wed Mar 19, 2008 3:42 am

As you have discovered, this is an error on the WoWRoster side. Those developers visit here so we'll wait for them to comment.

The work around is, of course, to tell this user to lose a battle once in a while! :D

Then there's my case which will probably fail as well... I can't win at all! :oops:

Regards,

Brad
Last edited by bsmorgan on Wed Mar 19, 2008 3:47 am, edited 2 times in total.
User avatar
bsmorgan
WoW Interface Developer
WoW Interface Developer
 
Posts: 160
Joined: Tue Nov 28, 2006 10:17 pm
Location: Colorado Springs, Colorado

Re: Errors when displaying some characters individual PVP info

Postby bsmorgan » Wed Mar 19, 2008 3:58 am

Argusi wrote:We have been running CP 2.3.1a and now running the PvPLog rev 21 from SVN. Running WoWRoster 1.9.9.1733.


If you are running a version of PvPLog from SVN then you must be running on the PTR servers. SVN code beyond revision 15 won't work on the current WoW 2.3.3 servers.

It is possible that the version of PvPLog you are running doesn't record losses correctly. Please verify that both wins and losses are happening (and then that they are being recorded).

The data you posted shows duels as well as wins against the other faction. This data has to be from the PvPLog 2.5.1 or earlier because current SVN code doesn't record duels anymore.

I am, at this point, completely confused... :?

Regards,

Brad
Last edited by bsmorgan on Wed Mar 19, 2008 4:00 am, edited 2 times in total.
User avatar
bsmorgan
WoW Interface Developer
WoW Interface Developer
 
Posts: 160
Joined: Tue Nov 28, 2006 10:17 pm
Location: Colorado Springs, Colorado

Errors when displaying some characters individual PVP info

Postby Argusi » Wed Mar 19, 2008 4:29 am

1st, it may kooky be because I updated to the SVN version, but never deleted the old lua since I started?

2nd, DOH! No PTR for me. I guess I need to roll back to the previous version.

That toon is an alt I'm leveling, so the only pvp is when he gets ganked. My main is a 'lock that is a bit more active ;o)

I'll blow away the DB entries, backrev PvPLog and delete my lua to at least get things back on track. I'll try that out and get back. Thanks!
Argusi
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Mar 04, 2008 11:28 pm

Errors when displaying some characters individual PVP info

Postby Argusi » Wed Mar 19, 2008 10:42 pm

Sleeping on this I realized although I don't know PHP, it's just a form of code that I'm not familiar with. I thought it looked like debug code before, so I removed it. Heh, so if the query returns nothing, it just keeps going. Well, it seemed to work. If it blows up on me, I'll update the thread.
Argusi
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Mar 04, 2008 11:28 pm

Errors when displaying some characters individual PVP info

Postby Argusi » Tue Mar 25, 2008 1:33 am

Put the workaround under another post just written:
http://www.wowroster.net/Forums/viewtop ... html#32782
Argusi
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Tue Mar 04, 2008 11:28 pm


Return to PvPLog

Who is online

Users browsing this forum: No registered users and 0 guests