major roster problem - roster is going crazy

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

major roster problem - roster is going crazy

Postby Grammaton » Fri May 02, 2008 8:35 pm

Hi,

i have a realy big problem with roster version 1.7.3.
The Roster deletet all Membersdata ...

For some time now i realized a strange behaviour in the memberslog everytime people joined or left the guild.

In the Memberslog there are always several entries for every transaction.
player Mike deletet .. player Mike added .. player Mike deletet .. player Mike added
or
added .. deletet .. added

And yesterday after a guild upload .. all members have been deletet.
And with the next update all members have been added new.

This is catastrophic because we rely very strong on the roster.

What could be the problem here?

We are updating the roster from 2 different pcs.
Could this be a part of the problem?

Thx in advance for any help!


P.S.: We are using Guild- and Charakterprofiler v2.3.1a for updating the Roster.
Grammaton
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Fri Feb 22, 2008 2:45 am

major roster problem - roster is going crazy

Postby zanix » Sat May 03, 2008 12:40 pm

Yes, updating from 2 different PC's might be your problem
Roster 1.7.3 does not check the time stamp of the guild export and will allow an older export to overwrite a newer upload

Roster 2.0 beta has fixed this issue
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

major roster problem - roster is going crazy

Postby Grammaton » Sat May 03, 2008 2:09 pm

Ok, thx for your reply Zanix.

The strange thing is, that this memberlog behaviour i mentioned above, started months ago and even if we didnt update from 2 different pcs.
But maybe it was the trigger for our problems.

Another aspect is, that even if we would have uploaded an "older" file, the files where never that old that it could lead to an overall deletion.

I assume that for some reason, maybe because of updating from different sources or because of a computer crash during an update, something in the roster was broken.

Now, after he deletet all Members and made new database entries for them, it seems that the roster ist working fine again.
I hope this never happens again.

Do you have some explanations what else could have triggered this malfunction?
I want to avoid this from happening again under all circumstances.

Thank you!
Last edited by Grammaton on Sun May 04, 2008 4:11 am, edited 3 times in total.
Grammaton
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Fri Feb 22, 2008 2:45 am


Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 0 guests