RosterDF 2.0[svn 1758] Issues

Dragonfly integration forum

RosterDF 2.0[svn 1758] Issues

Postby ElFe0 » Wed May 14, 2008 5:32 pm

Hi, I downloaded & Installed on my Dragonfly CMS 9.2.1.2 the wowRosterDF 2.0b on the sticky with the correspondent imagepack for the 2.0, with the new images of the patch 2.4. Seem's that I'm missing most of the images on the menu as shown on the image below. Maybe should be a spelling problem as I saw in other threads, I've checked mine & the names are like this: "Ability_BackStab.jpg".
Also, I still can't see the realm status, I've tried previously on the 1.7.3 version, but it has the same problem for me: the guild & realm is not recognized on the armory, so it say's the this guild from this server could not be found, so the realmstatus is on Unknown status. I think I did it right when saving in-game the characterprofile & guildprofile, & after uploading the correct CharacterProfile.lua. (btw, Im trying to retrieve the guild data from EU servers, certainly from a Spanish server)
Image
And finally there's another question I saw in the Roster Diag:
Image
I've tried to update the package but first I get the "WoWRoster_UpdatePackage_20080514_0639.zip", then after I downloaded that (I didn't upload this on my website yet) I click again the get update package and it get's me _0741.zip file. Are those svn older than the WoWRosterDF 2.0 [svn 1758] from the sticky?
Any ideas?
Last edited by ElFe0 on Thu May 15, 2008 4:46 am, edited 5 times in total.
ElFe0
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Apr 21, 2008 11:32 pm

[svn 1758] Issues

Postby zanix » Thu May 15, 2008 2:38 am

Realm status in image mode does not work in RosterDF as of yet, use div container/text mode

The path to the interface icons might be wrong, I would check it
Or you may still be using the image pack for 1.7.3, make sure you have the pack for 2.0 found in "the BETA Files" forum

I'm surprised RosterDiag even works in RosterDF
The version checking is against the standalone version of Roster, so the file check in RosterDiag in RosterDF is useless
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: [svn 1758] Issues

Postby ElFe0 » Thu May 15, 2008 4:48 pm

Too bad then, about the image status :(. I switched to the DIV mode, & It's pretty nice, so, for now i'll stay like this.

The path of my image pack wich one is the 2.0 found in the Beta files, is like this: "/public_html/modules/WoWRosterDF/img/Interface", where in the Interface folder I put the extracted folders: Icons, PvPRankBadges etc. I think I'm using the right package, I would recheck it.

Ok, so I would start ignoring the RosterDiag, for now :D.
ElFe0
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Apr 21, 2008 11:32 pm

RosterDF 2.0[svn 1758] Issues

Postby zanix » Thu May 15, 2008 10:05 pm

Change the image path to
modules/WoWRosterDF/img/
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

RosterDF 2.0[svn 1758] Issues

Postby Equisetum » Thu May 15, 2008 10:42 pm

For some reason I can't get my images to load up either. I have the exact path to what you have above, Zanix, and have tried a dozen other variations including full url...

I even deleted the image pack and reloaded.

Suggestions?
Image
User avatar
Equisetum
WR.net Apprentice
WR.net Apprentice
 
Posts: 65
Joined: Mon Jul 24, 2006 6:44 am

Re: RosterDF 2.0[svn 1758] Issues

Postby ElFe0 » Fri May 16, 2008 1:49 am

As Equisetum said, the problem still there, don't know why. :?
ElFe0
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Apr 21, 2008 11:32 pm

RosterDF 2.0[svn 1758] Issues

Postby petrakid » Fri May 16, 2008 4:27 am

After I updated to RosterDF beta, the missing images issue went away. I also turned LEO on in DF settings, but not sure it that had any effect on the image problem.

If you updated from the alpha to the beta, you should probably remove it all again and start from the instructions on the Beta WoWRosterDF thread

http://www.wowroster.net/Forums/viewtopic/t=5265.html

I know it's working fine for me, and for others, so if it's not working for you, go right back to the start and try again. Turn LEO on as well as it seemed to fix other minor issues I had...not sure if it has anything to do with the images.
Image
User avatar
petrakid
WR.net Apprentice
WR.net Apprentice
 
Posts: 53
Joined: Sat Jul 07, 2007 7:34 am

Re: RosterDF 2.0[svn 1758] Issues

Postby ElFe0 » Fri May 16, 2008 4:29 am

I did a complete install, no update, from the Stiky thread. I also had all the time LEO turned on, but I've tried turning off & the result is the same.
ElFe0
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Apr 21, 2008 11:32 pm

RosterDF 2.0[svn 1758] Issues

Postby petrakid » Fri May 16, 2008 8:54 pm

Hmm, I wonder if it may have something to do with the overlib. I was just looking through the page source and many of the menu options utilize the overlib. Overlib is the java script that makes the mouseover popups. I had all sorts of issues with the script - I use item_stats, and it also uses overlib. I had to go to the item_stats author's website and download the item_stats package and put a fresh copy of overlib.js on the server. After I did that, item_stats started working better and RosterDF seemed to improve a lot.

It's worth a try - go to http://itemstats.free.fr and download a copy (it doesn't have to be DF compatible or anything, as all you'll be utilizing is the overlib.js)

Extract the overlib.js file. You'll want to upload a copy of it into your modules/WowRosterDF/js directory and into your modules/item_stats/overlib directory (if you use itemstats). Clear you cache in DF and WoWRosterDF and give it a try. This is no guarantee. Again, the only things I did was to turn LEO ON and update overlib.js.

** When uploading overlib.js, BE SURE to do it in UTF8. I didn't, and I had to manually fix the entire script - it was all screwed up.
Image
User avatar
petrakid
WR.net Apprentice
WR.net Apprentice
 
Posts: 53
Joined: Sat Jul 07, 2007 7:34 am

Re: RosterDF 2.0[svn 1758] Issues

Postby ElFe0 » Sun May 18, 2008 12:11 am

Atm, I don't have the ItemStats installed, before I wanted to see everything is fine without the stas module. I've tried what you said: replacing the overlib.js but nothing seems to have changed, I still had the problem :(. If anyone else had any idea, I will apreciate it.
ElFe0
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Apr 21, 2008 11:32 pm

RosterDF 2.0[svn 1758] Issues

Postby ElFe0 » Mon May 19, 2008 7:06 pm

I have another issue: I can't turn off the PHP Debug mode and the SQL Window. In the menu, is shown as Off, but it stills there showing all the SQL queries and the php warnings. I tried turning on then off again, and also in extended mode then switch back but there's no way :(.
ElFe0
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Apr 21, 2008 11:32 pm

Re: RosterDF 2.0[svn 1758] Issues

Postby Anaxent » Mon May 19, 2008 9:08 pm

ElFe0 wrote:I have another issue: I can't turn off the PHP Debug mode and the SQL Window. In the menu, is shown as Off, but it stills there showing all the SQL queries and the php warnings. I tried turning on then off again, and also in extended mode then switch back but there's no way :(.


This is because it is still the beta version when Roster releases you will have full control over the debugging.
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az

Re: RosterDF 2.0[svn 1758] Issues

Postby ElFe0 » Tue May 20, 2008 1:20 am

This is because it is still the beta version when Roster releases you will have full control over the debugging.

Understood, I will wait patientlly, but any RC or future releases dates? Btw, I still have got the imagepack issues, I've tried many things but with no result :(. I've noticed that the Imagepack is also copied on the root/images/wowrosterdf/Interface, where the Dragonfly image patch, not in modules, maybe this has something to do with it :S.
ElFe0
WR.net Apprentice
WR.net Apprentice
 
Posts: 8
Joined: Mon Apr 21, 2008 11:32 pm

RosterDF 2.0[svn 1758] Issues

Postby Anaxent » Tue May 20, 2008 1:26 am

For now you can use my path

Interface Directory URL - http://www.secret-order.us/svn/
Roster Images Directory URL - modules/wowrosterdf/img/

wowrosterdf is equal to the name of your module
User avatar
Anaxent
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 642
Joined: Tue Jul 04, 2006 6:27 am
Location: Phoenix, Az


Return to Dragonfly

Who is online

Users browsing this forum: No registered users and 0 guests

cron