Database Error1048 pn upload.

View planned events from the WoW AddOn GroupCalendar

Moderator: Ulminia

Database Error1048 pn upload.

Postby revjackcheese » Mon Jun 23, 2008 1:08 pm

Using ver 2.0 WoWroster and current GroupCalendar. getting this error on upload.

Spitfire was our old guild, about 2 weeks ago. Renamed to Seduction. How can I fix?

Thanks.

Database Error1048: Column 'start' cannot be null
SQL:
INSERT INTO roster_addons_GroupCalendar_info SET `id`='6', `creator`='Nasek', `start`=FROM_UNIXTIME(-2085857400), `title`='', `type`='Meet', `description`='hahaha', `guildonly`='Spitfire', `duration`='15', `maxlevel`='70', `maxattend`='10', `limits`='Healers: 2
Melee: 2
Off-Healers: 2
Off-Tanks: 2
Ranged: 2
Tanks: 2
'
File: lib\dbal\mysql.php
Line: 234
revjackcheese
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Wed Jun 18, 2008 7:30 am

Re: Database Error1048 pn upload.

Postby tuigii » Mon Jun 23, 2008 1:30 pm

What about a :
De-install addon.
Re-install addon ?

(a Guild can be renamed ? Didn't now that :wink: )
Last edited by tuigii on Mon Jun 23, 2008 1:31 pm, edited 1 time in total.
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

Database Error1048 pn upload.

Postby Ulminia » Mon Jun 23, 2008 3:22 pm

this error has to do with the unixtime stamp on your server its comming up as 0 but the start time should be what is in the lua file this meas you have bad data in your file try rebuilding the database ingame and try agian
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Database Error1048 pn upload.

Postby revjackcheese » Mon Jun 23, 2008 8:10 pm

tuigii wrote:What about a :
De-install addon.
Re-install addon ?

(a Guild can be renamed ? Didn't now that :wink: )


Well every one quit (but the gm) and started a new one. :)

Ive dumped the lua 3 times so far and rebuilt. Im going to try and get the player Nasek to dump his and rebuild. I think thats where the corruption is coming from.

thanks for the help.
revjackcheese
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Wed Jun 18, 2008 7:30 am

Database Error1048 pn upload.

Postby Ulminia » Mon Jun 23, 2008 11:37 pm

no matter who uploads the data the tables in the database are dumped every time and only the events in your lua are uploaded and shown. make sure you are using GC4.0.4 and if you are still haven issues send me the lua ial have a look at it
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Database Error1048 pn upload.

Postby revjackcheese » Tue Jun 24, 2008 7:58 am

Still no love..

Here is the lua
Attachments
groupcalendar.lua
(50.26 KiB) Downloaded 85 times
revjackcheese
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Wed Jun 18, 2008 7:30 am

Database Error1048 pn upload.

Postby Ulminia » Tue Jun 24, 2008 7:56 pm

i looked it over it all looks ok.. ial see what the issue is here in a bit..
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Database Error1048 pn upload.

Postby revjackcheese » Fri Jun 27, 2008 11:59 am

any ideas?
revjackcheese
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Wed Jun 18, 2008 7:30 am

Database Error1048 pn upload.

Postby Ulminia » Fri Jun 27, 2008 8:03 pm

no ideas at all .. purge the lua (delete it and the backup) and then re sync it and try agian
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com


Return to Group Calendar

Who is online

Users browsing this forum: No registered users and 0 guests

cron