mySQL Version

Installation issues with WoWRoster

mySQL Version

Postby Tokrie » Tue Jul 01, 2008 12:27 am

Hello together,

first off all sorry for my bad english.

I use a time the Version WoWRoster v1.7.3 and want install the new verion, but i have sone big problems.

This is the error:
MySQL server version 4.1.0 or higher is required for Roster.

You are running:
Your server version: 4.0.24_Debian-1.dotdeb.0-log
Your client version: 4.1.10a
We are sorry, your MySQL server version is not high enough to install Roster, please upgrade MySQL.


But my Server Suppot say: that ist the highst verion of mysql for Debian Woody.

Has anyone an idea?

Beste regards

Tobias
Tokrie
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sun Dec 10, 2006 1:59 am

mySQL Version

Postby zanix » Tue Jul 01, 2008 1:11 am

There are SQL queries in Roster 2.0 that require MySQL 4.1 or higher
You can try to override this detection and force Roster to install by editing install.php, and comment or remove lines 645 - 670

We cannot guarantee that Roster will work on MySQL lower than 4.1, I personally have not tried it, but there are queries that are MySQL 4.1+ only

We will also not provide support for your install if your server does not meet Roster's requirements
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

mySQL Version

Postby Tokrie » Tue Jul 01, 2008 1:37 am

This was my first idea, but it dos not work.

i think i must wait for an new php version under Debian Woody.


Thank you for your help.
Tokrie
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Sun Dec 10, 2006 1:59 am

mySQL Version

Postby Diska » Tue Jul 01, 2008 1:43 am

Security support for Debian Woody ended a couple of years ago, security support for it's successor Sarge ended at the end of March this year.
I think you should wait for an upgrade of your entire server, not just for mysql. If you're going to wait for a newer mysql version for Woody you'll be waiting forever
User avatar
Diska
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 179
Joined: Tue Jul 04, 2006 2:05 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron