[REGLÉ] - [Frensh] problème d'instalation.

Installation issues with WoWRoster

[REGLÉ] - [Frensh] problème d'instalation.

Postby Spoon » Sun Jul 06, 2008 10:49 pm

bonjour,

voilà mon soucis, lors ce que je lance l'install du roster 2.0 j'ai une erreur sql ou php selon si je remplis ou non les champs optionnel Create Database Options en bas.

quand je rempli suniquement la partie Database Configuration
j'ai l'erreur suivante qui s'affiche une fois que je clique sur proceed.

En haut de page cela me dit ca : Notice: Undefined index: default_lang in /web/dreamquest/www/roster/install.php on line 893

Et en encadré rouge : Failed to connect to database dreamquest as dreamquest@sql2
2002: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)


Et quand je remplis Database Configuration ainsi que la partie Create Database Options et que je clique ensuite sur proceed, cela me faitl'erreur suivante.

Notice: Undefined index: default_lang in /web/dreamquest/www/roster/install.php on line 893

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /web/dreamquest/www/roster/lib/dbal/mysql.php on line 176

Notice: Undefined property: config in /web/dreamquest/www/roster/lib/functions.lib.php on line 149

Notice: Undefined property: config in /web/dreamquest/www/roster/lib/functions.lib.php on line 154

Notice: Undefined property: db in /web/dreamquest/www/roster/lib/functions.lib.php on line 160

Fatal error: Call to undefined function: border() in /web/dreamquest/www/roster/lib/functions.lib.php on line 165


quelqu'un pourait il me venir en aide et me dire ou est ce que je fait une erreur.
car je remplis bien tout.
exemple :
Locale Configuration
Default Locale: french

Database Configuration
Database Type: MySql 4.1.x / 5
Database host: nom de l'hote de ma base de donnée
Database name: dreamquest
Database username: dreamquest
Database password: mot de passe de ma base de donnée
Prefix for Roster tables: Roster_
Main Site URL Link: http://www.dream-quest.net

Create Database Options
Database Create username: Dreamquest
Database Create password: mot de passe de la base de donnée.

merci d'avance pour votre aide.
en français si possible.
Last edited by Spoon on Mon Jul 07, 2008 6:49 pm, edited 1 time in total.
Spoon
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Mon Apr 28, 2008 8:21 pm

[Frensh] problème d'instalation.

Postby tuigii » Mon Jul 07, 2008 1:04 pm

Salut,

Il me semble utile de nommer ton hébergeur.
Votre version SQL, votre version PHP ?

Sinon, partons du principe que vous ne pouvez pas 'normalement' créer des bases des données. Votre hébergeur vous en donne un, et c'est à vous (l'installateur du roster, dans tout les cas) de créer des tables.

J'ai compris que votre serveur SQL est joignable par "sql2".
Vous avez du recevoir un mail (ou autre envoi) qui vous confirme que votre base des données s'appelle « dreamquest » - et le nom de l'utilisateur s'appelle "dreamquest" (humm, jusqu'au la, c'est exactement comme chez moi : je suis chez OVH avec pas mal des 60GP et 90plan).

Bien attendu, vous essayez de joindre votre serveur SQL à partir de votre serveur web

Donc,
sql2
dreamquest
dreamquest
Mot de passe
Prefixe (vous avez le choix ici – presque tout est bon, « roster_ » est un bon choix)
Est tout ok.

Mon conseil : n’utilise pas les options : « Create Database Options ».
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

[Frensh] problème d'instalation.

Postby Spoon » Mon Jul 07, 2008 2:31 pm

tu as raison dans ce que tu écrit mais rien à faire.
pas moyen de créer les table.
mon serveur sql est bien SQL2
ma base de donné et mon nom d'utilisateur est bien dreamquest.
je remplis bien mon mot de passe et j'ai bien mis roster_ comme préfixe.
mais rien à à faire, impossible de créer la base de donnée.
et ce même si je ne touche pas à « Create Database Options » et que je laisse vide.

je n'ai jamais eu ce problème avant.
j'ai installer 3 forums bien distinc les uns des autres sur ce serveur avec ces même infos et tout est ok.
j'ai même installer la version beta du roster 2.0 et cela à été aussi.

J'ai ensuite vider tout les fichier du roster sur mon ftp, j'ai supprimer tout ma base de donner sur mon serveur sql concernant mon roster.
Et plus moyen de faire une nouvelle installation avec la version finale.

il me fait à chaque fois l'erreur suivante :

En haut de page cela me dit ca : Notice: Undefined index: default_lang in /web/dreamquest/www/roster/install.php on line 893

Et en encadré rouge : Failed to connect to database dreamquest as dreamquest@sql2
2002: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)


PS: je suis héberger chez nuxit.com
Spoon
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Mon Apr 28, 2008 8:21 pm

Re: [Frensh] problème d'instalation.

Postby tuigii » Mon Jul 07, 2008 3:27 pm

Spoon wrote:Et en encadré rouge : Failed to connect to database dreamquest as dreamquest@sql2
2002: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)


Passe au plan B : connecte toi avec phpmyadmin sur ton serveur SQL - ceci doit fonctionner d'abord avant de passer à autre chose.

Il est clair que il y a quelque chose de pas correcte entre ces trois données :
L'adresse du serveur - le nom d'utlisateur et son mot de passe.
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

[Frensh] problème d'instalation.

Postby Spoon » Mon Jul 07, 2008 5:03 pm

cela fonctionne.
je parviens bien à me connecter à mon serveur sql via phpmyadmin.

sinon j'ai tout recommencer au moins 10 fois et cela me fait tjs la même erreur.
alors que avec la bêta j'ai pas eu de problème.
et je précise que j'ai bien supprimer le dossier roster de mon ftp et que j'ai bien supprimer aussi tout les fichier roster_ de la base de donner sql avant de uploader la version final du roster.
Spoon
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Mon Apr 28, 2008 8:21 pm

[Frensh] problème d'instalation.

Postby Spoon » Mon Jul 07, 2008 6:48 pm

Alors là tu va rire.
je viens de le refaire dans un dernière espoir.
Et paf cela fonctionne.
C'est à ne plus rien comprendre, vu que j'ai fait exactement la même chose que je fait depuis plusieurs jours déjà.

enfin, bon maintenant et je ne sais pour quel raison, cela marche et l'installation c'est faite sans problème.

encore un grand merci pour ton aide en tout cas.
Spoon
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Mon Apr 28, 2008 8:21 pm

Re: [Frensh] problème d'instalation.

Postby hectelior » Mon Jul 07, 2008 7:13 pm

Bonjour à tous !

content que ça marche chez toi.
j'ai le même problème, mais celui ci n'est toujours pas résolu...
j utilise depuis assez longtemps WoWRoster, j'ai même installé les Betas de la V2 mais la... 'est le drame. même symptômes que chez Spoon...

Des Idées ?

PS : Mes id de connection à la DB sont sûres.
hectelior
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Mon Dec 18, 2006 1:58 pm

Re: [Frensh] problème d'instalation.

Postby tuigii » Mon Jul 07, 2008 8:13 pm

Content pour toi :)

Spoon wrote:...
alors que avec la bêta j'ai pas eu de problème.
...


Aha !

Sache que dans la procédure d'install peu de choses sont modifiées depuis pas mal de temps.

Comme vous avez pu constater, d'autres ont la même question ^^
Veuillez bien reflechir en quoi la 10 ieme tentative été la bonne, et les autres non.

Comme d'hab - ensemble, on y'arrive :pright:
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

Re: [Frensh] problème d'instalation.

Postby hectelior » Tue Jul 08, 2008 3:16 pm

Noob attitude :p

voila le soucis :

si vous ne disposez pas de droits d'admins sur votre Serveur de BDD, vous n'aurez pas le droit de créer un nouvel utilisateur.

il ne faut donc pas remplir ces champs à l'install :

Create Database Options

Database Create username: *****
Database Create password: *****


c'est tout bête mais je suis tombé machinalement dans piège !

Merci pour le support !
hectelior
WR.net Apprentice
WR.net Apprentice
 
Posts: 2
Joined: Mon Dec 18, 2006 1:58 pm

[REGLÉ] - [Frensh] problème d'instalation.

Postby Spoon » Sat Jul 12, 2008 3:52 pm

avec ou sans le fait de remplir Create Database Options cela ne changeais rien chez moi.

j'avais une erreur avec les deux façon. ( en remplissant Create Database Options j'avais une erreur, et si je laissais vide, j'en avais une aussi )

mes log étais bon, j'avais tout les droit nécessaire, et pourtant impossible à installer.

et en une fois je ne sais pour quelle raison, tout à fonctionner alors que je n'ai rien fait de différent.

donc si je connaissais le problème ou le comprenais je t'aurai bien aider mais là j'avoue que le comment du pourquoi sur ce coup là est incompréhensible.

me reste plus que à régler quelque bug de certain add on qui sont soit disant compatible avec la version 2.0
Spoon
WR.net Apprentice
WR.net Apprentice
 
Posts: 5
Joined: Mon Apr 28, 2008 8:21 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron