Roster 2.0 data getting wiped?

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

Roster 2.0 data getting wiped?

Postby Calystos » Sun Aug 24, 2008 4:14 pm

Okay, having looked via search an things on the forums I noticed people had similar problems with v1.x.x but that these problems were fixed in v2.x.x.

Yet for some reason I just installed a fresh install of v2.0 yesterday and uploaded the entire roster that was saved with a fresh scan/save of both Character & Guild Profilers. Confirmed they were all entirely uploaded and went to bed. I just logged in to see that the entire roster was wiped and was getting error messages about no guild found, etc.

Anyone else having this problem or is it just me?

Also, anyone have any ideas how to fix?
User avatar
Calystos
UA/UU Developer
UA/UU Developer
 
Posts: 140
Joined: Tue Mar 04, 2008 10:57 am
Location: Earth

Roster 2.0 data getting wiped?

Postby PleegWat » Sun Aug 24, 2008 5:41 pm

Did you set a default guild?

Does anyone else have the admin password?

Is ArmorySync installed and enabled?
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: Roster 2.0 data getting wiped?

Postby Calystos » Sun Aug 24, 2008 6:01 pm

PleegWat wrote:Did you set a default guild?

Does anyone else have the admin password?

Is ArmorySync installed and enabled?


Default guild set, yes.
Only I know the Admin password, but I've set the roster to upload via a modified UniUploader client using the Officer password (which only the Officers can use, all Non-Officer Members get a different client). And several of the Officers are using it.

I'm guessing that one of their data files may have become corrupted or confused or something and thus thats why its not uploading right and instead wiping the roster.

I've only got a bare minimum roster setup until I can make sure this bugs fixed an won't happen again. After that I'll sort out re-adding the armory, and other addons.
User avatar
Calystos
UA/UU Developer
UA/UU Developer
 
Posts: 140
Joined: Tue Mar 04, 2008 10:57 am
Location: Earth

Re: Roster 2.0 data getting wiped?

Postby Calystos » Wed Aug 27, 2008 4:13 pm

Just a quick update, I wiped the entire roster and database the other day. Then I downloaded both roster 2.0 again from here, and the character and guild profilers from rpgoutfitter.com and put them up on my uniadmin site so that everyone would definitely have those versions and not any others via the uniuploaders auto addon checker thingy. Then I re-installed the fresh roster.

And finally after wiping my profiler files from the WTF area, the cache dir (just to be safe) and then launching wow and re-scanning the entire guild roster, and my character info. I uploaded the freshly made roster list in my characterprofiler.lua file in the WTF area.

This was a few days ago and so far its looking okay and nothings wiped or anything so hopefully its fixed itself. And maybes it was just a corrupt characterprofiler.lua file someone was uploading to the roster site that messed things up, *shrugs* All I know is that the roster site kept getting its data erased for some unknown reason and the guild number that you can see when you go to various areas of the roster pages was changing every day or so instead of staying the same (thus I knew that the roster database was getting wiped).

(Just quickly double checked, and yeah seems okay still, rosters not been wiped or anything today thankfully, so thats at least 3 days without a wipe or anything else bad happening).
User avatar
Calystos
UA/UU Developer
UA/UU Developer
 
Posts: 140
Joined: Tue Mar 04, 2008 10:57 am
Location: Earth

Re: Roster 2.0 data getting wiped?

Postby tuigii » Wed Aug 27, 2008 9:37 pm

Just for checking :

The guys that up their chars and Guild roster data should install
CharacterProfiler
and the
Guildprofiler addon
They should use the Officers roster password.

In case of any doubt, check with them if they have the "red button" both on their char's page and the Guild tab page.
Be carefull, you're in WoW World here, with only two races: those who think that they understood everything, and those who actually do :)
Do, check, check double check.

What I think is that's happening to you is that some Officer is updating with incomplete Guild data. Many of your Guild mates are missing in the uploaded file, so all related info is also deleted.

You could use the member log to see whose being thrown out when.
Needless to say that the guy who did it isn't thrown out :)

In case of any doubt, ask your co-Off's to send you over their CharacterProfiler.lua file - this file can be analyzed rather easy. Use a text editor !
User avatar
tuigii
WR.net Master
WR.net Master
 
Posts: 891
Joined: Wed Dec 27, 2006 12:57 pm
Location: Somewhere in the South Ouest of France

Roster 2.0 data getting wiped?

Postby PleegWat » Wed Aug 27, 2008 9:54 pm

Roster 2.0 won't fully delete someone over this - if someone got removed from the guild like this they should still show up in the realm members view.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: Roster 2.0 data getting wiped?

Postby Calystos » Wed Aug 27, 2008 10:08 pm

tuigii wrote:Just for checking :

The guys that up their chars and Guild roster data should install
CharacterProfiler
and the
Guildprofiler addon
They should use the Officers roster password.

In case of any doubt, check with them if they have the "red button" both on their char's page and the Guild tab page.
Be carefull, you're in WoW World here, with only two races: those who think that they understood everything, and those who actually do :)
Do, check, check double check.

What I think is that's happening to you is that some Officer is updating with incomplete Guild data. Many of your Guild mates are missing in the uploaded file, so all related info is also deleted.

You could use the member log to see whose being thrown out when.
Needless to say that the guy who did it isn't thrown out :)

In case of any doubt, ask your co-Off's to send you over their CharacterProfiler.lua file - this file can be analyzed rather easy. Use a text editor !

True true, its always a good idea to check and double check. And as I said I think its probably just one of the other officers must have either had a corrupt characterprofiler.lua file (since all of my officers have both guildprofiler and characterprofiler and all the guild list is stored within the charaterprofiler.lua file and NOT the guildprofiler.lua) and that must have messed up the roster database when it uploaded.

Either that or 2 or more peoples UniUploaders were autouploading at the same time and the roster site got mixed up that way. Or possibly an upload was in progress and the users connection screwed up and thus the database got messed up that way.

Could be one of several possibilities. However, I am keeping track of who is uploading and when, via the uniadmin site. As well as the roster logs, etc. So if it does happen again I'll hopefully be able to narrow it down to exactly what the cause is. And find a fix, :-) And failing that of course, get the Officers to send me their datafiles to check them over that way.

But thankfully, so far so good, so maybe if it was a corrupted datafile then it looks like its fixed itself hopefully.

We can but wait and see, :-D
User avatar
Calystos
UA/UU Developer
UA/UU Developer
 
Posts: 140
Joined: Tue Mar 04, 2008 10:57 am
Location: Earth


Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 0 guests

cron