v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

A TeamSpeak 2 server monitor addon based on gllcTS2, and Ventrilo server monitor

Moderator: mdeshane

v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

Postby AnthonyB » Mon Sep 07, 2009 1:23 pm

When configured to use teamSpeak, I simply get the following error:

Code: Select all
The addon [guildspeak] has not been installed yet


http://anthonyb.dyndns.org/roster/index ... amp;a=g:17

in the addon config, the TS hompage defaults to index.php - what exactly should this be pathing to? The addon index.php? somewhere else?
Roster 2.0.2 svn [latest] latest trunk SVN svn [latest] running on IIS7/Windows Server 2008 SP2 | MySQL 5.0.85 | PHP 5.2.10 | Yes, Roster and PHP rocks on IIS! Even run as FastCGI extension!
User avatar
AnthonyB
Gimpy Developer
Gimpy Developer
 
Posts: 346
Joined: Tue Jul 04, 2006 2:44 pm
Location: Sydney, Australia

Re: v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

Postby mdeshane » Tue Sep 08, 2009 7:04 pm

I'm not sure why it's saying it's not installed, it seems kind of odd. I'll load up a new install of roster and see if it does the same. And the hompage setting in the TS config is for the image link on the display page. It's just so it goes back to the roster main page if you click on it. I need to modify the config to allow a longer roster link so you can set it for any page in roster.
Image
Accounts Addon - Roster v2 User Account Addon

PKC Dev Site - http://dev.pkcomp.net
My Roster Dev Site - http://myroster.dontexist.net
User avatar
mdeshane
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 203
Joined: Sun Dec 10, 2006 4:54 am
Location: Grand Rapids, MI USA
Realm: Khadgar (PvE) - US

Re: v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

Postby PleegWat » Tue Sep 08, 2009 9:29 pm

Weird. It should only give that error if you haven't installed the addon, and I can't find any codepaths offhand which are breaking that. You didn't add the button manually did you? Or mess with the DB?

Can you give the output of

Code: Select all
select basename from roster_addons
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

Postby AnthonyB » Tue Sep 08, 2009 11:46 pm

Me? mess with anything? Whatever would give you that idea? :)

But no, in the mode of a proper test, I simply coped the addon directory into my roster addons folder, went to the CP -> Addon Management, and clicked install. The Vent stuff is there if I configure it for that but when I change the config to TeamSpeak it just pretends to not be installed...

Output from that SQL query (used 'select basename from roster_addon') is as follows:

'forum'
'GemsDisplay'
'GlyphsDisplay'
'guildbank'
'guildhistory'
'guildinfo'
'info'
'keys'
'memberslist'
'missingrecipes'
'news'
'professions'
'pvplog'
'questlist'
'siggen'
'vault'
'questhistory'
'ItemSets'
'reputation'
'armorysync'
'GroupCalendar'
'Guildspeak'
Roster 2.0.2 svn [latest] latest trunk SVN svn [latest] running on IIS7/Windows Server 2008 SP2 | MySQL 5.0.85 | PHP 5.2.10 | Yes, Roster and PHP rocks on IIS! Even run as FastCGI extension!
User avatar
AnthonyB
Gimpy Developer
Gimpy Developer
 
Posts: 346
Joined: Tue Jul 04, 2006 2:44 pm
Location: Sydney, Australia

Re: v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

Postby PleegWat » Wed Sep 09, 2009 7:41 am

Gotcha. Inconsistent capitalization. The case in the directory name, the case in the url argument, and the case in the addon basename in the install class (and the database) must match, even on a windows server.
I <3 /bin/bash
User avatar
PleegWat
WoWRoster.net Dev Team
WoWRoster.net Dev Team
 
Posts: 1636
Joined: Tue Jul 04, 2006 1:43 pm

Re: v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

Postby mdeshane » Wed Sep 09, 2009 4:10 pm

Pleeg has it figured out! Just deactivate, and uninstall GuildSpeak, change the directory name to guildspeak no capitals and re-install in addon management. Then you should be back in business.
Image
Accounts Addon - Roster v2 User Account Addon

PKC Dev Site - http://dev.pkcomp.net
My Roster Dev Site - http://myroster.dontexist.net
User avatar
mdeshane
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 203
Joined: Sun Dec 10, 2006 4:54 am
Location: Grand Rapids, MI USA
Realm: Khadgar (PvE) - US

Re: v1.9.9.6 [SVN]469 - The addon [guildspeak] has not been inst

Postby AnthonyB » Thu Sep 10, 2009 1:02 pm

Bingo!

Pleeg - well spotted. :)

Weird how the addon partially worked... anyway, problem solved.
Roster 2.0.2 svn [latest] latest trunk SVN svn [latest] running on IIS7/Windows Server 2008 SP2 | MySQL 5.0.85 | PHP 5.2.10 | Yes, Roster and PHP rocks on IIS! Even run as FastCGI extension!
User avatar
AnthonyB
Gimpy Developer
Gimpy Developer
 
Posts: 346
Joined: Tue Jul 04, 2006 2:44 pm
Location: Sydney, Australia


Return to GuildSpeak

Who is online

Users browsing this forum: No registered users and 0 guests

cron