Alt/Stats not working

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

Alt/Stats not working

Postby Manamana » Sat Aug 05, 2006 3:46 pm

http://www.wowfellowship.com/roster/indexalt.php
http://www.wowfellowship.com/roster/indexstat.php


When attempting to view these pages I have no luck---

Any ideas?

I upgraded from 1.6
Manamana
WR.net Apprentice
WR.net Apprentice
 
Posts: 17
Joined: Wed Jul 12, 2006 1:12 am

Alt/Stats not working

Postby zanix » Sat Aug 05, 2006 4:26 pm

Did you run the upgrade script?

roster/upgrade.php
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Alt/Stats not working

Postby Manamana » Sat Aug 05, 2006 10:37 pm

Yes I did---and no error messages were shown during the update...

Is there an SQL statement that I can run post that will go in and modify those tables again?

Coincidentally, I cannot upload character data with those tables being in the format they are in
Manamana
WR.net Apprentice
WR.net Apprentice
 
Posts: 17
Joined: Wed Jul 12, 2006 1:12 am

Alt/Stats not working

Postby zanix » Sun Aug 06, 2006 1:24 am

Can you post the structure of your players tabe for me?
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Alt/Stats not working

Postby Manamana » Sun Aug 06, 2006 10:52 pm

Sure, thanks in advance:

Code: Select all
-- phpMyAdmin SQL Dump
-- version 2.7.0-pl2
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Aug 06, 2006 at 10:50 AM
-- Server version: 4.0.16
-- PHP Version: 4.4.1
--
-- Database: `XXXXXXXXXX`
--

-- --------------------------------------------------------

--
-- Table structure for table `roster_players`
--

CREATE TABLE `roster_players` (
  `member_id` int(11) unsigned NOT NULL default '0',
  `name` varchar(64) NOT NULL default '',
  `guild_id` int(11) unsigned NOT NULL default '0',
  `dateupdatedutc` varchar(18) default NULL,
  `CPversion` varchar(6) default NULL,
  `stat_int` varchar(32) NOT NULL default '',
  `stat_agl` varchar(32) NOT NULL default '',
  `stat_sta` varchar(32) NOT NULL default '',
  `stat_str` varchar(32) NOT NULL default '',
  `stat_spr` varchar(32) NOT NULL default '',
  `race` varchar(32) NOT NULL default '',
  `sex` varchar(10) NOT NULL default '',
  `hearth` varchar(32) NOT NULL default '',
  `res_frost` int(11) NOT NULL default '0',
  `res_arcane` int(11) NOT NULL default '0',
  `res_fire` int(11) NOT NULL default '0',
  `res_shadow` int(11) NOT NULL default '0',
  `res_nature` int(11) NOT NULL default '0',
  `armor` varchar(32) NOT NULL default '',
  `level` int(11) NOT NULL default '0',
  `server` varchar(32) NOT NULL default '',
  `defense` int(11) NOT NULL default '0',
  `talent_points` int(11) NOT NULL default '0',
  `money_c` int(11) NOT NULL default '0',
  `money_s` int(11) NOT NULL default '0',
  `money_g` int(11) NOT NULL default '0',
  `exp` varchar(32) NOT NULL default '',
  `class` varchar(32) NOT NULL default '',
  `health` int(11) NOT NULL default '0',
  `maildateutc` datetime default NULL,
  `melee_power` int(11) default NULL,
  `melee_rating` int(11) default NULL,
  `melee_range` varchar(16) default NULL,
  `melee_range_tooltip` tinytext,
  `melee_power_tooltip` tinytext,
  `ranged_power` int(11) default NULL,
  `ranged_rating` int(11) default NULL,
  `ranged_range` varchar(16) default NULL,
  `ranged_range_tooltip` tinytext,
  `ranged_power_tooltip` tinytext,
  `version` varchar(16) default NULL,
  `mana` int(11) NOT NULL default '0',
  `stat_int2` int(11) unsigned NOT NULL default '0',
  `stat_agl2` int(11) unsigned NOT NULL default '0',
  `stat_sta2` int(11) unsigned NOT NULL default '0',
  `stat_str2` int(11) unsigned NOT NULL default '0',
  `stat_spr2` int(11) unsigned NOT NULL default '0',
  `stat_total` int(11) NOT NULL default '0',
  `pvp_ratio` float NOT NULL default '0',
  `sessionHK` int(11) NOT NULL default '0',
  `sessionDK` int(11) NOT NULL default '0',
  `yesterdayHK` int(11) NOT NULL default '0',
  `yesterdayDK` int(11) NOT NULL default '0',
  `yesterdayContribution` int(11) NOT NULL default '0',
  `lastweekHK` int(11) NOT NULL default '0',
  `lastweekDK` int(11) NOT NULL default '0',
  `lastweekContribution` int(11) NOT NULL default '0',
  `lastweekRank` int(11) NOT NULL default '0',
  `lifetimeHK` int(11) NOT NULL default '0',
  `lifetimeDK` int(11) NOT NULL default '0',
  `lifetimeRankName` varchar(64) NOT NULL default '0',
  `Rankexp` int(11) NOT NULL default '0',
  `TWContribution` int(11) NOT NULL default '0',
  `TWHK` int(11) NOT NULL default '0',
  `dodge` float NOT NULL default '0',
  `parry` float NOT NULL default '0',
  `block` float NOT NULL default '0',
  `mitigation` float NOT NULL default '0',
  `crit` float NOT NULL default '0',
  `lifetimeHighestRank` int(11) NOT NULL default '0',
  `RankInfo` int(11) NOT NULL default '0',
  `RankName` varchar(64) NOT NULL default '',
  `RankIcon` varchar(64) NOT NULL default '',
  `clientLocale` varchar(4) NOT NULL default '',
  `timeplayed` int(11) NOT NULL default '0',
  `timelevelplayed` int(11) NOT NULL default '0',
  `max_res_all` int(11) default NULL,
  `max_res_fire` int(11) default NULL,
  `max_res_nat` int(11) default NULL,
  `max_res_arc` int(11) default NULL,
  `max_res_fro` int(11) default NULL,
  `max_res_shad` int(11) default NULL,
  PRIMARY KEY  (`member_id`),
  KEY `name` (`name`,`server`)
) TYPE=MyISAM;
Last edited by Manamana on Sun Aug 06, 2006 10:52 pm, edited 1 time in total.
Manamana
WR.net Apprentice
WR.net Apprentice
 
Posts: 17
Joined: Wed Jul 12, 2006 1:12 am

Alt/Stats not working

Postby zanix » Mon Aug 07, 2006 3:11 am

I'm not sure why, but the upgrade script didnt upgrade your sql tables...

Open install/db/upgrade_160.sql
Those are the upgrade SQL queries

You could run it, but all your current resists and int, str, sta, armor, etc wiil all be gone


Do you have a backup of your roster db before the upgrade?
Last edited by zanix on Mon Aug 07, 2006 3:11 am, edited 1 time in total.
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Alt/Stats not working

Postby Manamana » Tue Aug 08, 2006 1:18 am

I did----and hopefully correctly

I did a fresh install, lost all data, will just ask members to reinstall their data :)

Thanks!
Last edited by Manamana on Tue Aug 08, 2006 3:03 am, edited 3 times in total.
Manamana
WR.net Apprentice
WR.net Apprentice
 
Posts: 17
Joined: Wed Jul 12, 2006 1:12 am

Alt/Stats not working

Postby zanix » Tue Aug 08, 2006 4:47 am

Sorry it couldn't be saved
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Alt/Stats not working

Postby reist » Thu Sep 28, 2006 5:26 pm

i get this error too ... i have problem with DB user ... havnt alter permisions.
reist
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Wed Sep 27, 2006 8:38 pm


Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 0 guests

cron